Our new Indie Games subforum is now open for business in G&T. Go and check it out, you might land a code for a free game. If you're developing an indie game and want to post about it, follow these directions. If you don't, he'll break your legs! Hahaha! Seriously though.
Our rules have been updated and given their own forum. Go and look at them! They are nice, and there may be new ones that you didn't know about! Hooray for rules! Hooray for The System! Hooray for Conforming!

FL Studio MIDI assistance

mooshoeporkmooshoepork Registered User regular
edited June 2010 in Help / Advice Forum
Hey, this is really annoying me. I can't seem to get my midi working with FL studio.

I've got a Yamaha P85 as a midi controller, an Edirol UA25 preamp and FL studio.

I have a midi out from the p85 into the midi in on my preamp, which is then plugged in via USB to my laptop.

In FL studio it won't show up as an input under controllers. Any ideas?

mooshoepork on

Posts

  • EggyToastEggyToast Registered User regular
    edited June 2010
    Have you tried swapping the in/out cables? I don't mean the physical cables, but the inputs.

    However I'm pretty sure the P85 won't show up as a controller itself, because it's connected via midi. You'd need to simply select the midi port from your preamp as the Midi IN and then it should work.

    || Flickr — || PSN: EggyToast
  • OverlordOverlord Registered User regular
    edited June 2010
    Do you have the most recent drivers updated? Also, I know with mine if you don't have the input device plugged in before you start FL it won't recognize it.

    sigsh.gif
  • krushkrush Registered User regular
    edited June 2010
    Hey, this is really annoying me. I can't seem to get my midi working with FL studio.

    I've got a Yamaha P85 as a midi controller, an Edirol UA25 preamp and FL studio.

    I have a midi out from the p85 into the midi in on my preamp, which is then plugged in via USB to my laptop.

    In FL studio it won't show up as an input under controllers. Any ideas?

    Make sure you have the latest drivers installed for the Edirol unit and have it connected prior to launching FL Studio.

    In FL Studio, click Options > MIDI settings. Under Input, you should see the Edirol device. Highlight it and click the Enable button.

  • mooshoeporkmooshoepork Registered User regular
    edited June 2010
    Thanks guys. Wasn't working so I reinstalled the drivers, rebooted then it showed up.

    Then all my patches sounded out of tune. Turns out my sample rate wasn't the same and that was messing it up.

    Now it's all perfect! Thanks guys

Sign In or Register to comment.