Don't like the snow? You can make a bookmark with the following text instead of a url: javascript:snowStorm.toggleSnow(). Clicking it will toggle the snow on and off.
Our new Indie Games subforum is now open for business in G&T. Go and check it out, you might land a code for a free game. If you're developing an indie game and want to post about it, follow these directions. If you don't, he'll break your legs! Hahaha! Seriously though.
Our rules have been updated and given their own forum. Go and look at them! They are nice, and there may be new ones that you didn't know about! Hooray for rules! Hooray for The System! Hooray for Conforming!

weird keyboard issue

tallgeezetallgeeze Registered User regular
edited August 2010 in Help / Advice Forum
Hope you can help me out H/A.

I'm an avid WoW player and as such I have a hotkeys for a lot of stuff I do in the game. About a week ago I noticed that whenever I tried moving using Q, W, or E my numbpad 9 key wouldn't work when pressed. Eventually, I tried doing it in Notepad to see if it was my PC and not just WoW. Turns out it's my PC

I guess an example would be best to explain this problem. If I press and hold W it will repeat until I pressed another key to interrupt the chain. (Ex: wwwwwwwwww8wwwwww8). However, when I press and hold Q, W, or E then try to use numpad 9 it doesn't get recognized.

Hopefully, someone out there has run into a similar problem because I can't figure it out.

tallgeeze on

Posts

  • bigbhbigbh Registered User regular
    edited August 2010
    There are keyboards out there specifically designed so that you can pull off almost any key combination but they're definitely not common. 99% of keyboards you encounter are going to have some sort of restrictions to which keys you can press at the same time.

  • matt has a problemmatt has a problem Six pack on a dick Registered User regular
    edited August 2010
    If you're just using some kind of stock Dell/HP/IBM etc. keyboard, there are limits on how many keys you can press simultaneously. Higher end keyboards, the Logitech G series, Saitek Eclipse/Cyborg series, are designed for more simultaneous key presses.

    h1DI1.jpg
    All my fuckin life I lived a normal fuckin life
  • tallgeezetallgeeze Registered User regular
    edited August 2010
    But why would it limit it now? I've been using the the same PC for the past 2 years and it never had this problem until a couple of weeks ago.

    At max I'm pressing 2-3 buttons at the same time. I can do it with any other combo of keys, but when Q W E get involved I get nada.

  • matt has a problemmatt has a problem Six pack on a dick Registered User regular
    edited August 2010
    I know I've had a keyboard go partially bad after having something spilled on it, the left 1/4 of the board, qwe, asd, zxc, `123 all wouldn't work at all, but the rest of the board would. Maybe there's something about using multiple keys in a certain area?

    h1DI1.jpg
    All my fuckin life I lived a normal fuckin life
  • GR_ZombieGR_Zombie Registered User regular
    edited August 2010
    Not to hijack or anything, but I'm having a similar problem to the OP, except my keyboard is working fine outside my games, but not working in them. In Warcraft 3 I press the arrow keys to move the camera, and it treats a single press as if I'm holding the key down. In some of my other games, WASD either flat-out don't work or just inches me forward. I switched keyboards assuming it was a hardware issue, and I'm getting the same problem.

    edit: Fixed my problem, turns out it was a piece of key macro software I had installed that was messing up my inputs for some reason.

    fp4hy8vbapia.jpeg
  • ronyaronya Arrrrrrf. the ivory tower's basementRegistered User regular
    edited August 2010
    @GR_Zombie, go to Ease of Access center and see if you've turned on mousekeys, stickykeys, or filterkeys. By default these come with keyboard shortcuts so sometimes people turn them on by accident and never realize.

  • mightyjongyomightyjongyo Registered User regular
    edited August 2010
    OP: try cleaning your keyboard. Hold it upside down and give it a good shake, or blast it with some air. If it's happening now, then your keyboard just may also be getting old and slowly breaking.

Sign In or Register to comment.