Our new Indie Games subforum is now open for business in G&T. Go and check it out, you might land a code for a free game. If you're developing an indie game and want to post about it, follow these directions. If you don't, he'll break your legs! Hahaha! Seriously though.
Our rules have been updated and given their own forum. Go and look at them! They are nice, and there may be new ones that you didn't know about! Hooray for rules! Hooray for The System! Hooray for Conforming!

Computer takes an excessively long time to shut down [SOLVED]

ReznikReznik Registered User regular
edited February 2011 in Help / Advice Forum
Background: My computer recently had a run-in with a virus that left it unable to boot properly. Being as that is a bit above my pay grade when it comes to fixing computers, I brought it in to get fixed up at the place where I had it put together. They said the Master Boot Record got borked (but, you know, in more intelligent terms than that) but they fixed it up and everything was good to go.

Problem: So my computer starts up fine, and I notice no issues when actually running it. However, when I go to shut it down from the start menu it takes anywhere from 2 to 5 minutes for the Restart/Stand By/Shut Down window to pop up. In the mean time the computer basically acts like explorer has frozen. After the window shows up, though, it seems to shut down as normal but still slower than it did before the problem.

If I hit the power button instead of going through the start menu then it starts shutting down as normal (everything closes, desktop goes away, it goes to the 'saving your settings/windows is shutting down' screen). However it seems to sit on that shut down screen for like... 5 minutes. Basically it's not any faster than if I try shutting down the first way.

So... Any ideas what the problem is and how I can fix it?

Specs: Windows XP sp3, 2.31 GHz AMD Phenom X3, 4 GB RAM (well, 3 that XP can recognize anyway).

Reznik on

Posts

  • jclastjclast Registered User regular
    edited February 2011
    It sounds like something still is running that shouldn't be. I'd back up what you don't want to lose and start with a fresh OS install.

    steam_sig.png
  • MeizMeiz Registered User regular
    edited February 2011
    Eh, a fresh OS install may well resolve the issue but it's probably some piece of software that's running and is taking its sweet time to shut down.

    From what I understand it's when you actually chose the "shut down" option and not when you're navigating in the start menus that the slowdown occurs?

    Might want to try going by process of elimination in terms of software by going to start -> run : msconfig.

    Under the startup tab, that will show you what runs on bootup. I wouldn't recommend unchecking anything in there haphazardly though as it could have some undesired effects.

    Could try going to the task manager by doing ctrl+alt+del, killing a process showing under your name, trying to get the shut down window up and repeating.

    I ran a google search for other avenues:
    http://www.windowsnetworking.com/articles_tutorials/Troubleshooting-Windows-Shutdown.html

    This one seems more specific to your case however:
    http://superuser.com/questions/7557/why-does-my-xp-take-forever-to-show-the-shutdown-window

  • RuckusRuckus Registered User regular
    edited February 2011
    You could also try running 'shutdown -s -f -t 00' at a command line.

    The breakdown:
    shutdown = pretty self-explanatory command
    -s = shutdown type is shutdown (as opposed to -r for restart)
    -f = force running apps to close without warning
    -t 00 = initiate the shutdown in this amount of time, in seconds, or 0 seconds in this case.

    If it shuts down in a normal amount of time, this would definitely indicate that there's an app of some sort delaying the normal shutdown process.

    Raneados wrote: »
    so what SPECIFICALLY is the problem with my hole?
  • bustin98bustin98 Registered User
    edited February 2011
    Some viruses have begun installing themselves as drivers. This keeps them under the radar, similar to rootkits.

    Start Windows in safe mode -

    hit F5 a number of times just after booting up but BEFORE you see the Windows logo
    (for me F5 and F8 bring up the menu for choosing Safe Mode, but F5 starts with Safe Mode highlighted, and F8 has Start Windows Normally highlighted.)

    - and then run through the shut down process. If its faster, you could narrow it down to either a bad driver or a bad device. Go into Device Manager -

    Right click on My Computer -> Properties -> Hardware tab -> Device Manager

    - start disabling things like the video, sound, network, modem (??). Restart after each one then restart again to see if the boot speed is affected.

    OR

    It could be as easy as looking in the Event Log. Dr Watson may be writing an entry with each shutdown.

    Start Menu -> All Programs -> Administrative Tools -> Event Viewer

    There are a number of categories. Look through each one and read entries with exclamation points.

    Xbox Live, PSN, Twitter: bustin98
  • TofystedethTofystedeth veni, veneri, vamoosi Registered User regular
    edited February 2011
    It's F8 for safemode.

    steam_sig.png
  • Gilbert0Gilbert0 VictoriaRegistered User regular
    edited February 2011
    Can try this from Microsoft:

    http://support.microsoft.com/kb/837115

    "You experience log off problems on a Windows XP-based, Windows Server 2003-based, Windows 2000-based, or Windows NT 4.0-based computer"

  • ReznikReznik Registered User regular
    edited February 2011
    The problem seems to be solved. I went through Meiz's first link and disabled Terminal Services and that seems to have done the trick.

    Thank you everyone for your help. I'm going to copy this stuff for future reference.

Sign In or Register to comment.