Our new Indie Games subforum is now open for business in G&T. Go and check it out, you might land a code for a free game. If you're developing an indie game and want to post about it, follow these directions. If you don't, he'll break your legs! Hahaha! Seriously though.
Our rules have been updated and given their own forum. Go and look at them! They are nice, and there may be new ones that you didn't know about! Hooray for rules! Hooray for The System! Hooray for Conforming!

Source engine games performing poorly

Cannon GooseCannon Goose Registered User regular
First of all, here are my system specs:
2008 era Intel iMac running Windows 7 Home Premium 32 bit via Boot Camp
2.16GHz dual core Intel processor
2.5GB RAM
Nvidia 7300 GT 128MB graphics card

I had always been able to run Source games (Counter-strike: Source, Half-life 2 and Episode One, etc.) very well with everything except anti-aliasing cranked up to the maximum. But when the Orange Box came out I was very disappointed to find that all the games in that package ran poorly on my system.

Each title (Portal, Team Fortress 2, HL2: Episode Two) all gave me roughly 30fps that would dip wildly. Compare this to older Source engine games where I would get very high consistent framerates. The peculiar thing is that I experimented a lot with the graphics settings and even with everything turned down I would still get this jittery almost 30 framerate. I seem to recall having to force the games to run in direct X 7 or 8 just to maintain a good framerate. This also made the games look ugly as sin though, so I'd rather find a different solution.

Now, after a long break from PC gaming, I've returned to find all my older Source games have also had the Orange Box features added to them resulting in poor framerates across the board.

Has anyone else experienced this problem?

Cannon Goose on

Posts

  • AzioAzio Registered User regular
    edited April 2011
    I don't think there's much you can do about that. You'll get a solid performance boost by running the games in Boot Camp, but otherwise you'll have to either turn down the graphics or buy a new computer.

    Adding some RAM, or running a 64bit OS might help.

  • tsmvengytsmvengy Registered User regular
    edited April 2011
    Do you use AVG antivirus? That has caused some serious headaches for people.

    steam_sig.png
  • Cannon GooseCannon Goose Registered User regular
    edited April 2011
    I'm already running Windows through Boot Camp and unfortunately this model of iMac can't have 64 bit Windows installed on it for whatever reason.

    I'm using Microsoft Security Essentials. I too have had trouble in the past with AVG.

  • kleinfehnkleinfehn Registered User
    edited April 2011
    That graphics card has a very low amount of RAM, and if your resolution is too high then your FPS will plummet. I would upgrade that if possible, otherwise there isn't anything you can do.

    For Dx8 mode right click the game and select properties and add "-dxlevel 80" without the quotes.

  • Cannon GooseCannon Goose Registered User regular
    edited April 2011
    This is ridiculous, even in DirectX 8 with everything turned down at 720x480 (the lowest) resolution I STILL get an unstable 30fps. If I turn it up to 1280x800 (half my native res, what I usually play all games at if possible) and crank up the settings the framerate stays at the unstable 30fps...

    I've got the latest graphics drivers, so I'm not really sure what else I can do. About a year ago changing to DirectX 8 gave me acceptable performance in all the games I was having trouble with.

    I've never had this problem with any other game. I was playing Stalker: Shadow of Chernobyl just fine today with zero problems.

  • LaCabraLaCabra Registered User regular
    edited April 2011
    There were a lot of changes to the engine with Source 2007. One of the major ones is that textures are on average twice as large, sometimes more, than in previous games, which is one area where your 128MB on the (fairly low-end) card is going to be a problem.

    Back when I had a 128MB card, I was having a similar problem to you on TF2 (same engine version as every other orange box game). I emailed Josh Weier from Valve about it and got this back:
    As we've updated the Source engine, our demands on the memory of the video card have increased. 128mb is now on the lower end of our scale and causes us to diminsh the texture quality to compensate. The bug you were most likely seeing was that your video card was running low on memory, which can cause considerable performance loss. This is why -autoconfig lowers your texture resolution by default. You can try to increase it, but Direct3D can sporadically fail in low memory situations caused by allocating textures which are too large. Unforuntately, to enjoy hi-res textures in the Orange Box titles, you may need to upgrade your video card to one with higher video memory capacity.

    Hope that helps. See you in TF2; I'll be the pyro running right for you!

    One way to help determine if there's something else going wrong would be to play HL2 now, and see how your performance is. HL2 has fairly recently been updated to Source 2007 from the version it shipped with. If HL2 still runs smoothly, the problem is coming from the increased demands of the Orange Box games. If it doesn't, the cause is specific to that version of the engine. Either way there's not a lot you can do about it besides the measures you've already found work (lower dxlevel).

    Also, tried disabling HDR? Just a thought.


    edit: Also, just a point on how you've been playing Stalker just fine: I'm sure you've been playing that without Full Dynamic Lighting on, or you'd be lagging terribly. That means it's forcing DX8, which is consistent with your performance gain forcing Source 2007 down to 8.

    Blog | Impromptu Games | twitter

    totally buy my video game InFlux on Steam or Humble Store or GOG or Amazon!
  • DrunkMcDrunkMc Registered User regular
    edited April 2011
    People here seem knowledgeble about Steam + Source, so I'm going to piggy back on this thread a bit. I asked this in the Portal 2 thread, but people are just spamming how great it is and I got no answers and have come a little to close to getting Spoilers. So,

    Whenever I try to load Portal 2, it gets past the valve loading screen and gets to where I think the menu is going to load. It then crashes to the desktop where a balloon from the task bar tells me Window's DEP (Data Execution Prevention) prevented me from executing Portal 2.

    I have tried:

    Adding Steam.exe to DEP's exclusion list, and when I try to add Portal2 it tells me Portal2 can not be run without DEP, and won't add it to the list.

    I have also tried setting Portal 2 to run in Windows XP Sp2 compatibility mode, and running as administrator. I still crash to the desktop because of DEP.

    This is all on Vista 32-bit. I have a ticket in Steam for this, but guessing by the amount of people saying Portal 2 is crashing on load, it could take a while. There's a few people on the Steam Forums with the same exact problem, but no luck there yet finding a solution. Was wondering if anyone had ideas here?

  • AzioAzio Registered User regular
    edited April 2011
    This is ridiculous, even in DirectX 8 with everything turned down at 720x480 (the lowest) resolution I STILL get an unstable 30fps. If I turn it up to 1280x800 (half my native res, what I usually play all games at if possible) and crank up the settings the framerate stays at the unstable 30fps...

    I've got the latest graphics drivers, so I'm not really sure what else I can do. About a year ago changing to DirectX 8 gave me acceptable performance in all the games I was having trouble with.

    I've never had this problem with any other game. I was playing Stalker: Shadow of Chernobyl just fine today with zero problems.

    When was the last time you reinstalled Windows

  • LaCabraLaCabra Registered User regular
    edited April 2011
    Can you turn DEP off entirely? I forget.

    Blog | Impromptu Games | twitter

    totally buy my video game InFlux on Steam or Humble Store or GOG or Amazon!
  • Cannon GooseCannon Goose Registered User regular
    edited April 2011
    Azio wrote: »
    This is ridiculous, even in DirectX 8 with everything turned down at 720x480 (the lowest) resolution I STILL get an unstable 30fps. If I turn it up to 1280x800 (half my native res, what I usually play all games at if possible) and crank up the settings the framerate stays at the unstable 30fps...

    I've got the latest graphics drivers, so I'm not really sure what else I can do. About a year ago changing to DirectX 8 gave me acceptable performance in all the games I was having trouble with.

    I've never had this problem with any other game. I was playing Stalker: Shadow of Chernobyl just fine today with zero problems.

    When was the last time you reinstalled Windows

    I just did a completely clean install of Windows 7 about three days ago.
    LaCabra wrote:
    One way to help determine if there's something else going wrong would be to play HL2 now, and see how your performance is. HL2 has fairly recently been updated to Source 2007 from the version it shipped with. If HL2 still runs smoothly, the problem is coming from the increased demands of the Orange Box games. If it doesn't, the cause is specific to that version of the engine. Either way there's not a lot you can do about it besides the measures you've already found work (lower dxlevel).

    Also, tried disabling HDR? Just a thought.

    edit: Also, just a point on how you've been playing Stalker just fine: I'm sure you've been playing that without Full Dynamic Lighting on, or you'd be lagging terribly. That means it's forcing DX8, which is consistent with your performance gain forcing Source 2007 down to 8.

    Yes, Stalker is running in DX8 mode but all my Source games have not been getting a performance increase from running in DX8. Half-life 2, Counter-strike Source and Episode Two all get chuggy performance no matter what settings I use.

  • LaCabraLaCabra Registered User regular
    edited April 2011
    Oh, I was going off of
    I seem to recall having to force the games to run in direct X 7 or 8 just to maintain a good framerate.

    In any case, all those games are Source 2007 now. Seems like the changes they made make it a bit too much for your laptop. It does seem weird that you'd see no performance gains from lowering the dxlevel though.

    Blog | Impromptu Games | twitter

    totally buy my video game InFlux on Steam or Humble Store or GOG or Amazon!
  • kleinfehnkleinfehn Registered User
    edited April 2011
    I think your only solution here is to get a new computer. Sorry mang, but that's how it works with laptops.

  • Cannon GooseCannon Goose Registered User regular
    edited April 2011
    It's an iMac, but yes, what you said still applies.

    Thanks for the insight, guys.

  • DrunkMcDrunkMc Registered User regular
    edited April 2011
    LaCabra wrote: »
    Can you turn DEP off entirely? I forget.

    I couldn't find a way to turn DEP off entirely. There's allegedy "hax" to do it, but I didn't want to risk it. Luckily someone on the Steam Forums found a work-around. Incase anyone else runs into it:

    Set Portal2.exe to run in Windows XP SP2 Comp mode.
    Set to run as Administrator.
    THEN
    through Steam verify your files. For some reason doing that makes Steam re-download certain files, and then it worked.

  • AzioAzio Registered User regular
    edited April 2011
    Azio wrote: »
    This is ridiculous, even in DirectX 8 with everything turned down at 720x480 (the lowest) resolution I STILL get an unstable 30fps. If I turn it up to 1280x800 (half my native res, what I usually play all games at if possible) and crank up the settings the framerate stays at the unstable 30fps...

    I've got the latest graphics drivers, so I'm not really sure what else I can do. About a year ago changing to DirectX 8 gave me acceptable performance in all the games I was having trouble with.

    I've never had this problem with any other game. I was playing Stalker: Shadow of Chernobyl just fine today with zero problems.

    When was the last time you reinstalled Windows

    I just did a completely clean install of Windows 7 about three days ago.

    Oh, another thing, when you say you have the latest drivers, do you mean the latest one from Nvidia, or from Boot Camp? Boot Camp's graphics drivers are useless.

  • Cannon GooseCannon Goose Registered User regular
    edited April 2011
    Yeah, I made sure to get the Nvidia drivers as soon as I had Windows set up.

  • EffefEffef Who said your opinion mattered, Jones? Registered User regular
    edited April 2011
    Your graphics card is your problem. Source 2007 and even more recently with the release of Portal 2 Source has put increasing demands on the graphics hardware. A 7300GT 128mb just isn't enough anymore.

    ox30LTf.gif
Sign In or Register to comment.