Our new Indie Games subforum is now open for business in G&T. Go and check it out, you might land a code for a free game. If you're developing an indie game and want to post about it, follow these directions. If you don't, he'll break your legs! Hahaha! Seriously though.
Our rules have been updated and given their own forum. Go and look at them! They are nice, and there may be new ones that you didn't know about! Hooray for rules! Hooray for The System! Hooray for Conforming!

Computer wont autosleep

emp123emp123 Registered User regular
edited October 2011 in Help / Advice Forum
I leave my computer on over night as I use it as an alarm to wake me up in the morning and Im trying to get it to go to sleep when its not in use for more than an hour. It will shut off the display after 10 minutes, but it wont go to sleep. Ive done some googling and Ive seen suggested that turning off some wake from sleep options is the best course of action but I dont want to do this as I have a scheduled task set to run right before the computer is supposed to wake me up.

Im running Windows 7 Pro x64 (fully updated).

Ive tried turning off my mouse, unplugging my microphone, changing the sleep conditions but nothing will get it to go to sleep.

camo_sig2.png

Posts

  • DraygoDraygo Registered User regular
    Will it manually go to sleep?

  • emp123emp123 Registered User regular
    Yeah, I probably should have mentioned that, but yes it will go to sleep when I tell it to.

    camo_sig2.png
  • kimekime Queen of Blades Registered User regular
    Just to make sure, you've changed the power options of "Change when the computer goes to sleep" for plugged in, right?

    3DS Friend Code: 3110-5393-4113
    Stream - Offline
    Battle.net ID: kime#1822
  • emp123emp123 Registered User regular
    Im on a desktop so maybe thats why, but I dont see a "plugged in" setting.

    camo_sig2.png
  • DrowsDrows Registered User regular
    My computer doesn't autosleep if steam or pandora are connected

  • kimekime Queen of Blades Registered User regular
    emp123 wrote: »
    Im on a desktop so maybe thats why, but I dont see a "plugged in" setting.

    That would be why, yeah. My bad, shouldn't have assumed it was a laptop haha.

    A quick google search showed this. In particular, this post has a couple solutions perhaps?
    Spoiler:

    It says to check the Task Scheduler and see if any errors pop up automatically. I assume none do, since you've probably been to that frequently trying to figure this out, but that's worth a try.

    The second option is to reinstall/repair the OS while keeping all your programs/files. I'd probably wait on that till you try other things, don't want to make a mistake and lose everything

    3DS Friend Code: 3110-5393-4113
    Stream - Offline
    Battle.net ID: kime#1822
  • emp123emp123 Registered User regular
    Yeah, no errors pop up in the task scheduler and I doubt a reinstall of the OS is necessary.

    I do keep Steam running though.

    camo_sig2.png
  • AdusAdus Registered User regular
    Go to your Advanced Power Options settings and click down all the + boxes, and make sure every option that has the choice "Allow the computer to sleep" is selected, like Multimedia Settings - When Sharing Media.

  • emp123emp123 Registered User regular
    Will that allow it to sleep while Im watching a video, or will that only allow it to sleep if Im streaming a video to another computer?

    camo_sig2.png
  • AdusAdus Registered User regular
    That was just an example, but if you didn't have that option selected for that, then the computer would never sleep while you have media sharing enabled. Not necessarily actively streaming something, but just having the option on.

    You said you can manually put it to sleep so that particular one probably isn't the issue, but check the list.

  • emp123emp123 Registered User regular
    I switched the multimedia setting to "Allow computer to sleep" and I exited Steam, but the computer still didnt sleep.

    I looked through the power options and nothing looks like it should be keeping it awake (theres some stuff about CPU and PCI power usage, but I didnt see any sleep settings).

    I guess I'll have to remember to manually put it to sleep.

    camo_sig2.png
  • emp123emp123 Registered User regular
    Okay, so I think my computer likes to sleep now except it will only sleep if the task I have set up in the Task Scheduler hasnt run yet. Im not entirely sure why this is.

    camo_sig2.png
Sign In or Register to comment.