Our new Indie Games subforum is now open for business in G&T. Go and check it out, you might land a code for a free game. If you're developing an indie game and want to post about it, follow these directions. If you don't, he'll break your legs! Hahaha! Seriously though.
Our rules have been updated and given their own forum. Go and look at them! They are nice, and there may be new ones that you didn't know about! Hooray for rules! Hooray for The System! Hooray for Conforming!

Network login

RohanRohan Registered User regular
edited April 2009 in Help / Advice Forum
We have a number of pc's in the apartment, all hooked up to a Netgear DG834G router. Three desktops, two using Vista and one using 7. Two laptops, one XP and one Vista. The second desktop is the media pc, and everyone on the network can connect to it with no problems. The reason I mention this is because on my desktop and my laptop, both using Vista, I cannot connect to them from any other machine. Some network login screen appears, asking for a user name and passwords. I have disabled password protected sharing on both. File sharing, public folder sharing and network discovery are enabled on both. They both, in fact, have the exact same network setup as the media pc. There is no password assigned to the only user on both machines.

So why do they insist on a user login and the media pc does not? And how can I get rid of the damn thing? Oh for the days of XP networking when things looked difficult but worked when they said they would. Now we have Vista and 7 making it look easy and fucking it all up :|

Rohan on
...and I thought of how all those people died, and what a good death that is. That nobody can blame you for it, because everyone else died along with you, and it is the fault of none, save those who did the killing.

Nothing's forgotten, nothing is ever forgotten

Posts

  • AdusAdus Registered User regular
    edited April 2009
    I believe there's a security audit that prevents logging onto computers over the network with a blank password. Obviously it can be disabled, but have you tried just making a new account with a password in order just to see if it lets you log onto that account?

  • RohanRohan Registered User regular
    edited April 2009
    But I don't want to have to do that, and when friends arrive with their pc's next week for a lan I don't want to have to give them a user name and password just to access the folder on my desktop called "Network files" - generally filled with games patches, mods and the like. I just want to remove the thing so it can be as it is with the media pc - double-click on the name, et voila! All shared folders viewable and accessible.

    ...and I thought of how all those people died, and what a good death that is. That nobody can blame you for it, because everyone else died along with you, and it is the fault of none, save those who did the killing.

    Nothing's forgotten, nothing is ever forgotten
  • ascannerlightlyascannerlightly Registered User
    edited April 2009
    Rohan wrote: »
    Oh for the days of XP networking when things looked difficult but worked when they said they would. Now we have Vista and 7 making it look easy and fucking it all up :|
    (what should be) simple functionality bullshit like this is why everyone clung to xp for so long in the first place (and why some of us still do).

    i guess it's the wording that's throwing me off, but which machine(s) are you having this trouble connecting to from which machine(s)? need a flow chart or something...

    armedroberty.jpg
  • KrikeeKrikee Registered User
    edited April 2009
    Make sure 'Everyone' has read & list access on the folder. I've had a few machines at the house mess up the permissions on network shares for some unknown reason.

  • RohanRohan Registered User regular
    edited April 2009
    Rohan wrote: »
    Oh for the days of XP networking when things looked difficult but worked when they said they would. Now we have Vista and 7 making it look easy and fucking it all up :|
    (what should be) simple functionality bullshit like this is why everyone clung to xp for so long in the first place (and why some of us still do).

    i guess it's the wording that's throwing me off, but which machine(s) are you having this trouble connecting to from which machine(s)? need a flow chart or something...

    Two Vista machines, a desktop and a laptop. Whenever I try to access either of these machines with another, they give me the log-in window. But there's another desktop in the apartment that uses Vista (the media pc) with the same network settings, and no log-in screen comes up... when I double-click on my desktop or laptop in the network view of another computer, a window pops up asking for a user name and password. When I double-click on the media pc in the same network view, it immediately opens up to show all the shared folders, which are accessed with no problems.
    Krikee wrote:
    Make sure 'Everyone' has read & list access on the folder. I've had a few machines at the house mess up the permissions on network shares for some unknown reason.

    I've added "Guest" as a co-owner on a shared folder. I did this with the media pc and it works just fine, but no go on my laptop or desktop.

    ...and I thought of how all those people died, and what a good death that is. That nobody can blame you for it, because everyone else died along with you, and it is the fault of none, save those who did the killing.

    Nothing's forgotten, nothing is ever forgotten
  • CronusCronus Registered User regular
    edited April 2009
    Rohan wrote: »
    *snip*
    Krikee wrote:
    Make sure 'Everyone' has read & list access on the folder. I've had a few machines at the house mess up the permissions on network shares for some unknown reason.

    I've added "Guest" as a co-owner on a shared folder. I did this with the media pc and it works just fine, but no go on my laptop or desktop.

    Everyone is a valid parameter for both the sharing and permissions tabs. Unfortunately there is no option to add everyone and sometimes it isn't there. However if you type "Everyone" into the box it will accept it and allow any computer on the network whatever access to that folder you have permitted Everyone in the security/permissions tab for that folder.

    camo_sig.png
    "Read twice, post once. It's almost like 'measure twice, cut once' only with reading." - MetaverseNomad
  • RohanRohan Registered User regular
    edited April 2009
    I've tried that just now but it doesn't work because the log-in window won't let me into the computer at all to see any folders.

    ...and I thought of how all those people died, and what a good death that is. That nobody can blame you for it, because everyone else died along with you, and it is the fault of none, save those who did the killing.

    Nothing's forgotten, nothing is ever forgotten
  • CronusCronus Registered User regular
    edited April 2009
    Have you tried turning on simple sharing for the desktop and laptop? That might do the trick.

    camo_sig.png
    "Read twice, post once. It's almost like 'measure twice, cut once' only with reading." - MetaverseNomad
  • AdusAdus Registered User regular
    edited April 2009
    You might also want to change the network from public to private in the Vista Networking and Sharing center. Should be the Customize click text right under the computer icons to the right of the network name. But this is more for helping discovery and it sounds like that's not your issue.

  • RohanRohan Registered User regular
    edited April 2009
    What do you mean by simple sharing? I've taken a few screenshots to show you what's happening.

    This is what I see when I open up the network window -

    network.jpg

    If I click on say, the media pc, this is what I get -

    media.jpg

    And this is what I get when I click on my desktop -

    desktop-1.jpg

    That's the log-in window I'm talking about. I don't understand why it's there at all, especially when the network settings are the same on the laptop and the desktop as they are on the media pc... it's irritating to say the least.

    ...and I thought of how all those people died, and what a good death that is. That nobody can blame you for it, because everyone else died along with you, and it is the fault of none, save those who did the killing.

    Nothing's forgotten, nothing is ever forgotten
  • RohanRohan Registered User regular
    edited April 2009
    Adus wrote: »
    You might also want to change the network from public to private in the Vista Networking and Sharing center. Should be the Customize click text right under the computer icons to the right of the network name. But this is more for helping discovery and it sounds like that's not your issue.

    Yeah that's already done, thanks anyway.

    ...and I thought of how all those people died, and what a good death that is. That nobody can blame you for it, because everyone else died along with you, and it is the fault of none, save those who did the killing.

    Nothing's forgotten, nothing is ever forgotten
  • AdusAdus Registered User regular
    edited April 2009
    In the Networking and Sharing Center for Vista, there should be a dropdown that says "Password Protected Sharing" which is something that stops users from logging on to that computer unless they have a password. Make sure that's off, too.

  • RohanRohan Registered User regular
    edited April 2009
    Yeah, did that one already.

    ...and I thought of how all those people died, and what a good death that is. That nobody can blame you for it, because everyone else died along with you, and it is the fault of none, save those who did the killing.

    Nothing's forgotten, nothing is ever forgotten
  • tech_huntertech_hunter Registered User regular
    edited April 2009
    I had this issue too networking and vista is just fucked up. I cant say how I fixed it though I messed with settings on both the machines that I was having a problem with and I guess I eventually hit on a configuration vista finds acceptable. I can tell you I dread the day I have to reformat one of them and go through that bullshit again.

    Sig to mucho Grande!
  • TL DRTL DR Registered User regular
    edited April 2009
    You want to go to the Network and Sharing Center (ugh) and make sure File Sharing and Public Folder Sharing are enabled, and disable Password Protected Sharing. I think that's where your problem is.

    eokNV.jpg
  • KrikeeKrikee Registered User
    edited April 2009
    To eliminate variables, do you have a username and password combination that is the same on the machines you are accessing from and on the machines you are able to access without a prompt?

  • RohanRohan Registered User regular
    edited April 2009
    You want to go to the Network and Sharing Center (ugh) and make sure File Sharing and Public Folder Sharing are enabled, and disable Password Protected Sharing. I think that's where your problem is.

    Have done that, too :/
    Krikee wrote:
    To eliminate variables, do you have a username and password combination that is the same on the machines you are accessing from and on the machines you are able to access without a prompt?

    Both machines have the same user name (set to admin)... I wonder if that's the problem?

    ...and I thought of how all those people died, and what a good death that is. That nobody can blame you for it, because everyone else died along with you, and it is the fault of none, save those who did the killing.

    Nothing's forgotten, nothing is ever forgotten
  • KrikeeKrikee Registered User
    edited April 2009
    If you are logged in as user X with password Y and attempt to access another machine which also has user X with password Y you have the access that user X on the machine you are attempting to access does. Anonymous access should still work although it has been a while since I have had to configure user permissions though.

  • RohanRohan Registered User regular
    edited April 2009
    The passwords are different on both machines, but I guess that doesn't make any difference... the same log-in window came up when my flat-mate tried to access my desktop using his XP-based laptop. Weird.

    ...and I thought of how all those people died, and what a good death that is. That nobody can blame you for it, because everyone else died along with you, and it is the fault of none, save those who did the killing.

    Nothing's forgotten, nothing is ever forgotten
  • CronusCronus Registered User regular
    edited April 2009
    Ok, I did a little google searching and may have found something.

    Try enabling the guest account.

    camo_sig.png
    "Read twice, post once. It's almost like 'measure twice, cut once' only with reading." - MetaverseNomad
  • RohanRohan Registered User regular
    edited April 2009
    Hmm... that worked! Thanks Cronus. I wonder why I didn't have to do that on the media pc... so odd.

    ...and I thought of how all those people died, and what a good death that is. That nobody can blame you for it, because everyone else died along with you, and it is the fault of none, save those who did the killing.

    Nothing's forgotten, nothing is ever forgotten
  • CronusCronus Registered User regular
    edited April 2009
    Rohan wrote: »
    Hmm... that worked! Thanks Cronus. I wonder why I didn't have to do that on the media pc... so odd.

    Is it already enabled on the media PC? Is the media PC on a different workgroup? Perhaps one that's the same as the XP machines?

    Either way I'm glad you got it working.

    camo_sig.png
    "Read twice, post once. It's almost like 'measure twice, cut once' only with reading." - MetaverseNomad
  • RohanRohan Registered User regular
    edited April 2009
    Nope, there's only one admin account on the media pc, and all the machines are on the same workgroup. Like I said, weird. But yeah, thanks for the help :)

    ...and I thought of how all those people died, and what a good death that is. That nobody can blame you for it, because everyone else died along with you, and it is the fault of none, save those who did the killing.

    Nothing's forgotten, nothing is ever forgotten
Sign In or Register to comment.