Club PA 2.0 has arrived! If you'd like to access some extra PA content and help support the forums, check it out at patreon.com/ClubPA
The image size limit has been raised to 1mb! Anything larger than that should be linked to. This is a HARD limit, please do not abuse it.
Our new Indie Games subforum is now open for business in G&T. Go and check it out, you might land a code for a free game. If you're developing an indie game and want to post about it, follow these directions. If you don't, he'll break your legs! Hahaha! Seriously though.
Our rules have been updated and given their own forum. Go and look at them! They are nice, and there may be new ones that you didn't know about! Hooray for rules! Hooray for The System! Hooray for Conforming!

USB Xbox 360 pad lights: Won't. Stop. Blinking.

harvestharvest By birthright,a stupendous badass.Registered User regular
I'm on Windows 7, and this is a new problem that I could easily solve with any kind of tape but the clear kind. But I want it solved properly.

My USB 360 pad's lights won't stop blinking. This is really, really irritating! It distracts me from what's going on on-screen in a big way. I don't understand why it bothers me so much. I mean I have an entire other monitor filled with distracting stuff but it's these 4 little LEDs down at the edge of my peripheral vision that set my teeth on edge.

I tried installing Microsoft's "accessories" driver to see if it would clear up the blinking. All it does is add a little popup that tells which pad number (and battery status for wireless controllers) you're using when you push the guide button.

Googling such generic terms as "xbox 360 controller windows 7 blinking/flashing" gives generic useless results, mostly forum posts about people whose pads don't work at all. Mine works properly as far as I can tell, so these searches haven't done me any good.

So I put it to the group. Does anyone know how to stop the LEDs on the face of a USB 360 controller from constantly blinking?

B6yM5w2.gif
harvest on

Posts

  • harvestharvest By birthright, a stupendous badass.Registered User regular
    edited May 2011
    You know what? I give up. Microsoft can make their hardware behave however they like.

    I just uninstalled the device from the Device Manager AGAIN and rebooted. EVERYTHING IS NOW FINE.

    I'm going to leave that first post there in case anyone else is having this problem.

    harvest on
    B6yM5w2.gif
  • herrchinherrchin Registered User
    I have the wireless controller version. It worked fine for years. Suddenly it started doing the same thing as yours: it would work fine, but the 1-4 circle of lights would constantly blink. Disabling the entry in Device Manager for "Microsoft Common Controller for Windows Class / Xbox 360 Wireless Receiver for Windows" and re-enabling it fixed the issue (after power-cycling the controller).

  • WordLustWordLust Registered User regular
    Was using this controller for a long time and never had a problem, but this just happened to me and it was driving me BATSHIT CRAZY. Also was getting nothing but useless console/broken controller results from google. First place to give me a simple answer that worked. Thanks!

  • BarrakkethBarrakketh Registered User regular
    Usually you can simply unplug/replug it and it'll be happy.

    Restarting the device in the device manager should also work. If you have devcon.exe on your machine you could even write a one-liner batch file that looks something like:
    devcon.exe restart "PCI\VEN_1814&DEV_0301&CC_0280"
    
    You can get the device ID from the device manager (details tab, hardware ids in the dropdown box). I had to do that for my WiFi adapter because every so often my ping would skyrocket, which was fixed after being restarted.

    Rollers are red, chargers are blue....omae wa mou shindeiru
  • steaktimesteaktime Registered User
    I was having the same problem, and figured it out. I had previously installed the MotioninJoy drivers for my ps3 controller. When I picked up my wired Xbox controller, i uninstalled the software, but for some reason there was still a MotioninJoy Xbox driver showing up under Microsoft Common Controller for Windows Class. Once I uninstalled that (be sure to check "delete the driver fromthe system) and reinstalled the drivers from Microsoft that horrid blinking stopped

  • meateemeatee Registered User new member
    I hate to resurrect an old thread, but I just ran into this problem on Windows 8.1 with a wireless 360 controller. After not finding much help through Google searches (none of the suggestions worked for me), I finally fixed it by clearing out all the USB devices in the system registry. Here's how I did that:

    1) Disconnect everything plugged into a USB port (except your mouse/keyboard).
    2) Download USB Oblivion.
    3) Run it and let it clean your registry of all traces of USB devices.
    4) Restart your computer.
    5) Connect the Wireless adapter for the 360 controller and wait for the drivers to reinstall.
    6) Turn on your controller and sync it to the wireless adapter.

    That should be it! My controller now properly shows the top-left light, and no more insane blinking!

    Once everything was back to normal on the controller, I left the controller on while I hooked up my other USB devices, just in case. Everything's perfect now.

    Matagalpa
  • MatagalpaMatagalpa Registered User new member
    Thanks Meatee! I can confirm that USB Oblivion solved this issue for me :-)

  • joebeardjoebeard Registered User new member
    Major thread necro, but I just wanted to thank the poster who pointed out that MotionJoy drivers could be the issue - this had been driving me nuts, and like the OP I googled to no avail and my joypad seemed otherwise functional. I'm trying to troubleshoot issues with Yakuza 0 freezing (switched from SSD to HDD just in case) and began to suspect drivers to be causing it. The game is stuck but there are several threads active doing stuff, so it must be waiting for something... Anyway, at least I don't have that stupid flashing ring anymore, cheers!

Sign In or Register to comment.