Our new Indie Games subforum is now open for business in G&T. Go and check it out, you might land a code for a free game. If you're developing an indie game and want to post about it, follow these directions. If you don't, he'll break your legs! Hahaha! Seriously though.
Our rules have been updated and given their own forum. Go and look at them! They are nice, and there may be new ones that you didn't know about! Hooray for rules! Hooray for The System! Hooray for Conforming!

PC Dead, Need A Hand Diagnosing It

AbracadanielAbracadaniel Registered User regular
So my desktop machine decided to start acting odd Thursday night. Basic description was some weirdness on the monitors, crazy green artifacting, on reboot Win7 display looked super low-rez. I figure it's maybe a dying graphics card (Nvidia 9800GT) but Friday afternoon I go to boot the machine up and nothing. No error codes, no beeps, nada. All I get is a blue light toward the bottom of the board, and a red light toward the top, nearish to the CPU. When I hit the power switch the PSU, CPU, other assorted fans begin to spin up, but just as quickly shut back off.

I know the thing at least appears to be getting power, but without an error code to go on, I'm guessing maybe the mobo is dead?

Anyone have some advice/maybe a walkthrough or two to help me figure out if it's salvageable before I go out and order a new one on Newegg?

The machine was built about a year or two ago. Foxconn Blackops Mobo (I'll have to check on the specific model), Thermaltake 430w PSU, 4GB DDR2 RAM, Nvidia 9800 GT graphics card.

Posts

  • TychoCelchuuuTychoCelchuuu ___________PIGEON _________San Diego, CA Registered User regular
    Could still be the graphics card. That would be the first thing to check, if you can.

  • AbracadanielAbracadaniel Registered User regular
    Hmm. Had a spare card, swapped it out, no dice. Tried a diff slot as well. Still same; fans start to spin, then stop.

  • TychoCelchuuuTychoCelchuuu ___________PIGEON _________San Diego, CA Registered User regular
    Bah, at that point it could be the PSU, the mobo, or even the CPU, although CPUs don't really fail AFAIK.

  • AeytherAeyther Registered User regular
    I doubt it's the CPU, it could be the mobo since it doesn't even give an error but it could be the psu dying and not giving the mobo sufficient juice.

    Is there any way to try out the psu on a different machine?

    Steam | 3DS: 2406-5131-9006
  • AbracadanielAbracadaniel Registered User regular
    Hmm, could be. PSU is at least five-six years old at this point, held onto it from a previous hardware update. Going to order a new one; even it if wasn't the PSU and is the mobo it's time for an upgrade.

  • harvestharvest By birthright, a stupendous badass.Registered User regular
    edited August 2011
    Sounds like PSU to me. Try that PSU on a different computer if you can, or waltz over to Best Buy to get one to test with. Return it whatever the results are, and order the one you really want if needed.

    harvest on
    steam_sig.png
  • AbracadanielAbracadaniel Registered User regular
    Update!

    Took your advice, @harvest and grabbed a PSU at a local Staples. Running now, however it seems like it may have been the graphics card after all as it overheated within a few minutes. May have fried the PSU on it's way to a fiery grave. Now I just have to get a new GPU.

Sign In or Register to comment.