As was foretold, we've added advertisements to the forums! If you have questions, or if you encounter any bugs, please visit this thread: https://forums.penny-arcade.com/discussion/240191/forum-advertisement-faq-and-reports-thread/

[Help] Low frame rates on Guild Wars 2 on a decent rig

italianranmaitalianranma Registered User regular
Comp specs first:

i5 2500K 3.30 GHZ
Radeon 6950
Gigabyte Z68X-UD3H-B3 F12 mobo
SSD
running win 7
playing the game on 1080

my fps varies between 24 and 42 in a non-dynamic environment. As soon as I swing the camera it plunges to to the 10 - 14 range and then back up to 18-24. I can play SW:TOR at its highest settings no problem, as well as play Battlefield 3 on High (but not ultra) at 55fps. These frame rates are constant whether I'm using the lowest or highest settings. Additionally I do have a second monitor, but disabling it does not increase my fps

I've searched online about this, and it seems to be hit or miss with other users with similar settings. I've got the most up to date drivers on all my components, and I've turned off all other background running programs except for Norton anti-virus, which hasn't ever been a resource hog in the past, and I don't really want to run without it. Any other ideas on what I can do?

飛べねぇ豚はただの豚だ。
italianranma on

Posts

  • StormwatcherStormwatcher Blegh BlughRegistered User regular
    I have the same CPU and a Radeon 7950, and GW2 on an SSD. I can't remember precise FPS numbers, but it's also kinda hiccupy on my machine at times.
    I think GW2 is just power hungry and that ATI latestest drivers aren't optmized for it yet. It should get better after a few patches and newer drivers.

    I heard Nvidia GPUs are having ever more trouble.

    Steam: Stormwatcher | PSN: Stormwatcher33 | Switch: 5961-4777-3491
    camo_sig2.png
  • DehumanizedDehumanized Registered User regular
    Yeah, I'd recommend being on the lookout for beta drivers. It'll probably all get sorted out in the next month or so.

  • EshEsh Tending bar. FFXIV. Motorcycles. Portland, ORRegistered User regular
    I have the same CPU and a Radeon 7950, and GW2 on an SSD. I can't remember precise FPS numbers, but it's also kinda hiccupy on my machine at times.
    I think GW2 is just power hungry and that ATI latestest drivers aren't optmized for it yet. It should get better after a few patches and newer drivers.

    I heard Nvidia GPUs are having ever more trouble.

    Nope. I play it at 1080p on a 670 with everything on Ultra and Super Sampling and have a steady 50fps.

  • InfidelInfidel Heretic Registered User regular
    Yeah, I'd recommend being on the lookout for beta drivers. It'll probably all get sorted out in the next month or so.

    This. I have a top of the line nvidia-based rig and had the latest drivers. Things were playing okay but it felt like it wasn't doing what it should.

    Got the latest beta drivers from nvidia and now it plays super slick. If you can try the same thing for ATI, I'd say give it a shot.

    OrokosPA.png
  • italianranmaitalianranma Registered User regular
    Thanks for the help so far guys. One of my friends brought up that my Win7 32-bit isn't taking advantage of my 8GB of ram, and suggested that I upgrade to the 64 bit version. I have the 64 bit disk as well, so it wouldn't cost me anything other than time to do so. If the consensus is that I will see improvement then I will do so tonight. For reference this rig is only used for playing games, my laptop is where I do everything else.

    飛べねぇ豚はただの豚だ。
  • TefTef Registered User regular
    Yeah you should absolutely upgrade to 64bit when you can

    help a fellow forumer meet their mental health care needs because USA healthcare sucks!

    Ever tried. Ever failed. No matter. Try again. Fail again. Fail better

    bit.ly/2XQM1ke
  • DratatooDratatoo Registered User regular
    With certain ATI GPU driver - ATI HW combination, having a flash open in the background can drastically reduce performance. I recommend simply disabling HW acceleration for flash or close all browser windows.

  • KimuraKimura Registered User
    Hi italianranma,

    I noticed that you and I have literally the exact same setup, except that I'm running 64 bit Windows 7 with 8 gigs of RAM. Just wanted to let you know not to give up hope as it is almost certainly a software issue or there is something wrong with a piece of your hardware and hopefully you'd be able to get it sorted under a warranty.

    I run Guild Wars 2 at 1080p on high/ultra setting with a very consistent 30+fps - usually 60, in big fights in WvWvW i drop down to 30ish.

    Only real advice I can give is to get the latest beta ATI drivers and failing that do a reformat into 64 bit. The hardware is more than capable of running this stunning looking game on high settings very smoothly. If you do the reformat, firstly install only the things essential to running gw2 (graphics driver etc.) - if there is an issue with other software you use messing with your gw2 performance, it shouldn't be there at that stage, and you'll know exactly what it was if you reinstall stuff and your performance suddenly drops :).

    Good luck, would be happy to help if there's any other way I can.

Sign In or Register to comment.