My graphics card is stupid

WybornWyborn GET EQUIPPEDRegistered User regular
So I'm running a 560 Ti, and have been since August of 2011. She's a good sort of card.

About the end of last year, when I installed Far Cry 3, I noticed that every once in a while the card would kinda blip out for a bit - I'd get a black screen, and my monitor would say the resolution as if I had just turned it on, and then the game would come back in, reloading all the textures as I looked at it.

Every once in a while I'll get a CTD in certain games, and I'll see a message that says my Nvidia driver stopped working and had to be restarted. What? What the hell does that even mean?

This stopped being something that just happened in Far Cry 3.

I have tested via CPUID's Hardware Monitor and under load the card's only getting up to 75C, which is warm but not outside the normal range for the card, so I don't think it's a heat issue.

I have tried updating my drivers, reverting my drivers, taking canned air to it, and giving myself a completely fresh install of Windows. None of these have really stopped it.

Does anyone have any idea what the Hell is going on here?

dN0T6ur.png
Wyborn on

Posts

  • WybornWyborn GET EQUIPPED Registered User regular
    Just got a CTD without a message in the Witcher 2 tutorial - that being a game that traditionally hasn't crashed on me much at all. Boy is that frustrating.

    I won't bump again, but hoo buddy

    dN0T6ur.png
  • chr1sh4ll3ttb3chr1sh4ll3ttb3 A dagger in the dark is worth a thousand swords in the morningRegistered User regular
    You've already tried pretty much everything I can think of. How old is your PSU, and what wattage is it?

  • WybornWyborn GET EQUIPPED Registered User regular
    edited April 2013
    She's an Antec Earthwatts 650W Bronze, and I got her at the same time I got the vidcard - about twenty months ago. Could it be a power problem? Should I just take out the power supply and make sure everything is probably kerjiggered?

    While stomping around the nvidia support forums I'm finding that this problem is apparently not entirely uncommon with the 560 Ti, which is disappointing

    Wyborn on
    dN0T6ur.png
Sign In or Register to comment.