Options

Setting up Terraria server, have only had connection success with DMZ

Relevant Info:

- Laptop is running Windows XP, have Terraria version 1.2.2
- My laptop hangs for some reason when I try to launch multiplayer in the game with same result when I use the dedicated server from the Terraria guys
- For that reason I'm using the modded server software Tshock
- My local IP (laptop) is set to static
- Router is a newer Medialink router, I'm connected to it wirelessly (part number MWN-WAPR300N)
- Windows firewall has holes poked for terraria, tshock, and the relevant ports (7777 both TCP and UDP)
- I've tried using the Upnp router option with windows firewall ON and OFF, both failed
- I've tried specific port forwarding to my local IP with windows firewall both ON and OFF, both failed
- I've tried both of the above with my router firewall ON and OFF, failed each time
- I've checked my port using the tool available from portforward, and it comes back as open
- There is a Upnp plugin for the Tshock server software which I have downloaded and am using (but it doesn't seem to have an effect)
- I have a second laptop on the network also running Windows XP, same results as above. However, that laptop can launch a multiplayer game from Terraria and use the stock Terraria server software without locking up, I just still can't connect to either of those options.

The only thing that has worked is using the DMZ option in my router pointed at my local IP. I don't really want to continue doing this for security reasons (I guess?), so I'm hoping to get either port forwarding or Upnp working.

I've posted basically the same question on the Tshock forums but the only conclusion has been that my router sucks, which it may! There weren't any suggestions that came out of that thread beyond what I listed above. Just wanted to see if anyone here had anything else I could try. Thanks!

Posts

  • Options
    Apothe0sisApothe0sis Have you ever questioned the nature of your reality? Registered User regular
    Ideally, we want to use specific port forwarding, yes?

    The options are basically: Terraria has port requirements other than 7777tcp/udp OR you've muffed up the specific port forwarding on the router.

    Can you post a screen shot of the router port forwarding configuration? You might want to mask any IP addresses though.

Sign In or Register to comment.