Club PA 2.0 has arrived! If you'd like to access some extra PA content and help support the forums, check it out at patreon.com/ClubPA
The image size limit has been raised to 1mb! Anything larger than that should be linked to. This is a HARD limit, please do not abuse it.
Our new Indie Games subforum is now open for business in G&T. Go and check it out, you might land a code for a free game. If you're developing an indie game and want to post about it, follow these directions. If you don't, he'll break your legs! Hahaha! Seriously though.
Our rules have been updated and given their own forum. Go and look at them! They are nice, and there may be new ones that you didn't know about! Hooray for rules! Hooray for The System! Hooray for Conforming!

Windows 7 Taksbar Weirdness

RichyRichy Registered User regular
So my taskbar in Windows 7 is acting weird.

Normally, the taskbar is at the bottom of the screen, on top of everything else. When you maximize a software window, it fills the screen area not including the taskbar; the taskbar remains a special separate area, and the bottom of the maximized window reaches right above the taskbar. This is what I like, and what I want.

For a while now software windows have been ignoring my taskbar. Some software will maximize either on top of the taskbar to fill the entire screen and cover up the taskbar, and others maximize under the taskbar, making the bottom of the window underdable under the taskbar.

The only setting I know for the taskbar is the "lock taskbar" option, and it is checked. I tried googling for more settings or ideas, but everything I find comes back to that "lock taskbar" setting (or proposes custom software I could install to hide the taskbar altogether, which is the opposite of what I want).

Anyone know what's going on, and what I can do to stop it?

sig.gif

Posts

  • bowenbowen How you doin'? Registered User regular
    Is it all software doing this or just certain ones?

    A programmer can override this if they're so inclined. If it's a dialog window with "always on top" it'll go over your task bar. If it's maximized, it'll also take up the full screen.

    Ladies.
  • RichyRichy Registered User regular
    All software appear to do this, including Firefox, Word, Powerpoint, and Photoshop.

    sig.gif
  • HevachHevach Registered User regular
    Right click the task bar and click properties. Make sure auto hide is off, and always on top is on.

    bowen
  • RichyRichy Registered User regular
    Auto-hide is off. Where is the "always on top" option you mentioned? These are the properties I have:
    properties_zps6b7126a7.png

    sig.gif
  • PedroAsaniPedroAsani Brotherhood of the Squirrel [Prime]Registered User regular
    Try a variant of Turn it off, Turn it on:

    Uncheck the Lock taskbar. Restart the machine.
    Check the Lock taskbar. Restart the machine.

    Any better?

  • RichyRichy Registered User regular
    PedroAsani wrote: »
    Try a variant of Turn it off, Turn it on:

    Uncheck the Lock taskbar. Restart the machine.
    Check the Lock taskbar. Restart the machine.

    Any better?

    It's been a couple of days, and so far that seems to have done the trick. I'll be back if it breaks again. Thanks!

    sig.gif
Sign In or Register to comment.