As was foretold, we've added advertisements to the forums! If you have questions, or if you encounter any bugs, please visit this thread: https://forums.penny-arcade.com/discussion/240191/forum-advertisement-faq-and-reports-thread/

[Programming] djmitchella travelling through snow to rfind duplicate dates for singletons

24567100

Posts

  • InfidelInfidel Heretic Registered User regular
    I'd much prefer typing just letters vs letters and underscore, efficiency wise.

    A few extra letters is pretty negligible to my efficiency/flow, underscore is a bit more jarring even if it isn't very much more of a deal and typing isn't the majority of what makes for efficient programming...

    It still is like FUCK YOU, UNDERSCORE creeping into my brain.

    OrokosPA.png
  • TryCatcherTryCatcher Registered User regular
    bowen wrote: »
    Why would you not refer to it as stock everywhere, that is a whole lot of hassle for 2 letters.

    Because being consistent is one of those things that is hard on what is likely code done by a lot of people on crunch/must work now time.

  • KambingKambing Registered User regular
    bowen wrote: »
    I would make you so angry.

    Hah, why? Same naming convention for everything? I don't mind that so much. There's so much bigger fish to fry in the world of programming than naming things. =D

    @TwitchTV, @Youtube: master-level zerg ladder/customs, commentary, and random miscellany.
  • bowenbowen How you doin'? Registered User regular
    Yeah I use that camelCase system for everything.

    C++, Java, Python, PHP, C#

    The older I get the harder it is to remember everything under the sun. If I was still 14 I probably would just use whatever I felt like using at the moment.

    not a doctor, not a lawyer, examples I use may not be fully researched so don't take out of context plz, don't @ me
  • zeenyzeeny Registered User regular
    By order of importance:

    1. Follow the standard/style of the project you are currently in.
    2. Follow the standard/style guide of the language you are writing in.
    3. ?????
    4. Do whatever the fuck you want.

  • SporkAndrewSporkAndrew Registered User, ClubPA regular
    One thing I do that probably annoys other people is to underscore private methods on a class. It means I can see at a glance which are public and it makes the auto complete on function call when you're writing the class that much quicker.

    In other news AWS bill rose to $25 with no change to what I was doing. Now there's even more acronyms and mystery charges.

    The one about the fucking space hairdresser and the cowboy. He's got a tinfoil pal and a pedal bin
  • JasconiusJasconius sword criminal mad onlineRegistered User regular
    i use _underscore to denote a private variable

    and I use meta for GUI variables that correspond directly to a named variable for binding

    so "myObject.name" would bind to "lblName"

  • CampyCampy Registered User regular
    edited September 2014
    bowen wrote: »
    Why would you not refer to it as stock everywhere, that is a whole lot of hassle for 2 letters.

    I have no clue.

    The library itself (mostly) uses the stk prefix. But whenever it's referred to from another core library, it uses the stock prefix.
    roberto-stabby-gif.gif


    Campy on
  • EtheaEthea Registered User regular
    If you prefix anything with _underscore in a C++ project I will go :bowen: all over you.

    single or double leading underscores are reserved for the compiler and standard library ( except for underscore followed by a number e.g. _1 )

  • mightyjongyomightyjongyo Sour Crrm East Bay, CaliforniaRegistered User regular
    we...do the _underscore in our c++ code...

    *ducks*

  • bowenbowen How you doin'? Registered User regular
    Wait are we getting an animated gif of my avatar making stabbing motions with a knife ?

    not a doctor, not a lawyer, examples I use may not be fully researched so don't take out of context plz, don't @ me
  • EtheaEthea Registered User regular
    we...do the _underscore in our c++ code...

    *ducks*

    I first have to stab myself since I work on projects that use double underscore for include guard names, no matter how many times we bring up that it is against C++ standards.

  • JasconiusJasconius sword criminal mad onlineRegistered User regular
    Ethea wrote: »
    If you prefix anything with _underscore in a C++ project I will go :bowen: all over you.

    single or double leading underscores are reserved for the compiler and standard library ( except for underscore followed by a number e.g. _1 )

    alternative?

    I think in C++ I might use casingSuchAsThis for member level variables of varying access level, and then CasingSuchAsThis() for public accessor methods

  • bowenbowen How you doin'? Registered User regular
    Yesssssssssss do itttttttttt

    not a doctor, not a lawyer, examples I use may not be fully researched so don't take out of context plz, don't @ me
  • KakodaimonosKakodaimonos Code fondler Helping the 1% get richerRegistered User regular
    edited September 2014
    God dammit. If you don't understand IEEE-754 don't write your own goddamn rounding and/or truncation functions.

    This:
    int iSuck = (dSuck * 1000000 + 0.99);
    double dSuck = iSuck / 1000000;
    

    Is wrong.

    Kakodaimonos on
  • mightyjongyomightyjongyo Sour Crrm East Bay, CaliforniaRegistered User regular
    According to the google style guide, you should be using the underscore at the end, i.e. variablename_ . I don't think I agree with this though, personally I think I prefer a prefix to denote access level over postfix.

  • TryCatcherTryCatcher Registered User regular
    So, in short, most people do whatever the fuck they want.

    Sounds right to me.

  • bowenbowen How you doin'? Registered User regular
    Languages need better fixed point support.

    I find when most people want decimals, they almost never want floating point decimals.

    I guess they call that radix independent floating point, I always just called it fixed point decimal.

    Decimal is great when languages support it!

    not a doctor, not a lawyer, examples I use may not be fully researched so don't take out of context plz, don't @ me
  • JasconiusJasconius sword criminal mad onlineRegistered User regular
    I need fixed point support in Objective-C

    not sure something convenient to use exist, haven't looked to be honest.

  • bowenbowen How you doin'? Registered User regular
    not a doctor, not a lawyer, examples I use may not be fully researched so don't take out of context plz, don't @ me
  • urahonkyurahonky Registered User regular
    Project I'm working on is generating powerpoint documents.

    At times it calls charts "tables" and it's really fucking confusing. It'll be like:
    public static void generateAxisLabels(Chart table, Document doc){}
    

    Why not call it a fucking chart? That's what it fucking is!

  • bowenbowen How you doin'? Registered User regular
    "Chart chart" is a great way to fuck with people too.

    not a doctor, not a lawyer, examples I use may not be fully researched so don't take out of context plz, don't @ me
  • DelmainDelmain Registered User regular
    bowen wrote: »
    "Chart chart" is a great way to fuck with people too.
    public static void generateAxisLabels(Chart chrat, Document doc) {}
    

  • urahonkyurahonky Registered User regular
    bowen wrote: »
    "Chart chart" is a great way to fuck with people too.

    Go with "c" then. Once "chart" is passed in then there's nothing that needs to happen to it. You don't need to say "Chart chart" anywhere.

    chart.getSeriesNames().get(0);

    Makes a hell of a lot more sense than:

    table.getSeriesNames().get(0);

  • bowenbowen How you doin'? Registered User regular
    Delmain wrote: »
    bowen wrote: »
    "Chart chart" is a great way to fuck with people too.
    public static void generateAxisLabels(Chart chrat, Document doc) {}
    

    Not sure if I hate you or love you.

    Why do you do this to my emotions, man?

    not a doctor, not a lawyer, examples I use may not be fully researched so don't take out of context plz, don't @ me
  • DehumanizedDehumanized Registered User regular
    Chart graff

  • urahonkyurahonky Registered User regular
    Chart excelData

  • InfidelInfidel Heretic Registered User regular
    Chart course

    OrokosPA.png
  • bowenbowen How you doin'? Registered User regular
    Chart chrtChart

    not a doctor, not a lawyer, examples I use may not be fully researched so don't take out of context plz, don't @ me
  • DelmainDelmain Registered User regular
    public static void findTheWhiteDeer(Chart cHart) {}
    

  • DelmainDelmain Registered User regular
    public static void findWindowsDriverVersion(int iNT) {}
    

  • TryCatcherTryCatcher Registered User regular
    Chart chart_Chrt

  • urahonkyurahonky Registered User regular
    Chart new_chrt_obj = NewChartFactoryObject.getChartObjectFactory().createChartObject();

  • DehumanizedDehumanized Registered User regular
    the word chart has ceased to have any meaning to me

  • KakodaimonosKakodaimonos Code fondler Helping the 1% get richerRegistered User regular
    public Object AbstractSingletonProxyChartFactory.GetChartProxyAxisDataProxy(ProxyChart pChart)
    

  • LuvTheMonkeyLuvTheMonkey High Sierra Serenade Registered User regular
    Not enough FactoryFactories.

    Molten variables hiss and roar. On my mind-forge, I hammer them into the greatsword Epistemology. Many are my foes this night.
    STEAM | GW2: Thalys
  • bowenbowen How you doin'? Registered User regular
    I'm dangerously close to bloodlust.

    not a doctor, not a lawyer, examples I use may not be fully researched so don't take out of context plz, don't @ me
  • urahonkyurahonky Registered User regular
    Not enough FactoryFactories.

    Yeah I wanted to avoid making bowen's blood boil.

  • KakodaimonosKakodaimonos Code fondler Helping the 1% get richerRegistered User regular
    public AbstractKnifeProxy AbstractKnifeBeanMutableKnifeFactory.CreateAndInstantiateAbstractKnifeProxy(KnifeProxyParameters nKnifeProxyParams)
    

  • EvigilantEvigilant VARegistered User regular
    edited September 2014
    public AbstractKnifeProxy AbstractKnifeBeanMutableKnifeFactory.CreateAndInstantiateAbstractKnifeProxy(KnifeProxyParameters _nKnife_prxy_par)
    

    Just because I'm having a really bad day.

    Evigilant on
    XBL\PSN\Steam\Origin: Evigilant
Sign In or Register to comment.