[Let's Play] Dark Souls 2 - Day 19: Hell+++



  • Options
    Page-Page- Registered User regular
    Day 18 continued.
    If I want to fight this guy, I'll have to deal with that archer first, otherwise a stray arrow, even one that I block, will knock me off to my death.

    But I can do that after I've checked the other side of the bridge. This guy is guarding another ladder, possibly the next area. It can wait.

    I cross the bridge and charge the archer on the left, near the fog gate. My spear does little damage and doesn't flinch him at all. He pulls out a long katana crackling with energy and nearly cuts me in half. I survive that, but not the knight rushing to stab me in the back. See what I mean about honour?

    The problem I'm having, and will continue to have, is that their bulky armour is particularly effective against stabbing attacks, and they don't seem that bothered by lightning. If I can't stagger the knights, especially the big ones, I'm in trouble.


    I make sure to drag all the knights across the bridge. The last two, the ones that keep killing me, appear to have a short leash, so I can get free attacks when they turn back for the bridge.

    The first archer goes down before it can pull a sword. The second has more time, and manages a brutal slash that pierces my shield, doing significant bleed damage.


    It fights with a familiar katana style--Iaido, I think, which I only know from Soulcalibur. I'm not that much of a nerd. Sudden strikes followed by long recovery periods that allow for plenty of club time.

    Once they're all dead, I look for a way up to the Pharros' device. All I find is a nearby staircase that I'll have to jump for.


    That's another potential death, so it can wait till after I've checked out the bridge behind the furnace.


    This knight has no bow, but I'm well aware of how his sword works. I wait for him to make the first move, then start swinging my club. We back away from each other, then attack again. One more club swing, and it's over.

    I can hear a distinct crackling sound here, like a fire. Not a bonfire, as it lacks that soothing tone. This is danger. These odd pylons that line the bridge. What are they? In hindsight, it's obvious they're chimneys, but at the time I mistook the smoke coming from them for something more ethereal. I smack one with a club, and it explodes into a jet of flame.


    I don't want to get any closer to that than I have to. I loot the corpse at the far end of the bridge, picking up an old radiant lifegem and a green blossom. Then it's time to climb the ladder.


    Another open space, another metal bridge with knights guarding it. Once I've confirmed I'm not under attack, I climb all the way up. To the right, coming from the direction of the fog gate below, is a thick metal door. Of course it's locked.


    I walk to the doorway and crane my neck as far as I can without attracting the knights attention. If I go out there, will I take fire from more archers? Thankfully, no. So I do go out there, and I murder the knight. I can see another big, metalic thing at the far end of the bridge. It's one of those hammer-swinging armoured turtles I met in the coastal fortress inside the Forest of Fallen Giants.

    It doesn't attack me, but instead turns and runs as soon as I engage the knight, disappearing through a doorway.


    This is another big pit full of flowing hot iron. With the knight dead, I cross the bridge, and find the reason the armoured turtle booked it. There's a gap, short enough that I could jump it easily, but still too much for it to cross. So where did it go?


    Not far enough. When I jump across, it comes stomping back around the corner, hammer raised.


    There's no getting around it like this, and my shield is ineffective. One second it's swinging down at me, the next I'm kissing the hot metal of the bridge. I try to recover, but I can't turn and jump fast enough, and have little space to move or roll. The next swing kills me.

    I have a sneaking suspicious now that there's a bonfire behind that locked door.

    Coming back, one of the knights drops a blacksteel katana. One of the lowest base damages I've seen on a weapon, but it has slightly better durability than the other katanas I've found and a solid A dexterity gain. The Iron King was an eccentric that hired a foreign swordsman to train his knights to fight with these strange blades.

    When I exit the first section of the keep, another invasion message appears. It's Forlorn again. But there's also that parade of knights, one of which gets a hit on me. I have to fight a retreat all the way to the main entrance before I have the invader alone.


    An attack slips past my guard when I have Forlorn nearly beat. I die again, losing the 40,000 Souls I left on the upper bridge.

    Another drop in the ocean.

    I wonder if there's a special criteria for the Forlorn showing up. He, she, they, or it has appeared in most areas I've been through, at some point. Multiple deaths, maybe? It would be neat if Forlorn mostly showed up after a large number of Souls are on the ground, but that doesn't seem to fit the trends. Whatever it is, I hope I get a rematch today.

    When I say the 40,000 is a drop in the ocean, I mean that I hardly feel the effects of losing that amount when I'm gaining so many without going out of my way. By the time I've made it to the fog gate again, I'm already back at 48,000.

    I had to swap out the Stone Ring again for the Ring of Binding, and fighting the knights without the extra poise damage is a bit of a pain. They hurt when they hit, and do tick damage with the bleed buildup on the swords. But I suspect there's something dangerous through the fog gate, so I pop an effigy and put the Stone Ring back on before stepping through.

    Competitive Gaming and Writing Blog Updated in October: "Song (and Story) of the Day"
    Anyone want to beta read a paranormal mystery novella? Here's your chance.
  • Options
    Page-Page- Registered User regular
    Day 18 continued.
    Smelter Demon

    I'm locked in with a 3-metre tall hunk of iron and fury, a horned metal demon with a sword big enough that it could be its own boss fight. When I enter, it comes to life, the fire in its chest igniting, burning like a Soul. Slowly, joints clanking and grinding, it faces me, turning a blank, eyeless face in my direction. Maybe it can't see me, in a conventional sense, but it knows I'm there. And it knows it needs to kill me.

    And so begins my dance with a personal demon.


    At first, it doesn't seem so bad. I can block the sword swings without taking damage, take a few stabs when I see its back. I'm playing cautiously, as is my nature in a first encounter. My attacks do very little damage, which I expected. I've brought a toothpick to a sword fight, and jabbing a hunk of metal is never an effective strategy. Against armour, I should have a club. But as long as it can't hurt me, I'll be fine.

    The demon leaps high into the air, stabs its sword into the ground. An opportunity. I 2-hand the spear and start in, hoping to get some good damage done.

    A slight flexing of the shoulders is the only warning I get before a shockwave erupts from the blade. I'm on my back, wondering where all my health has gone, but I force myself to stand, to drink from my flask. I recover before the demon does, and start poking again.

    A few jabs later, and the demon pauses. The flame in its chest grows, gaining strength.


    This is more than intimidation. When I get close enough for another stab, the intense heat starts to drain my health. And that's not the worst of it.

    After I've done a bit more damage, the demon stabs itself with the sword, pushing the blade through the fire. It then pulls out a sword of fire. And now the real problem. I can't block that. The added fire damage cuts quarters and thirds from my health bar, and I can barely keep up with flask charges.

    Soon, my bottle is dry, and I'm scrolling desperately through my items for a lifegem. Will the fire die out? Another series of slashes, and I'm dead.

    The next fight goes better. I buff my spear before entering, attack viciously while it charges its flames, again when it lights the sword up. I still make a mistake, attacking during the shockwave, and die, but I had it around half health, which is encouraging.


    There are two major problems here. The first is the route from the bonfire to the fog gate, and the second is the demon's flaming sword. Call it three problems with my lack of damage. Unless I'm landing big critical attacks, my lightning winged spear+10 is doing less than 100 damage with a heavy attack, and the demon has thousands of HP. My first thought is that this is will be a damage race, with my initial efforts based on that. Buff the spear, aggressive 2-hand attacks to do as much damage as I can before the fire comes out. But once it does, I'm stymied.

    Getting to the boss is something I can work on, though. The patterns and enemies are consistent, if involved, and the only big stumbling block are the last two sword knights, the ones that jump down from the Pharros' device and charge across the bridge together. The rest I can fight one at a time, and if I'm mindful of angles to avoid arrows, that's all straightforward.

    Still, it's work every time. All told, it's 13 sword knights, the archer in the keep, the archer on the bridge, and the two bigger archers on the other side. Seventeen enemies every time, for a total of 12,800 Souls. It's not long before I've collected the complete armour sets, and the special helmet and armour from the bigger knights as well. Turns out, they're captains. One even drops an Alonne Greatbow, a huge weapon that requires 20 strength and 25 dexterity so it can fire those heavy greatarrows. I also discover the reason for my spear's unexpected degradation. The captains fire destructive arrows that damage equipment even when blocked.

    Forlorn shows up again, and I have my chance to kill it.


    Yes, I cheese out the AI by running up the stairs repeatedly, forcing it to follow so I can get free hits before dropping down to repeat the process. But, in fairness, they gang up on me, and I have that stack of Souls in the boss room. The kill gets me a few thousand Souls and an awestone.

    Working out the route is tedious enough that I can understand why people would avoid the Company of Champions. But it gives me opportunities to learn, which are valuable. For example, I discover that the Stone Ring adds poise damage to spells, too. I figure this out with the method I use to take down the two captains without getting arrows in the back. By standing on their side of the bridge, but between the buttresses so they can't see me, I force the one on the right to come running over to get a line of sight. Then I can zap him with my magic missiles, danger-free because it takes half a minute to knock those big arrows and fire. With the Stone Ring on, each magic missile staggers the captain. With it off, it takes two in a row.

    I perfect the run as well as I can, timing each pull, switching from club to spear as the situation demands. But it all feels like work, because I make no progress beyond that. The Smelter Demon is where I break.

    Slowly, I learn its patterns. A combo of two horizontal slashes followed by either a jumping stab or an overhead slam. The jumping stab leads into the shockwave attack. There's also a lunging thrust, which is easy to avoid. This changes once the fire comes out. The radius of the shockwave multiplies, the overhead slam sends out a line of fire. For a while, I try using the magic shield buff spell, and it helps some. With it active, I can fully block the fire damage. But I'm on the defensive there, with fewer opportunities to counter-attack. My hope that the fire will run out is dashed when I spend a full minute running and dodging, with no result. And the shield buff doesn't last very long, even if I look for chances to re-apply it.

    I give up on that tactic, because it's not addressing the core problem. Even if I could block all the fire damage, if I can't hurt the Smelter Demon back, I'm not going to win.


    Once, I go through my equipment, putting together as much fire defence as I can--and this includes the Alonne Captain's armour. It's not much, boosting me from 171 to 243. It also makes no discernible difference. A single overhead slam or shockwave burst will kill me regardless. Maybe not if I was human and had my full health bar, but I'm not confident that will help enough to waste more effigies.


    If I could use the club, it might help. But that also means getting close enough to the demon that I'm taking constant fire damage. If I had a shield with better fire resistance, like my Watchdragon Parma, that might cut down on the fire damage. But that would mean taking more physical damage, so it's a wash. As it is, without upgrades the club isn't doing a whole lot of damage anyway. With upgrades, the club might serve, and would certainly do more damage than the spear. But all my Souls are tied up in the boss room.

    At one point, I step too far across the bridge, take an arrow in the side from one of the captains, and fall into the fire, losing my full stack of Souls.

    Without going back for upgrades, which I really don't want to do, my options are avoidance or manning up. It was obvious right away that this boss is optional. If I kill it, I'll get access to a bonfire and a shortcut through that locked door up behind the furnace. If I wanted to, I could keep going without that. But I don't care about the bonfire. I care about killing this thing.

    It takes a lot of work. Progress is incremental, but once I start to learn, it's steady. Back to the magic weapon buffs, and no more blocking the fire sword. If I want to win, I'll have to stop being so lazy and start dodging. Not aggressively--that's pointless. Whether I block or dodge, I don't have the stamina to support staying close to the demon while still getting to attack. So I abandon any notion of a damage race, and instead take it slow. I keep to the outside, circling to the demon's right, where I can best avoid attacks. When I roll, it's only to get away from the first hit in a series, putting distance that lets me avoid the rest. I go for counter-attacks while it's recovering, as I gain the most bonus damage then.


    All at once, it starts to click, and I realize I'm closer than I've ever been to winning. To give you some idea of how long this takes, even with the stack of Souls I lost, I'm over 100,000 the first time I nearly kill the demon.

    I've reached a point where the only dangers are the shockwave and the overhead slam. The shockwave only because the range can be hard to judge, or I might be pressed against a wall with no room to get away. The slam attack because the timing to dodge it seems to change after the sword is on fire. I regularly roll away, only to get caught somehow without the attack seeming to actually hit. Consequence of low agility, perhaps? Over time, I work on that as well, tightening my timing by recognizing the animation early and staying further away.

    I'm that floating butterfly, I have that bee's sting. In and out, back away from the slashes, poke for counter-attack damage against the lunges. Heal when the demon has the sword in the ground, recast the buff when it gathers flames.

    When it starts to happen, I can feel it. The fight is going as close to perfect as possible, the demon is nearly dead and I've yet to use a flask charge in earnest, deciding to take a quick sip to top up some of the burn damage only because it was doing the shockwave and I couldn't attack.a


    A track and field coach once told me that I peter out before the finish line, which made me a poor sprinter, but maybe I'm built for marathons. I hold on, keeping my hands loose, willing myself to not over-commit with the finish line in sight.

    I have to admit, there's a bit of luck involved. It doesn't use the slam attack. It's stabbing and jumping, which is easy to dodge. I'm drinking from the flask at any sign of damage, waiting for only the surest openings. And I have it. I dash in and start stabbing. It's going to die.


    "Victory Achieved"

    I gain 32,000 Souls and a Smelter Demon's Soul. Adding everything together, I'm up over 150,000 on the day.

    The Old Iron King lost his life to this demon, a hunk of iron made living with a Soul. Did the Iron King give it that Soul? Did he become the demon?

    There are stairs at the back of the room.


    I climb to the top and open a metal chest. Inside is a porcine shield and 5 flame butterflies. The shield is a novelty, a pig head made from leather and wood. Bad defences across the board, but I guess it looks weird enough to make up for that.


    As expected, the next room has a bonfire and the metal door.


    I have secured the "shortcut."

    I light the bonfire, but don't rest. I still want to check out that Pharros' device, and I may as well do it now, while everything out there is still dead.


    My heart catches in my throat as I jump at a weird angle, smacking into the wall. I'm certain I'll fall to my death, but somehow I slide to the edge of the stairs and roll to safety. A loot corpse there holds a petrified dragon bone.

    Inside are only some stairs to a ladder, which takes me to the roof.


    Inside the chest is a zweihander, the lightest ultra greatsword I've seen. I walk over and place a lockstone into the device. I'm ready to jump back, because the indentation there reminds me of the poison in Earthen Peak. If molten iron pours out of those eye-holes, I want to be anywhere but in the way.

    It's only water, though.


    I hear a clank, and then nothing. What happened?

    I look over the edge. Still only hot death below. I look at the flaming stones, and they're still on fire.


    Back to the fire-breathing statue in the lobby. It's still breathing fire.


    I go as far back as the first bonfire, and the stones out there are still on fire as well. So, what happened? Maybe it was something to do with the Smelter Demon? I go back and rest at the upper bonfire, then check through the door, to the bridge with the armoured turtle. Nothing new there, either.


    Disappointed, I warp away. I go to Straid first, to see what the Smelter Demon's Soul will make. It's the sword it carried, a heavy ultra greatsword with added fire damage, requiring 40 strength. I buy the rest of Straid's spells and the Ring of Intelligence before leaving, spending about 70,000 Souls. My trouble with the Smelter Demon convinced me that I had to start upgrading again, if only to save time, but that was before I won. Now I'm back to that feeling that I can conquer any problem, giving the time to learn how. It's a vicious cycle.

    Besides, I'm going to sell all that gear I collected and end up with even more Souls than I started with.

    Except, I can't, because Gavlan is MIA. I check his little cave down in Harvest Valley, and it's empty.


    I even check the place I first met him, the little building in the middle of No-Man's Wharf. He's not there, either.


    Now what? I look around Majula, without any optimism, find nothing. Where will he pop up next? And what if I've already been there? Doors of Pharros maybe? Oh well.

    Even if I don't particularly want to level up anymore, there's nothing much left to spend Souls on. I bow before the Emerald Harold and start thinking about where to put my levels. With the 80,000 Souls still in my pocket, I can get a full 12 levels. Should I start down that strength path?

    No. I don't want to abandon my current plan before I've had a chance to fully test it. I'll hold out for a faintstone. I put 9 points into dexterity and 3 into intelligence. If I end up able to try a few more spells as well, I won't complain.


    I gain a whole +4 damage. Maybe next I can get the faith needed to use a hex. I don't have enough Souls left over to upgrade the club, or the jester's hat. I do go to McDuff's and test a plain +10 winged spear to see if the bonus damage is any better. It still doesn't compete with the added lightning damage, but I have another boltsone on hand and re-infuse the weapon.

    The last thing I do is give up my awestones to the Victor's Stone. That's enough for today.


    It's been so long since I last saw the stat screen. I'd been content to stick with my level 60 build, worried that all the time I spent skipping ahead would trivialize the earlier areas. Fortunately, that hasn't been the case, for the most part. While I wasn't pressed too hard, the last couple of areas were still challenging enough to be interesting. How much of that is thanks to lingering rust hardly matters.

    More importantly, the Smelter Demon was tailor made to cause my as much trouble as possible. Optional or not, it's good to know that sort of boss will get in my way. Would it have been half the challenge without the distance and enemies between the fog gate and the bonfire? Perhaps not, but I've made up my mind about the Company of Champions.

    And if that was the optional mid-boss, how is the real boss of the Iron Keep going to treat me?

    Competitive Gaming and Writing Blog Updated in October: "Song (and Story) of the Day"
    Anyone want to beta read a paranormal mystery novella? Here's your chance.
  • Options
    Page-Page- Registered User regular
    Took longer than I planned to thanks to that boss, which has probably been the toughest so far. Anything that forces me to start dodging and rolling is going to throw me for a loop at first. What can you do.

    Competitive Gaming and Writing Blog Updated in October: "Song (and Story) of the Day"
    Anyone want to beta read a paranormal mystery novella? Here's your chance.
  • Options
    ecco the dolphinecco the dolphin Registered User regular
    Nice going on the Smelter Demon!

    What that lockstone did:
    You realised that it was water, but did you know that if you roll through the water... you gain temporary fire resist?

    Penny Arcade Developers at PADev.net.
  • Options
    Page-Page- Registered User regular
    edited February 2016
    Is that something coming up, or have I already missed it?

    It's going to make me feel dumb, isn't it?

    Page- on
    Competitive Gaming and Writing Blog Updated in October: "Song (and Story) of the Day"
    Anyone want to beta read a paranormal mystery novella? Here's your chance.
  • Options
    ecco the dolphinecco the dolphin Registered User regular

    A bit from both column A and column B, I'm afraid.

    Don't worry - I think most people missed it until it was pointed out to them. =)

    Penny Arcade Developers at PADev.net.
  • Options
    Page-Page- Registered User regular
    Missing the obvious is a specialty of mine.

    Competitive Gaming and Writing Blog Updated in October: "Song (and Story) of the Day"
    Anyone want to beta read a paranormal mystery novella? Here's your chance.
  • Options
    Page-Page- Registered User regular
    Been busy with stuff, but still trucking. The last update turned out to be way, way more than I expected, and I had to cut things short. But I plowed through the writing and I'll do the editing tomorrow. So, update incoming.

    Competitive Gaming and Writing Blog Updated in October: "Song (and Story) of the Day"
    Anyone want to beta read a paranormal mystery novella? Here's your chance.
  • Options
    Page-Page- Registered User regular
    Day 19
    Iron Keep


    After using an effigy, I'm ready to take on the second half of this hellhole.

    I leave from the upper bonfire, above the Smelter Demon's lair. And now there are two knights guarding the bridge, plus the one outside the bonfire. That guy has his back to me, and maybe he'd leave me alone, but I'm not taking chances, and could use the extra space. So he dies first.


    I'm pleasantly surprised when neither of the knights on the bridge comes out to shove a sword through my back. One of them always jumped down to fight me when I was trying to cross the bridge before the fog gate, but they don't seem to care about me murdering their comrade out here. Laziness? Some sort of sick Hollowed love triangle between them and the archer on the bridge? What ever it is, it's working for me.

    Being human, with the Stone Ring on, dealing with the two in the bridge is simple enough. While that's happening, I can see the ironclad swinging its hammer in the background, smashing it into the ground. Frustration that it can't reach me?

    By the time I get there, it's turning its back to run away, but I think I saw what was going on. The ironclad was bashing away at a section of the bridge, it's the reason there's a gap.


    As with many of the Hollowed in Drangleic, there's a sort of low cunning left over after the rest of the mind goes. This is the only way to the back of the keep, and with red-hot iron below and to either side, anyone would think twice before going on.

    Anyone that had something other to live for than what these guys are guarding. And even without that, it would only be a matter of time before curiosity got the better of me. "I wonder what's in that obviously dangerous cave, ruin, or pit?" may as well be the official Drangleic party game.

    What I mean to say is that, when I think twice, the second thought is always, "I've got nothing better to do."

    On the other side, I remember what happened the last time I did this. A quarter-tonne of iron to the skull has a lasting impact, literally and figuratively. What's my approach here? Is there enough space through this doorway that I can run for it and avoid the ironclad trapping me in the narrow entrance? Perhaps, but I don't like the look of that knight I can see in the distance. If he's got a bow it will ruin my sunny disposition.


    Best to rely on spacing and my only real strength, which is having a lightning winged spear+10. I don't have much of a sense of the gear curve in Dark Souls 2 compared to the first game--and didn't have a handle on that game, either--but half the stuff I'm using comes from further in the game than this. And I've killed plenty of nasty things. If I can't trust myself to take down a turtle with a metal fetish, I may as well give up right here and now.

    It goes both better and worse than expected.


    The ironclad stomps around the corner, hammer raised. I get a couple of deep 2-handed stabs in, and it's nearly dead. Then the hammer hits me, and I'm on the ground. But it doesn't follow up. It's guarding the doorway, and that's where it wants to stay. I stand up and stab it again. It drops a large titanite shard.

    As I stick my neck through the doorway far enough to make sure nobody is going to shoot an arrow at it, I hear fast footsteps coming at me. Another knight appears, sword already chopping.


    Once he's dead, I try again. Nothing else attacks.

    Evidently I've found some sort of switch puzzle, as I'm standing next to one, while looking at a platform suspended by chains high above the room. To my immediate left is a metal door like the one opening from the bonfire. To my right, across the platforms in the middle of the room, is a fog gate.


    Getting to it will likely involve lowering that central platform and getting around the fire-breathing statues, as well as whatever else guards the way. I can see at least one ironclad from down here, and the knight. There's bound to be more.

    I try the metal door purely as a matter of course, not expecting it to open. But it does open, and I'm inside what amounts to a closet with a Pharros' device.


    Do I want to use this right away? I have a spare lockstone, so I could. There's no telltale indentation underneath it, so it probably won't give me another mysterious pool of water. Might it still give me a clue about that, or offer something completely different?

    I check the walls. They don't respond to interaction, but the one to the device's left (my right) feels insubstantial. My attacks pass right through it. Odd. It still blocks my passage. Could this be what the device opens?



    I use the lockstone, and a glowing face appears in the exact spot my weapons couldn't hit. I break the wall down to reveal another room beyond. Which is nice, but what's more important is I've confirmed that I wasn't throwing away lockstones earlier. Those secret rooms they opened up were inaccessible otherwise, and have stayed that way if I'd figured out how to interact with hidden doors sooner. I had to use the lockstones to get through them.

    The next room has a ladder, which I climb to a metal chest holding a thunder quartz ring+1. An extra 80 lightning defence, but why here, of all places? True, my lightning defence is my lowest stat, by a substantial degree, at only 99, but I haven't seen much in the way of lightning attacks. I certainly don't expect them in this molten pit.


    Up here I also get a good look at what's coming. More fire traps. Should be fun.

    I find another bonfire, but it's at a lower level than the roof. If I drop down to it, I can't get back up. I mean, I could, if I actually tried. It's waist deep at best, and tiny babies have figured out how to navigate that sort of obstacle. But I'm an honest Undead, and if the designers don't want me climbing back up, I will grant them that.


    From the bonfire, the only way out is a ladder disappearing into the ceiling. I'm not so far away from the last bonfire that getting back here would be an imposition, so why not check this out?

    According to the bonfire, I've found the Belfry Sol approach. Is this related to the prince and princess, connected to the Belfry Luna? Obviously, but to what degree?

    I climb the ladder and find out.

    Belfry Sol

    At the top is a munchkin like the ones that guard the Belfry Luna.


    It asks me to join the Bell Keeper's covenant. I don't. I'm wondering now if this prince is the same person as the Iron King, and if that's also the same person Mytha pined after. I've been wondering this a lot lately, because the pieces don't quite fit together.

    The Iron King was in charge of Drangleic, all evidence points to that. But Mytha, according to Gilligan, was a queen before Drangleic existed. Either he was full of hot air, or someone has been loose with the pronouns, because every indication is that Mytha was in love with a king, not a prince.

    As best as I can put it together, trying to parse inconsistencies, Mytha loved a prince from a kingdom predating Drangleic. The prince loved a princess from another kingdom, and each had a bell tower built to show this bond. The Covetous Demon followed Mytha into the depths of her madness as she tried in vain to get the prince's attention, and neither of them recovered. The prince married the princess, or another princess, and grew up to become the Iron King of Drangleic. Or something like that. It's hard to point to a seat of power, but the fortress in the Forest of Fallen Giants is clearly connected to the Iron Keep. Not that fortress and keep are big distinctions, but you kind of expect a king to have a castle.

    Then again, maybe the prince was the Iron King's son, and it's a completely different love affair. I'll hold out for more pieces that might make the puzzle clearer.

    As all there is up here, besides the munchkin, is a fog gate, I step through.

    I'm out on the roof of the keep, under the red sky. Before I can get my bearings, a munchkin attacks me with a flaming axe.


    I kill it easily. It's hearty, but I have reach, and it's only wearing leather armour, so I can keep it stun-locked. When it dies, it drops a fire whip pyromancy.

    I can see the great volcanoes in the distance, which is ominous, but otherwise it's a lot cheerier up here than inside the keep. It may smell like burnt sulfur either way, but at least out here it's fresh sulfur.


    The roof is a wide, flat space surrounded by a tall fence. In the corners are ballistas? Ballistae? There are big mechanical bolt throwers in the corners. At the far end of the roof I can see a wizard-looking person, and there are more munchkins around as well.

    I turn left, where the fence cuts across the angled roof, blocking the way to another tower. On the other side are a pair of munchkins and a knight holding the kind of sword that should only exist as the punchline to a joke about insecurity. That's going to be fun.


    I turn to see what the nearest ballista is aimed at. A munchkin and the wizard.

    Before I can fire the ballista--or not, more likely, because I think the little guy would be all over me--the little guy is all over me. I'm still busy poking it in the eye when the wizard shows up, staff swinging as he rolls past.


    The swing misses completely. The munchkin dies and I turn to the wizard. I'm not about to give this guy a chance at doing something silly like cast a spell, so I start poking him in the back. I suspect even without the Stone Ring I could keep him reeling. He keeps trying to turn toward me, and I keep jabbing him in the spine. He's nearly dead when I run out of stamina, and by the time he finally spins in my direction, I have enough for a final attack to finish him off.

    Neither of them drop items. I fire the ballista anyway, and it looks like it would have hit the wizard. Probably wouldn't have killed him, though, and I won the fight, so I shrug and move on.

    I try firing a magic missile at the knight on the other side of the fence. It doesn't work. I can't target him, either, which should have been enough of a clue.

    So I hug the fence, moving to the far right corner. From there I can look across the rest of the roof, and find all that's left to oppose me is a single munchkin and another of the knights with the big swords.


    The munchkin is already trundling toward me, axe swinging over its head. I wait, and let it impale itself on my spear. This way I escape the big knight's notice until he's all alone.

    Munchkin dealt with, I move forward far enough to get the knight's attention. He starts toward me, sword held high in both hands.


    And things start going wrong.

    I doubt I can break his poise with my first hit, even with the Stone Ring, so I wait for the knight to make the first move. He starts with a guard break, which whiffs. Forgetting every lesson I learned in the darkness underneath the Gutter, I walk into his instant followup swing. It hurts. The high, arching slash he combos it into hurts even more. When I say it hurts me even more, I mean that I'm dead. What kind of poise do I need to counteract my rampant stupidity? More than I have, obviously.

    I respawn at the bonfire and climb back up the ladder. I swing left and fire the ballista. It hits nothing, because the wizard didn't respawn. The munchkin did, though, so I have to kill it, and the other one, before my rematch with the knight.

    This time I get the first hit, and I was right about not being able to stagger him. I'm settling in for a bit of a duel, when an invasion message appears.


    A Bell Keeper, a stronger spirit version of the munchkins, is somewhere nearby. Distracted by this thought, I take a hit and die again.

    The next time, I come to the fight prepared. I apply my weapon buff and charge straight at the knight. I have to make it quick, because the invasion message is already filling up the bottom of my screen. Roll around a swing, try for a backstab. It misses, but I get some good damage in while the knight has his shield up in the wrong direction. I can see red out of the corner of my eye, and kill the knight in time to face the invader.


    It's a beefier than the normal munchkin, like the invader I faced in Belfry Luna. Extra health, and maybe defence, but it has no more range or poise. A few stabs, a few more stabs, than a few more after that, and I win. I've banished the invader, and earned myself a rusted coin.

    The knight was guarding two towers. Inside one is a switch, inside the other is a ladder.


    What if the switch lowers the barricade on the other side of the roof and lets those guys out? I decide to check the gable roof first, and climb the ladder.

    Crossbow bolts are whizzing past my head. Another human, this one with dual crossbows, was waiting for me.


    I duck behind a nearby pillar, then rush out when he gets closer. The fight is over in seconds. As he has nothing but the crossbows, when he's in reach of my spear, the fight ends in seconds.


    From up here I can see the switch tower, and that there's a bell at its top. Right. It's the Belfry, after all.


    Back down the ladder, and I find a body between the tower and the outer fence. It holds a simpleton's spice. I pull the switch. The bells start ringing. I look across the roof and see the fence is still up. So what was that about? And what is that knight guarding if I've already rung the bell, which is presumably the reason I'm here? And what did ringing the bell actually do?

    There's another body with another simpleton's spice on the gable roof. I get to the far end, look over the peak. The munchkins start firing arrows, the knight disappears somewhere to the right, out of sight.


    I step below the peak for cover, and when I look again, the knight is on the roof with me.


    I get around a wide slash, try to stab at his back, but I'm up too high and my spear passes over his head. The knight turns into another slash, pushing me up the roof, and an arrow hits me in the back. Dead again. Of course there's a way up to the gable roof, but I shouldn't have any trouble if I fight the knight out of sight of the munchkins.

    On the way back, there's more bow trouble. I stand with my spear in hand, waiting for one of the munchkins to run over and let me kill it. It has other ideas, and starts firing arrows when I go into a 2-handed stance. I take two to the chest before dodging out of the way. Then, when I'm on the gable roof and trying to fire a magic missile at the knight below, I realize too late that I'm casting my weapon buff instead. There I am, a completely still target while the munchkins turn me into a human porcupine. This is why I don't use magic. It's too hard.

    After I get a proper spear buff, out of sight, and have my rematch with the knight, things go my way.


    For all the damage these knights can dish out, they're not good at taking it. Just like for me, there's no amount of armour that can take the danger out of getting hit. Keeping low on the roof, poking when I have an opening, I win without further trouble. Then I run down and murder the last munchkins.


    Another body, another simpleton’s spice. All that’s left is the tower. And it doesn’t have a fog gate. Not that it looked big enough to hold a boss in the first place, but this is anticlimactic.

    I open the door. Inside is a metal chest with an immolation spell.


    As the saying goes, "When there is nothing left to burn, you have to set yourself on fire." Which is what immolation is all about.

    I take the stairs offered, going back down into the keep. Another body there, with an effigy and snake troches. Temporary resistance to petrification.

    I follow the short hall to the end, and I'm back where I started.

    Competitive Gaming and Writing Blog Updated in October: "Song (and Story) of the Day"
    Anyone want to beta read a paranormal mystery novella? Here's your chance.
  • Options
    Page-Page- Registered User regular
    Day 19 continued.
    Iron Keep


    So that was that? I rang a bell and smashed a few action figures. Nothing happened, and there was no boss to fight. Perhaps it's an online thing, or I might find out more later on.

    Anyway, let's try this area again. I warp to the lower bonfire and use the effigy I picked up.

    This time, I kill the knights on the bridge before the ironclad has a chance to get away. What will it do?


    I can see the exact spot it's breaking. Is it safe to cross? I get close enough to poke the ironclad. It doesn't like that, and chases after me, crossing the half-broken section of the bridge, which falls away beneath it. I lead it to the middle of the bridge, block a sideways swing of its club, get behind it. And remember, again, what that means. The ironclad flops onto its back, crushing me into the hot metal. We stand up together, but I'm faster, and kill it before it can turn around.

    With the first knight in the big room dead, I want to see what I can do before pulling the switch. There are stairs to the left, next to the Pharros' device's closet. Standing up there, next to a bunch of jars, I can see something moving below. A little greyish spot. And something else, even smaller, moving in my direction. I squint, trying to make it out, and realize only when it hits me between the eyes that it's an arrow. There's a captain down there, and the thing I saw moving is a crystal lizard. I can't hear it over the general din of this place, all that molten iron pouring and splashing.


    The crystal lizard disappears at the archer’s feet. I may as well go down there and check it out.

    I start running across the long platform. I hear a click, and something heavy shifts behind me. Another click, and I can hear and feel the new heat of hot iron flowing. The grooves I’m passing over are trenches, and by the time I’ve made it to the archer, I am trapped behind three new streams of molten metal.

    Which is tricky, because this guy has pulled a blade and neither of us have anywhere to go. We do some negotiating, and he makes a persuasive argument for my death with a sword slash that reduces me to a sliver of health. But I have my own bargaining tool. I pull out my club, close my eyes, and start swinging.

    When it’s over, I’m still alive. But I’m also still cut off.


    The only other way to go is down some stairs to a long line of flaming rocks.


    I could use a homeward bone to get out, and I'm slightly tempted to for the sake of my humanity. Yet, I don't think the game would put me in a situation like that. I should be able to get back on my own.

    I use the stairs to get a running start, and leap across the first stream. The angle is bad, and I fly face-first into the falling magma. Though it's a close call, I do survive, and heal up on the other side. This stuff isn't instant death, which is good for me. The next one I just roll across. I could line up a better jump, but I'll have to reset at the bonfire anyway to make the crystal lizard respawn, so I'm not saving the flask charges for anything else. Between the second and third streams is a loot corpse.


    After resting at the bonfire and returning, I see that the iron is still flowing. It seems like bad news at first, until I realize the crystal lizard isn't any more immune to death by melting than I am. When it tries to escape, it runs straight into a magma flow and dies.

    I blast the archer with a few magic missiles, then hop over and loot the lizard's corpse.


    With a firedrake stone, I can finally make a fire weapon and get some use out of my intelligence stat for bonus elemental damage.

    Standing at the top of the stairs, I get a good look at what I need to pass if I want to cross to the fog gate.


    Five square metal panels of roughly equal size, one in the middle and the other four connected at its corners. Each, except the closest, holds a single enemy. In the middle is a knight, while two ironclads stand at opposite corners and a big knight captain guards the panel connecting to the ledge with the fog gate.

    So the question is, what's the switch for? As far as I can tell, I can get across without it, and having those fire statues down here would only make things more difficult.

    Only one way to find out. I go down and pull the switch. The upper section lowers into place, and now there's an archer standing over me.


    As I'm blasting him, I gain the Souls from the knight on the other platform, which is now submerged in the hot iron below. When the archer is gone, I go back up the stairs and look at what has changed.


    As I thought, it's only more of a hassle getting across now. And there aren't any items or loot corpses on this platform.

    So I pull the switch again and take the platform without any fire-breathing statues on it.

    One of the ironclads marches cross to attack me. I wonder if I could get back to the switch fast enough to dunk them in the hot iron, too. When it dies, the ironclad drops an ironclad helm. The Old Iron King had a Greater Soul, obviously, and it was the source of his power. He's likely the next boss I face, but didn't the Smelter Demon kill him? Maybe that's supposed to by symbolic.

    I have an idea. I pull the switch to lower the fire platform. The statues might give me some cover from the captain, and maybe I can get the ironclads to run into the fire.


    Of course not. And this guy gets a lucky hit in. I see it raise the hammer for an overhead smash, so I step back and go into a 2-handed stance, ready for a counter-attack. I don't get the chance, because the ironclad runs forward, hammer still raised, and splattering me all over the ground. When I stand, it starts swinging. One, two, three, four attacks. I back off, wait them out, heal. Another overhead smash, the vibration of the impact so strong that it staggers me even when the attack misses. Horrible thought: what if the entire platform goes down while I'm standing on it? I kill the ironclad before it can attack again.

    Since the fire statues aren't helping me, I raise the platform yet again. The archer captain draws, and another knight wanders in from somewhere to my right, getting in my way. I know the timing of those arrows well enough that I can kill the knight before another one comes my way. The captain draws his sword.


    I let him slash, and circle around. I wonder if I can backstab him? He's pretty big, as enemies go. I lash out with a kick at the back of the captain's knee, but he's already hopping away from me, and it misses. Odd. I've never seen that animation before. I let him have another free attack so I can try again. This time the kick connects, forcing the captain to kneel, and I shove the spear through his heart, killing him in a single blow. So there's a different animation for enemies too big to lift. Neat, and I'll have to be more adventurous with the enemies I try to backstab. I grab a Soul of a Nameless Soldier from a the ledge one of the ironclads was guarding and keep moving.

    Next up is a series of fire-spitting statues, the final ironclad, and the fog gate.

    But I have two questions. First, what is the purpose of this big, black button on the ground? Second, how do I get to this ladder hanging in the air?

    darksoulsii-2016-02-07-13-22-00-80.jpgNot complicated questions, and I get the answers soon enough. The ladder must be the reason for the switch and second platform, and the button controls the platform next to it. Good thing I noticed before making a terrible mistake, because whatever is on one of those platforms after the buttons gets pressed is going straight into the magma.darksoulsii-2016-02-07-13-22-54-87.jpg

    I pull the switch and climb the ladder. It takes me to an upper floor, about level with the way out of Belfry Sol. As I roll through a few water jars underneath what looks like an opaque stained-glass window, breaking them apart, a knight comes down at me from the nearby stairs. I'm half-done skewering him when another shows up, but I'm not selfish. I kill him, too.


    At the end of the ledge is another ladder, and beyond that a wooden chest. I'm wondering if I can open it from the side and maybe dodge a mimic chomp without having to attack it, when an invasion message appears.


    Oliver the Collector is here, and it looks like he wants what I've got. If that's the case, he'll be sorely disappointed when he finds I've nothing more than a lowly club and spear. Though I suppose there's some value in a full +10 lightning spear.

    Or maybe he's just doing it for kicks these days, because he looks fully loaded already. As he gets closer, I can see he's holding a spear in one hand and a big sword in the other.


    I let the spear bounce off my shield, and get a few pokes of my own in. I can stagger him with a couple hits. I assume it's because he's having to cut back on armour to carry what looks like half a dozen different weapons. The first exchange of blows over, he backs off and pulls out a huge club.


    He tries for a guard break, but I'm not falling for that again today. I roll back, and he's spinning in circles like a hammer thrower. I take a solid hit as I stand, but he doesn't press the issue. Instead, he changes weapons again, and now it looks like he wants to fight bare-handed.

    I give him some space, not sure what he's up to. He gets closer and starts trying to stamp on my feet. Or maybe not. Each footfall sends out a shockwave that bounces me back a bit. That's not so bad, so I start poking him again. When he's nearly dead, he pulls out the club and tried for another guard break. I dodge this one as well, so he pulls out a sword and bounces that off my shield. It's a tense moment, because I haven't had a chance to heal from the club hit, and either of us is likely to die with the next attack. I decide I can't let him pull something else out of his ass, and make the first movie. Oliver dies, I gain a few thousand Souls and an awestone.


    Inside the wooden chest--which I cannot open from the side--is a stack of destructive greatarrows.

    I climb the ladder and find another Pharros' device, along with more stairs. It's a small room built around this ladder, and I guess the keep sank before someone could pit in stairs. As it is, if I drop down, I cannot get back up.


    But I'm here already, so why not?

    I check out the Pharros' device. It has a ittle well below it, so something will pour out of the eyes. More water? Is it connected to the one below? Will it give me some clue about what it's for? I plug my last lockstone in.


    So I have another puddle to play in. Nothing else happens. I'm not sure what to make of this yet. I'll leave it on the back burner for now.

    The only way out is up, so I climb the stairs.


    The burnt sky comes into view, and before I reach the top I can see a pair of knight captains waiting for me. By the time I do reach the top, it's worse. There are three in total, guarding a chest and a big hole, and the same lazy builder who decided not to build stairs to the ladder below also decided not to build stairs up to the stairs. That is, they end in a short drop, so if I go out onto the roof I'm not coming back this way.


    One of the archers takes a shot at me, and I back up, down the stairs and out of sight. They're slow enough that I think I can deal with them all, and there's no reason to keep delaying the inevitable. I buff my spear and leap out onto the roof.

    As battles go, it's not a story for the ages. But I'll take a workmanlike victory over none at all. I hit the archer on my right first, as he's both the most isolated and closest. He goes down, but I take an arrow the size of a small tree in the side, losing half my health. The next archer is eyeballing me in a way I don't appreciate, and I don't want him drawing a blade yet. So I back off a bit, dodge the next volley of arrows, and move in for the kill while he tries to switch weapons. With only one archer left, I have the space I need to take a sip from my flask. The final captain draws his blade and dashes past me. So I stab him in the back.

    There is something odd in the distance. A towering spire of stone stabbing up from the volcanic landscape beyond the Iron Keep. Temple-like structures are carved haphazardly into its surface. Reminds me a bit of termite mound. What is it doing there? Who built it? Is there a way over?


    A loot corpse in the corner holds a simpleton's spice, fire arrows, and titanite shards, while the chest has a Black Knight Greataxe. At 40 strength and 10 faith, it's too rich for my current means, but I like the added fire damage. The move list is generic, but it has good reach and nice damage for its weight. Might be worth considering.


    Since I can't go back down the stairs, I have to use the hole in the centre of the tower. It's lined with platforms, and will presumably take me to the area past the fog gate.


    After a few mild falls, I'm standing above a smelting pot full of hot iron. Next to it is the narrow final platform, with a knight waiting at each end. I can hear, and soon see, the heavy iron chains pulling and grinding endlessly against something in the magma far below.

    There's a loot corpse hanging off the rim of the smelting pot. All this to drop down onto that. I'd better not miss.


    I stick the landing, and retrieve my prize.


    Considering I got the Covetous Gold Serpent Ring+1 when I first entered the keep, this isn't the pot of gold I hoped to find. If not for the Black Knight Greataxe, this would be a wasted trip.

    Feeling a bit put out, and not wanting a stupid death in such an awkward position, I buff my weapon before dropping down to the final platform. I needn't have bothered, because the knights are completely oblivious. I'd imagined them trying to sandwich me, coming from both side to skewer me while I couldn't get away. But I'm practically up the first knight's nose before he notices me, and by then he's already dead. The second doesn't do any better.

    I drop down to the curving stairs below. There's the fog gate.


    I step through, remembering at the last possible moment that there's an ironclad waiting on the other side. By the time I regain control of my movement, the hammer is already coming down. I roll forward, avoiding the hit, and kill it. Easily done with my weapon buff still active.


    A nearby corpse holds a monastery charm and an Undead Soul.

    What's my next move? I've cleared this area out, but I'm down to 3 flask charges, no more spells, and my spear has only 10 durability left. On the other hand, with that detour I'm relatively close to the bonfire, and it's only about 45,000 Souls at risk.

    Back to the smelting room and down the stairs. I turn a corner and find an ironclad waiting in a narrow metal corridor.


    It nearly gets me, as I'm still working on my timing and positioning for baiting attacks. I run out of space in the corridor, and while fighting on the stairs I take a hit and have to run all the way back to the fire-spitting statues to heal. But I do, and then come back and kill the ironclad.

    A piece of rusty metal serves as a gate near the far end of the corridor. It's purpose? Beats me.


    I pull the switch in the wall, and the metal rises. I can see it's covered with bloody scratches, and that the bottom edge is razor sharp despite the rust.


    A good horror-movie vibe, but I'm still unsure what the original purpose was. Could be to cut the iron while it's still hot. Or it could be that the Iron King was just a raging jerk and wanted a big chopping blade as part of his decor.

    I pass under the blade, then wait for it to fall again. I knew it would, both because there's a switch on this side, and because that's the kind of thing that happens in a place like this.

    A few more steps and I can see a hammer poking out from around the corner.


    If I'd been less careful, this could have turned into a big problem. With the blade at my back, I have even less room in which to move, and it would be hard getting around the ironclad. Considering the amount of space it took for me to fight the last one, I'm not eagre to try that. And if I'd rushed in faster, I might have that blade cutting off my retreat, and a few limbs in the bargain.

    As it is, now that I can see it all plainly, I know exactly how to proceed. I turn around and pull the switch, raising the blade, then poke the ironclad and take off.


    The spear is nearing its breaking point, and I'd like to use my club. Problem is, in this confined space all my attacks bounce off the walls, limiting my damage and leaving me wide open. I get the kill with my spear, and then put it away.

    Around the corner is another fire-spitting statue. An entire room full of them.


    I wait for the fire to stop, then start again. Plenty of time to get past. The blade makes a heavy sinking sound as it drops into place behind me.

    I run down and take a left. Long spikes, likely purchased from the same interior decorator as that guillotine, cover the walls in here. A loot corpse sits enticingly under the fire of two more statues. Again, this is not the decor of someone who likes people.


    I want the item, obviously, but the timing is too strict. There's no way I can grab it without a very, very hot shower. I decide to leave it for now. If there's a bonfire somewhere ahead, I can come back, and if not I can try for it next time, when I have more flask charges.

    A final fire-statue guards the way out. And so does another ironclad. I take a step past the statue and there's a hammer swinging for my face. With the fire licking my back, I have to take a hit, but I dodge back into the open once it stops.

    The ironclad tries to follow, but for once the traps are working in my favour. It charges into the fire and roasts alive. Or dead. Or undead. The important thing is that it's gone.


    I come out onto a steep roof. I'm underneath the huge minotaur statue that I saw from the windows near the keep's entrance. Its giant hand curls around a nearby spire, and in the distance, down a path of shattered stone, is a fog gate.

    I think this is it, but what's over there? I can see what's beyond the fog gate, and it isn't much. A small island of paving stones facing a hellish sea of fire. Not much room for a boss fight.

    The only sound out here is the lapping and bubbling of the magma. All I have is my club. I look around a bit, for extra loot or maybe a bonfire. Neither turn up. There's no debate here. This is the boss fight, and though I'm unprepared, I am not going back.

    The last thing I see before stepping through the fog is that ominous tower.


    Competitive Gaming and Writing Blog Updated in October: "Song (and Story) of the Day"
    Anyone want to beta read a paranormal mystery novella? Here's your chance.
  • Options
    Page-Page- Registered User regular
    Day 19 continued.
    Old Iron King

    I'm not sure what I expected. All indications were that the Iron King was not a good guy. He might even have been a bad guy, in the conventional sense, by the end. He certainly doomed his people, and paid the price for it. Having your coveted iron manifest as a giant beast to cut you down in your own home is a bad day for anyone.

    The corruption must have run deeper, because what I find is far beyond Undead or Hollowed, and closer to demonic.

    At first, I'm not so sure. A cut-scene plays, a pulse of red--is that how I can tell I'm up against a Greater Soul? There's something under the surface of the magma, moving toward me. A head emerges, huge curved horns, a face you'd only expect to see on a statue carved out of the sculptor's nightmares. A curved back, and leathery wings. The Smelter Demon's big brother? Whatever it is, it sees me, and starts coming toward me. And not for a chat.


    When the cut-scene ends, I'm standing on the little stone shelf--it feels smaller now that I can see what I'm up against. The beast towers over me, taking up most of the screen before it's even close enough to fight.


    What it actually is remains an open question until it takes the first swing and the life bar appears. This is indeed the Old Iron King after his Soul spent untold years laying in the hell he created for himself.

    The demon starts aiming clobbering fists at me. I dodge the first, but not the second. It nearly kills me, but I'm able to recover and use my final flask charge. Then it starts breathing fire, a wide arc of flames that crawl along the ground. I back away to find a gap. This puts me around the corner of the broken building. The Iron King gathers flames in his hands, and I'm trying to move back out into the open space nearer the fog gate so I have more room. A concentrated beam of flame shoots out at me from the Iron King's palm. I don't die from that, but I do die when I land in the small pool of magma that separates the building's front wall from the stone island.

    All that work to get back to him. I still don't regret the Company of Champions, but perspectives change now that I know things could be different. Hopefully it doesn't come to so many runs that a different covenant would make a difference. But imagine if I'd skipped the Smelter Demon. I'd have to run the entire Iron Keep, or at least Belfry Sol. Which might not be so bad, since only the munchkins respawn up there.

    On the way back, I decide to try for the item under the flame statues. I die--might have survived with more fire resistance and some extra health--but I do get the item. It's a lightning shortbow+1.Could the Iron King be weak to lightning? I think it's good against armour, but does his demonic form count?

    The ironclads are starting to drop their armour pieces. I get a chest plate. It's like the old ironclad armour I picked up in the Forest of Fallen Giants, but with better stats. Still not worth using, as it's double the weight for half the defence of what I've got on. Its special property of nullifying backstab critical hits might be useful for PvP, but not something worth crippling myself over when all I'm fighting are dumb Hollowed.

    I'm starting to work out my route. Three knights outside the bonfire, then the ironclad that smashes the hole in the bridge. If I'm fast enough there, I can trick it into knocking itself into the magma. One more knight on the other side, then the archer on the upper platform. I could leave the the switch alone and avoid it, but I have my magic missiles and it's a free kill on the knight on the lower platform, dropping him into the magma to clear the route. I can mostly avoid the ironclads in the corner platforms of the big room, and I've figured out that the archer captains can't aim their bows very well. Once they draw, I can walk right up, circle behind them, and get a free backstab kill. Or I can hit the button and drop him into the fire. So there's the captain, and the knight guarding him. Then the ironclad guarding the fog gate. In the room with the stairs, both knights drop down from their platform, but are spaced far enough that I can kill each individually. Then the two ironclads in the guillotine corridor--time that right, and the second will wander under the blade as it comes down. One more ironclad guarding the way outside. I become more aggressive with each run, as I work out the spacing. I'm able to fight with my spear in both hands without worrying about getting hit, or having to dodge attacks.

    After all that, my spear is down to about 30 durability, which is more than enough. I've also earned between 12,000 and 14,000 Souls, depending on if an extra ironclad or two notices me.

    The next time I step through the fog gate, I remember my weapon buff. The Iron King is nowhere in sight, so I quickly pull out my wand. Which is, of course, when the Iron King bursts out of the magma and coughs fire all over me. Dead again.

    The next fight goes a little better. I finally start getting hits in. I move close to his head while he's breathing fire and stab away. Then I realize in a single, horrible second, that I've made a terrible mistake, and that it's too late to correct it. He's swinging his head from side to side while he breaths the fire, and I'm caught on his horn. I'm mid animation when he sweeps me over the edge, into the magma.


    I'm closing in on another problem now. My life keeps dropping, and soon it will be too low to survive a big hit. As it is, I have just enough, with the aid of my Ring of Binding, that I can take a full fire blast and stand up to heal. A few more deaths and that might not be the case.

    Other than that, I have the fight mostly worked out. At least the first half. I stick to the right side of the island, where I have more space to back up and avoid fire. More space, but not so much that I can get careless. I learn that the hard way when I tumble into the magma while trying to dodge a crawling flame.


    As long as I have him in that spot, I can control him. I have enough room to back away and avoid his punches, or when he gathers flame into the hands and smashes them into the ground.


    I switch to the Watchdragon Parma for a bit, hoping the extra fire defence will help. It doesn't. I lose stamina faster, and end up taking even more hits from his fire blast.

    Another death comes when I take my position for granted, hugging the right wall of the building to avoid fire. After a few waves miss me, the Iron King dives into the magma, then comes out in a different, closer position. Another fire blast puts me into the magma.

    My recent trouble with the Smelter Demon has me well enough prepared for a few deaths. And unlike that fight, where I struggled for a while to find the right strategy, and longer to implement it, now I'm only working on not making a major mistake.

    So, as usual, when I win, I win with a perfect fight. I'm moving back and forth to bait out punches and then stabbing at his fists. I recognize the fire blasts early and make sure I have the space I need to dodge them. Soon, the demon is near death.


    I move in for the final hit. The Iron King falls, and as the screams fade, I get the expected message.

    "Great Soul Embraced"


    I also get 48, 000 Souls and the Old Iron King Soul. This tells me he died to the flames, and the things lurking below possessed his Soul. Demons, I guess. And maybe flames could be the Smelter Demon, metaphorically? Literally? Ironically? Whatever it is, I'm just glad it's over.


    I find a way into the building. Inside is a single chest holding a petrified something, and some stairs.

    In the basement is the Primal Bonfire, and, unexpectedly, another of those odd snake alters that I found near the Rotten's lair.


    There are more inscriptions with the alter. Another warning.


    This one has a different line. “In the tower of the Old Iron King resides a Child of Dark.” Is the tower that place I can see in the distance?

    I kneel at the alter. The warp takes me somewhere else, but not to that place underneath the tree. So this is a completely different mysteriously locked door.


    Maybe this is the bottom of that tower.

    I look around. More of those weird grave-looking things, and another message channelled from far away. I’m still miffed by that wording. What is it supposed to mean?


    I warp back. I wasn't expecting two of those places. Maybe they're not connected to the second half of the game after all. One of them I could see as the way to a final boss, especially when it's found at the bottom of that pit. That seems to be the furthest area I've found, and would make it the most distant of the Greater Souls. Then again, the Primal Bonfires are one-way, so I couldn't get back there without running through some enemies. I think the final area will be more closely connected to a safe bonfire.

    I rekindle the Primal Bonfire here and warp back to Majula.

    As usual, the general populace greets my triumphant return with a resounding shrug. I tell myself it's not that they don't care about me at all, but that they're all falling further into that collective madness.

    Lenigrast, the blacksmith, has some choice words to share about Gilligan. They're form the same hometown, and Lenigrast tells me Gilligan is a conniving jackal when it comes to money. I hear that.


    The real question is how Lenigrast, Gilligan, and Chloanne are all from the same town, but each have wildly different regional accents. Lenigrast and Chloanne are even related. In land full of mysteries, that's still near the top of the list.

    I upgrade my club to +8, running out of titanite in the process. I'm the odd position of having more titanite slabs on hand than chunks. My Drangleic Shield is also stuck at +4 until I can find more twinkling titanite. Will I ever have a reliable source for them? Maybe it's too late to try a more exotic weapon. I'm also concerned about my petrified dragon bone supply, remembering that in Dark Souls I missed one dragon scale and couldn't get the full +5 on my Dragon Greatsword.

    I also upgrade my jester's cap to +6. It looks all kinds of stupid, but it has better numbers than the monocle.


    Another flame appears in the map room. The last one should be inland. But who does it belong to? And which way is east? If I put the coastal fortress in the Forest of Fallen Giants as north, meaning I'm looking at the map upside down, east is inland, the direction I've yet to fully explore. So, this fabled dragon shine will come.

    Maughlin is now selling a complete set of Smelter Demon armour. I buy it, and other random bits to fill out my collection. Wish other vendors here were as diligent about getting new stock. The Demon's armour seems pretty good. High defence for the weight, and very high fire resistance. The only major weakness is against poison, which, really, who cares? With the Soldier Ring on for more equip load on top of the First Dragon Ring, I finally have some new duds.


    It's not ideal, but any change is a good change after so long with that same gear. And it does have a certain ugly charm.

    Back to the Iron Keep, where I speak to Magerold. Why is he still here? I buy everything that I can. The Cursebite Ring, the rest of the jester's motley, and all the bandit's armour, a few spells, and the repair powder. That's all of it. But he's got nothing new to say, so it looks like he's not going anywhere. And the knight with the big, blue sword. Was he ever here? I saw him last headed in the opposite direction. Maybe Magerold will move his shop over there, toward Brightstone Cove.

    I've been all through the keep now, and nothing has stopped the fire traps, or done anything about the flaming stones. I'm patient, and was content to wait for something to happen. Three Pharros' devices and two bosses later, I know that if something happened, I missed it.

    Maybe it's a matter of stacking fire resistance. I did buy that demon armour, and it has the best fire resistance I've seen. With it on, and the Flame Quartz Ring as a bonus, I approach the first fire statue.


    Maybe I can, maybe I can't. Maybe I need more health. But I've got nothing to lose from trying.

    I nudge close to the item. Can I just reach over and grab it without getting fried? It doesn't work. When I bend down to pick it up, I stick my face into the fire. I die, but I an Iron Key. Which opens an iron door, somewhere. Not in the Iron Keep. The description says that people came through and looted the place after the Old Iron King's death, taking everything not nailed down, including doors. Where have I seen a door that looks like it belongs in the Iron Keep? Because I know I have.

    I recover my corpse, then try the flaming stones under the bridge, next to the first bonfire. Still almost instant death. Maybe with enough healing over time I could make it to the item, but there's no way I could pick it up and get back safely.

    But I got the key. Maybe it will get me what I need.

    The first place I think of is the tunnel under Heige, the one that leads down to No-Man's Wharf. There was a big black door down there that was the same as the Iron Keep's front door.


    It's a dead end. Should have remembered that.

    The doors are bent and fused, and no key will help open them.

    What else? There’s that big, black door in the fortress on the coast.

    Competitive Gaming and Writing Blog Updated in October: "Song (and Story) of the Day"
    Anyone want to beta read a paranormal mystery novella? Here's your chance.
  • Options
    Page-Page- Registered User regular
    Day 19 continued.
    I warp to the Forest of Fallen Giants, but get a little lost. After some wandering, I end up in the sub-basement, near the fight I had with the last giant. And there is a door down there that was always locked.

    This isn’t an iron door–it’s clearly wood–and this fortress belonged to the Old Iron King, so it makes no sense for it to have been stolen. Nothing about it matches the key’s description. But the door opens anyway.


    On the other side is a big cavern. Continuing the theme, and a good sign that I'm going the right way, are the flames and scorch marks that paint the ground, wall, and ceiling of the cave. I've found the way to those flame salamanders.

    Inside, the very ground itself is a field of low flames. Not so much that it hurts to walk on, but I get the point. Whatever lives in here likes fire a whole lot.

    The first salamander is on my left as I enter. I've wanted a shot at these guys from the first time I saw them. I rush to attack.


    It doesn't go so well. The salamander lashes out with a whip-like tongue, breaking my guard and taking out half my health. I'd soon find that most of its attacks go right through my guard. As it's bobbing its head, I stab it in the face. The damage is minuscule, not much more than a scratch. The salamander jumps into the air and lands a belly flop on me. The shield does nothing. I die.

    This isn't going to be easy.

    A couple more attempts reveal the extent of the problem. I can barely hurt the salamander with my spear, and the club does even less. The sharp blade-like ridge on its head cuts through my guard like butter, making most of its attacks unblockable. And that's not counting it breathing fire, which it does regularly. I try getting around that, but it tracks faster than I can run. If that weren't bad enough, there's another salamander further in the cavern that sits back and belches fireballs at me while I fight. Even if I get my shield up, or dodge them, the explosions obscure my vision and I can't see the next headbutt before I'm laying on the ground in two pieces.

    I do eventually kill the first salamander by fighting it at the doorway, where I can see the fireballs coming and get behind cover. It gives maybe 1600 Souls and drops no items. And then the one in the back is pounding after me.

    I back out to the hall and heal. When I go back in, the second salamander has returned to the back of the cave, where it's running endlessly into a wall. I can see a loot corpse near it.


    On the left is a wide ramp going up to what I assume is the ground floor of the fortress, with the pillars of fire and the salamander near the elevator I have to ride to get down here.


    I check out a corpse near the wall and pick up a pair of cracked red eye orbs. The salamander is still running its invisible treadmill. Maybe I can grab the item it guards without the salamander noticing.


    I get half of that done. I loot the corpse, but the salamander definitely notices. This was the one shooting fireballs into the valley at the bottom of the outer wall when I came through the fortress originally. The first salamander I saw, and the first I wanted to kill.

    My dream doesn’t come true. It turns and breaths fire at me, a long flame that sweeps back and forth. I manage to survive the first time, but I’m desperately sucking a bottle charge down when the fire comes back on its return leg, and die.

    All in all, it’s a lousy situation. But I’m determined to see it through, to solve the mystery so I can move on. I check out my loot. The Rebel’s Greathshield belonged to Raime, who was the king’s left hand until his partner declared him a traitor. Bad physical defence and on the low side for stability at only 65, but everything else is nice, including the 90 fire defence. Too bad I can’t hold a shield up while I grab items.

    The heavy iron key is another matter. It says it opens the way to the tower the Iron King used to mine his ore. Is that the thing I saw sticking out of the lava?

    Those are all the items in the cave. All that’s left is whatever is up that ramp. But that means getting through those salamanders again–I find out, on returning for my corpse, that they respawn.

    In my hour of need, I decide to resort to some cheese. I tell myself that if I’d not built for magic I’d have other options. Whatever helps you sleep.

    After another difficult and drawn out kill on the first salamander, which nets me an awestone, I check the ramp. It’s as bad as I feared. Worse, even.


    The salamander guarding the top isn't going to move. It sits there belching fireballs that I can't defend against, and there's no way I can get to it and away safely. Or that I could kill it before it dropped another fireball on me, which I can't survive even with all my extra fire defence.

    So, like I said, cheese time. Which means magic.

    I start with a little experimenting. I equip that chameleon spell I picked up a while back. Maybe I can sneak past them and save myself the trouble.

    It doesn't work like I expected it to. Not at all. I don't turn invisible, or partially so, and I don't exactly blend in with my surroundings. Instead . . . well, see for yourself.


    I can see how this would be interesting in PvP, but is a box going to make it past the salamanders?

    I go out slowly, casually, like a box on the way out for a pack of smokes. Nothing to see here. Somehow, I get past the first salamander and make it to the ramp. I don't get much further.


    I could give the first salamander a wide berth, but I'll have to crawl under this one's belly to get past it. It doesn't give me the chance and starts preparing a fireball. At least I can see what I'm up against. I squeeze past and come to the hall of fire. And there's yet another salamander up there, with a fireball ready. I die again.

    So I have to kill at least three salamanders if I want to see what's up there. The second one in the cave will ignore me and hug that wall after I kill the first, so I can leave it alone. But still, that's a big ask.

    I kill the first salamander, then use my magic missiles on the one guarding the ramp. It's a bit tricky because the targeting doesn't want to stick to it unless I'm way too close. I can go out and explore the ground floor now.


    I loot a corpse holding a Hawk Ring--extra range for arrows--and a firedrake stone. Is that what these things are supposed to be? The Hawk Ring belonged to Blue-eyed Durgo, who used it to win many "valiant" victories. I use quotes there because I don't see the connection between cheesing someone out with extreme range and valiance.

    No, the irony is not lost on me. But, in my defence, I'm not making a claim for a fancy title or a knighthood. I'm just an Undead with enough curiosity to kill a barrel full of cats.

    The final salamander, or drake, or whatever, is holding its ground. I can see it's guarding a chest. Eventually, a fireball catches me, and I die.

    Maybe the answer is doubling down on my fire defence. I put on the heavy Smelter Demon helm. The horns are so big that I can barely see what I'm doing.


    That doesn't help. So what do I do? The last two salamanders won't move, so I have to throw magic missiles at them. Problem is, I run out.

    I start by dropping my buff spell and using both slots for great heavy soul arrows. It's still the best ranged spell I can use, and I have two of them, so why not take both? Now I have 20 charges, which, along with a few well-placed stabs, gets me past the first salamander and the one guarding the top of the ramp.


    I wonder about my next move for a bit, then remember that I have a backpack full of different flavours of dusk herbs that restore spell charges. So I use one, get all my charges back, and kill the last salamander.


    My prize, after all that? Nothing more than a Flame Quartz Ring+1 in the chest. A whole +80 fire resistance. The answer I was looking for is not here.

    And this new key? If it leads me to the tower, that's likely a different area. After all the trouble I went through here, I'm not going through that much work to find another dead end. Whatever it is that I need to get through the fire in the Iron Keep must be in the Iron Keep itself.

    What do I have? A bunch of flaming stones and a couple shallow puddles. Those puddles mean something. I didn't spend two lockstones to improve the Iron Keep's resale value with a couple of nice water features. What's the connection?

    Something about that trip through the tunnels under Heide comes back to me. While looking over the iron door down there, I noticed footsteps. I thought at first they were an indication that someone had been that way, which is impossible because of the door's condition. Then I realized they were my own. Water flooded the tunnels long ago, so I was all wet. Looking back, there are times when I had footsteps, and times when I didn't, all through the Iron Keep. Then I remember the jars full of water. And the Pharros' devices themselves. How they're placed.

    I warp to the Iron Keep and fight my way up to the first set of jars, in the room overlooking the fire-spitting statue in the lobby.


    I roll through them, and now I have a nice trail of wet footsteps following me.


    There is some sort of effect, at least visually. The jars only annoyed me before. If I could just move them, I could pour water onto the fires.

    Things are starting to add up. What’s the safest way to check this out? I run back to the first bonfire, where there’s a single fire stone with a loot corpse. This time, I make it to the corpse, picking up an effigy, before I die. That’s a marked improvement over my last attempt. The water does help.


    Next is the longer line of fire stones under the bridge.


    I put on as much fire resistance as I can and drop down. It takes a couple of attempts, the first going wrong when I forget to jump, but there are safe stones between the fire stones where I can heal. The last one is a bit tricky, as I have to land and jump immediately or burn to death, but I can do it if I keep moving.


    Two more sets of fire stones. One below the bridge outside the Smelter Demon's lair, the other in the room with the switch and the lowering platforms.

    I'm part-way through the first area when I step into the Smelter Demon's lair and get a surprise. The Pursuer is back, floating up from floor in the middle of the room.


    I'm not at all prepared, overweight and lacking my rings and buffs, but I give it a go anyway. It goes alright for a while, but my lack of speed catches up with me in the end, and I catch a blade off my face.

    I warp to the bonfire above the Smelter Demon and come down with my proper gear. This time, the fight goes just fine. It's a stronger version of the Pursuer than I've ever faced, but I have its attacks committed to memory. I start with my club, but switch to my spear when the weapon buff wears out, relying on that counter-attack damage boost.


    It still takes a while, but a win is a win.


    I gain a few Souls and it drops the Ring of Blades+1. The vanilla Ring of Blades, which I already have, adds a flat +10 damage to all my weapons, but this one is different. The damage bonus scales, seemingly dependant on the weapon's stat bonuses, or overall power, whichever is higher. Some experimenting gives me the base numbers. A weapon with D or C scaling gets +15 damage, a B scaling gets +18, and an A scaling is +35. Weapons with no scaling also get +35, and I don't have any S-scaling weapons on hand, so I'll assume that's +35 as well. Better for my club than for my spear (what isn't?), but an improvement either way.

    The next set of fire stones is under the bridge outside the Smelter Demon's lair. I fight my way up to the Pharros' device and the pool of water. Stepping through it gives me the wet footsteps. And maybe my armour is a bit shinier, or maybe that's the lighting up here.


    That's only one half of the problem solved, as I soon find out. The chest down there is past two and a half fire stones, without any safe stones between them on which to heal.


    Even if I could survive running across two fire stones--which is a stretch--I'd have to pull the chest open and then grab the item, which is a much longer process. And then make it back. I can't see that happening.

    With an old radiant lifegem's heal active and all my best fire resistance gear, I don't even make it to the chest before going up in smoke.

    I only have 6 vigour, and less than 1000 total health. That's an obvious hindrance. But even if I had twice as much health, it would be very, very close. There has to be something else.

    My base fire resistance with my best gear and the Flame Quartz Ring+1 is 346.


    Stepping into the water adds a flat 300 fire resistance, putting me at 646. My stat screen also shows that getting soaked drops my lightning resistance to zero. Something worth remembering.


    That's not cutting it. Do I leave, keep going till I have even more fire resistance and health? I'd rather not. What else can I do?

    I have all that pyromancy that I never use, including the flash sweat spell, which says it reduces fire damage. I return to the bonfire and equip that spell. Back at the Pharros' device, I find that it adds another 300 fire resistance, putting me at 946 in total. Will it be enough?


    It is. There must be a threshold of resistance to hit, because now the fire only tickles. I could stand in it for days.


    I grab the loot, a Phoenix Parma, another fire-resistance shield, and move on to the final group of fire stones.


    Easily done with my newfound powers. I get a chaos storm spell from the chest, and a fire seed from a corpse under the stairs.


    So what about the other Pharros' device? The first one was above a chest, but the other one is way up at the top of the keep. The second chest wasn't an issue, as there are water jars next to the stairs leading down to it. Is there something else I've missed?

    I climb all the way up. There's nothing in the room with the Pharros' device, and no way back down, so it's not as if I could use to go back down the ladder and get that second chest. Not only that, but there are water jars out on the roof with the archers. So the only place I could get to with the water from the Pharros' device already has water. If I'd figured this out earlier I might have saved myself a lockstone.


    Even then, what's the reason for getting wet here? I suppose I could carry it down to the room with all those fire statues and pick up the lightning shortbow, but I think the water in the previous room is, if not as close, easier to access.

    In a fit of madness, I think that maybe the reason for having water at the top of the tower is for something at the bottom. What is the one place I could only reach from up there? That smelting pot is.


    I'd like to pretend it never happened, but it did. It makes no sense any way you look at it, but honestly, I'm tired, and not thinking straight. In my mind, it seemed maybe not reasonable, but possible that there was another item in the smelting pot itself, buried in the hot iron. After all, there was an item that I couldn't see under the poisonous water in Earthen Peak. Speaking of, could the poison from the Pharros device there be a milder sort of poison than the water, allowing for a temporary inoculation? It doesn't matter anymore.

    Anyway, there I am, standing over this pot of molten iron, seriously debating whether to dive feet or head first. I'm soaking wet, have my flash sweat going. I drop to the rim and nudge the liquid with my big toe.

    And die.

    All I'm thinking then is that of course I'd die, because even if I could survive inside there, how would I get back out?

    Lesson learned.

    What about this heavy iron key? Is it really a way to that tower? I return to the Primal Bonfire and use the alter.

    I approach the door there. The usual message telling me it's closed doesn't appear, and when I touch it, it opens.


    Nothing inside but an elevator and a switch. I step onto the platform. It carries me up to a big fog gate. I can hear wind on the other side. The key promised another world, but so far this is on the mundane side.


    At least I have something to do tomorrow.

    Competitive Gaming and Writing Blog Updated in October: "Song (and Story) of the Day"
    Anyone want to beta read a paranormal mystery novella? Here's your chance.
Sign In or Register to comment.