Trouble playing S.T.A.L.K.E.R.?

EinEin New Jersey, USARegistered User regular
edited May 2007 in Help / Advice Forum
I managed to get this game the other day, and I've patched it to 1.0001 as recommended to me, but I don't seem to be able to actually play it.

While the program is running, it will tend to lock up for 5 seconds, run for 5 seconds, lock up for 5 seconds, run for 5 seconds, ad nauseum. This has rendered me mostly unable to play it - even the THQ logo and the other things that appear on startup follow this pattern, as well as the menu and, if I can actually make it that far, the game itself.

I did actually make it a decent way in without any trouble on my first attempt at playing - I was going through the tutorial when my computer randomly restarted. I'm taking this to be a heat issue, perhaps, and have subsequently cracked open my case and pointed a decent fan at it's internals to try and cool things off, though it wasn't all that hot to begin with.

My computer:

Compaq X Gaming PC
Intel P4 3.2 GHz
1024 Ram
Radeon x800 XT graphics card
2x Radeon 7000 to run secondary monitors (disabled for the purposes of trial and error fixing)

I've updated my drivers for the x800 about two-three weeks ago.

I originally tried running it in 1900x1200, which was a bit ambitious but I always like to try it initially with my games to see how well the computer can cope with my main 24" monitor. It was actually working alright till the initial shutdown.

Any ideas? I can't quite figure out why my computer would just shut itself off halfway through playing the game - I figured it might be a heat issue - but I don't see what that would persist with the case open and a hefty fan on it. I just can't figure out how to make it stop running so choppy.

btest3.gif
Server info: mc.crafti.ca
Ein on

Posts

  • JWFokkerJWFokker Registered User
    edited May 2007
    Make sure you have 2GB of virtual memory allocated and kill any memory hungry applications running in the background because Stalker requires a lot of resources. You can also add -noprefetch and -nointro to the shortcut to cut back on memory usage. Also, it's unlikely you'll be able to run the game with dynamic lighting enabled, or even just object dynamic lighting with that video card, so try using static lighting first. It won't look nearly as cool, but you'll get playable framerates at most resolutions. The other option is to turn the resolution down to 1024x768 or so and enable dynamic lighting. Stalker requires about as much horsepower as Oblivion, so you get to either play it with all options enabled at super low resolutions or with most options disabled at a resonable or even high resolution. The minute you enable any sort of dynamic lighting, your FPS will be a fraction what it was with static lighting. Also take the texture settings down a notch. Everyone has problems with max texture resolution (likely because of poor resource management by the engine), so that should considerably reduce stuttering as well.

    JWFokker on
Sign In or Register to comment.