Amazon Prime videos not loading on laptop

N1tSt4lkerN1tSt4lker Registered User regular
Okay, y'all.
I'm having an issue and I can't find anything beyond "check your internet connection" and "restart computer" when I do a Google search.

My school laptop is a Dell Latitude E5470. Suddenly yesterday, I am unable to load an Amazon video. It will open the movie's page, but when I click the "watch" button, it spins the white loading circle for a few seconds and then just sits at a black screen. When I refresh the page, it goes back to the movie's landing page. I was concerned it was something with the network, but I could play movies on the Prime Videos app on my phone while logged into the wifi, and I could play movies from a desktop hooked up to the school's network. It's just my laptop. I've updated everything and restarted the laptop twice. I don't know what else to troubleshoot because everything I find when I search is just back connectivity issues or "make sure your account is up to date" or "restart your computer."

Does anyone have any idea what I could do here? Or is it out-of-date hardware issue?

Posts

  • dispatch.odispatch.o Registered User regular
    edited December 2020
    Plug-ins, ad blocker and pop-up blocker software don't play nice with Prime Video.

    Try a different browser you don't normally use. It also might be a firewall issue if Windows updated. Microsoft loves fucking up software settings like Windows Firewall, hardware acceleration and sound devices when it updates.

    edit: after the video fails to load, right click the video window and see if you can change settings.

    dispatch.o on
    N1tSt4lkerShadowfire
  • N1tSt4lkerN1tSt4lker Registered User regular
    Okay. So it works fine (but loads slow) in Edge (ugh). I ran it on Chrome on the desktop that worked, so it's something in my laptop's Chrome settings. I turned off adblocker for Amazon which didn't fix it, but the Inspector said it failed to load due to 404 and 403 errors. I'll have to dig into that at some point, but as long as I can play videos in Edge, we'll make it through the end of the semester and I can dissect Chrome then.

    It didn't even occur to me to try a different browser. 🤦‍♀️ Thank you!

  • ShadowfireShadowfire Vermont, in the middle of nowhereRegistered User regular
    What extensions do you have on chrome on your laptop?

    WiiU: Windrunner ; Guild Wars 2: Shadowfire.3940 ; PSN: Bradcopter
  • N1tSt4lkerN1tSt4lker Registered User regular
    Currently: google mail checker, pinterest, amazon and amazon assistant, google art, ad blocker, lastpass, screencastify, honey, grade transferer.

    I haven't added or changed any extensions between the time prime worked and the time it didn't, but something could have updated that's clashing.

  • ShadowfireShadowfire Vermont, in the middle of nowhereRegistered User regular
    Just for giggles, disable screencastify and see if that makes a difference.

    WiiU: Windrunner ; Guild Wars 2: Shadowfire.3940 ; PSN: Bradcopter
  • N1tSt4lkerN1tSt4lker Registered User regular
    So ultimately—a different chrome profile worked fine with a bunch of the same extensions. So I went in and removed some extensions that I wasn’t using that weren’t shared between profiles. And now it works. 🤷‍♀️ I don’t even know which extensions I removed and whether it was even that action that solves it? At some point during this time the drop-down for the Amazon assistant extension went through some changes, so that could be related? That and Honey are the only non-shared extensions that I didn’t remove.

    At any rate, if it happens again, I’ll do an elimination run with each extension and see what’s not playing nice. 🤷‍♀️ Technology!

    Thanks, all!

    dispatch.o
Sign In or Register to comment.