As was foretold, we've added advertisements to the forums! If you have questions, or if you encounter any bugs, please visit this thread: https://forums.penny-arcade.com/discussion/240191/forum-advertisement-faq-and-reports-thread/
We're funding a new Acquisitions Incorporated series on Kickstarter right now! Check it out at https://www.kickstarter.com/projects/pennyarcade/acquisitions-incorporated-the-series-2

USB Ports stopped working overnight?

GrundlestiltskinGrundlestiltskin Behind you!Registered User regular
Hey, was hoping you guys might have some insight on this. This morning I came down to my computer to work and my two external drives just weren't showing up (despite working completely fine yesterday). After some checking around it looks like:

1. All of my USB 3.1 Gen 1 ports on the motherboard work fine.
2. Neither of my USB 3.1 Gen 2 ports work.
3. Both of the front USB ports on my case work. I'm not sure which these are but given they both work they're probably the USB 2.0 connectors? I'd have to dig deeper on this one.
4. None of the USB 3.0 ports on my PCI-E USB Controller work.

It looks like I had an AMD driver update on the 4th, so I'm not sure why the drives would have worked fine yesterday but not today. It also looks like a Cumulative Update Preview for .NET Framework 3.5 and 4.8 installed today, but I'm not sure if that would be relevant.

This is my motherboard - https://www.amazon.com/gp/product/B07C57Q1XH/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1

Any suggestions for how I might resolve this?

3DS FC: 2079-6424-8577 | PSN: KaeruX65 | Steam: Karulytic | FFXIV: Wonder Boy

Posts

  • [email protected]fister8@crocoyes.fun Registered User new member
    I've been having a similar issue. I have the same motherboard, same graphics card. None of my usb ports or any devices worked, and nothing online really helped. The worst issue is mouse and keyboard no longer work, right? I'm not certain, but I'm willing to bet that if you're on Windows 10 (like I recently decided to be) that your drivers can't be digitally signed as a result of some update error. I did find a workaround, which works alright for me, and might for you since we have the same mobo.

  • [email protected]fister8@crocoyes.fun Registered User new member
    Does your keyboard work on startup? I'm assuming yes because you were able to reset the bios. You're gonna need to go into the BIOS again

  • MugsleyMugsley DelawareRegistered User regular
    You said there was an AMD driver update, but the updates you list look like Windows updates.

    Check your motherboard manufacturer's website for USB drivers. Even if they're old, try reinstalling to see if that fixes the issue.

    As noted above, try updating the BIOS or otherwise check if the BIOS got reset.

    You can also check Device Manager to see if any of your USB 3 related items are throwing errors at Windows and for whatever reason not being detected

    Another option is to replace the motherboard battery, but I doubt that's the issue.

  • ShadowfireShadowfire Vermont, in the middle of nowhereRegistered User regular
    If there was an update you can go into device manager and roll that driver update back. If you select that it doesn't work correctly it will block the update from happening again for a month or so.

    WiiU: Windrunner ; Guild Wars 2: Shadowfire.3940 ; PSN: Bradcopter
Sign In or Register to comment.