As was foretold, we've added advertisements to the forums! If you have questions, or if you encounter any bugs, please visit this thread: https://forums.penny-arcade.com/discussion/240191/forum-advertisement-faq-and-reports-thread/

Windows 10 walk away settings

deathnote666deathnote666 Registered User regular
I have a windows 10 20H2 home HP laptop.

I switched from a win 10 pro 20H2 Toshiba laptop that was upgraded from older versions of 10.

I had it on Toshiba that it would sleep in an hour and lock afterwards. No other prompts for passwords.

On the new HP, if I'm away more than a few minutes, it locks despite the power settings. If I turn dynamic lock to never, then it doesn't lock when sleeping/hibernating.

Is this a HP issue or windows 10 issue? Some sort of proximity sensor in HP that I don't have controls to, windows 10 home/pro option availability, or something lost from older windows 10 versions not present in a fresh install of 20H2?

Posts

  • SanderJKSanderJK Crocodylus Pontifex Sinterklasicus Madrid, 3000 ADRegistered User regular
    I haven't encountered this going wrong, but I'd guess the solution is in this screen:

    p3vg8uhousot.png

    One of the worst things about Win10 is settings being in 2000 different unconnected, hard to find submenus.

    Steam: SanderJK Origin: SanderJK
    SmrtnikShadowfireMugsleyPailryderSiskaurahonky
  • deathnote666deathnote666 Registered User regular
    Thanks but my only options for Require sign-in are: Never, every time, 1-15 minutes.

  • ShadowfireShadowfire Vermont, in the middle of nowhereRegistered User regular
    Just out of curiosity, is this a work laptop?

    WiiU: Windrunner ; Guild Wars 2: Shadowfire.3940 ; PSN: Bradcopter
  • deathnote666deathnote666 Registered User regular
    Personal. Win 10 home. Not on a domain.

  • PailryderPailryder Registered User regular
    so in win10 there is the power and sleep "settings" page but there is also the power settings section. I've seen those not be in sync before and i had to force a change by looking up the command line stuff. other things that can impact this potential are removing the suspend option and my brain just died but i think theres one other setting that can affect this. let us know!

    Burtletoy
  • BurtletoyBurtletoy Registered User regular
    I always have the issue where some random program decides to interrupt the sleep cycle and I have to run powercfg on a command line prompt weekly if I want my PC to go to sleep. These apps seem to take control without notice, regularly.

    But I guess that's the opposite problem of the sleep cycle working too good

  • deathnote666deathnote666 Registered User regular
    The laptop still goes to sleep but I want it to still want to ask for my password after it comes out of sleep.

    The problem is after a minute or 2 of it being closed, it considers "I'm away" from it and locks it on its own. This is what I want to stop. If I set it to "never", it stops this but doesn't lock it when it goes to sleep or I put it to sleep/hibernate manually.

  • PailryderPailryder Registered User regular
    so to restate, you want it to ask for a password when you force a lock (control alt delete or windows key + L) but you don't want any kind of timeout? And when you say close, you mean closing the lid down? I don't think you can change anything to not make the computer think its "off" or "sleep" when you close the lid, in windows at least. There might be some hardware config in the bios?

  • deathnote666deathnote666 Registered User regular
    I want it to lock when it goes to sleep/hibernate manually or times out and goes to sleep automatically.

    I do not want it to lock after 2 seconds after I close the lid.

    In power settings, there is an option to "do nothing" when closing the lid so closing the lid doesn't put it to sleep..

  • PailryderPailryder Registered User regular
    I understand now, thanks. There are three areas that can affect locking the screen. As you said, the power settings is one. There is also the lock screen settings in windows 10. Go into Settings and search for lock screen. Make sure that is what you want. Then, there is the screen saver settings within lock settings. If that is on, it may kick when the lid is closed. There's a box you should be able to uncheck, i think it's "on resume display login" or something "like" that.

Sign In or Register to comment.