As was foretold, we've added advertisements to the forums! If you have questions, or if you encounter any bugs, please visit this thread: https://forums.penny-arcade.com/discussion/240191/forum-advertisement-faq-and-reports-thread/
Options

Half-life 2 episode 2 video problems

tech_huntertech_hunter MoreSeattleRegistered User regular
edited November 2007 in Help / Advice Forum
I tried to search in the forums to see if anyone else is having this issue but search doesnt seem to be working.

So first off computer Specs
  • EVGA 128-P2-N368-TX GeForce 6600GT 128MB 128-bit GDDR3 PCI Express x16 SLI Supported Video Card
  • ABIT KN9 SLI mother board
  • AMD Atholon 2.0 Ghz AM2 Processor

  • 1 gig ram (forgot the manufacturer)
  • Seagate Barracuda 7200.10 ST3320620AS (Perpendicular Recording Technology) 320GB 7200 RPM SATA 3.0Gb/s Hard Drive
  • Windows XP SP2

    The Problem is during play of Half-Life 2 Episode 2 Portions of the screen flash Pink and purple triangles and other shapes like maybe the textures aren't refreshing correctly. This seems to also slow down game play. I didn't have this problem with HL2 or HL2 ep 1. When I ran Ep 2 like the second time steam told me my video card drivers were out of date so I updated them but the problem persisted. Then another occasion when I tried to play it said again my drivers were out of date. This time I went directly to the Nvidia site and got the latest drivers. Still having the same issue. Also before the second driver update the problem has started occurring in Team fortress 2 also which I have been playing fine for weeks. I have de-fragged my computer and had steam run a check on the HL ep 2 files and everything checked out fine but still having the same problem. No recently added hardware or software, and the only help on steam says to make sure the drivers are up to date. Anyone else having this problem or had ideas on how to fix it?

Sig to mucho Grande!
tech_hunter on

Posts

  • Options
    TetraNitroCubaneTetraNitroCubane The Djinnerator At the bottom of a bottleRegistered User regular
    edited November 2007
    I tried to search in the forums to see if anyone else is having this issue but search doesnt seem to be working.

    So first off computer Specs
    • EVGA 128-P2-N368-TX GeForce 6600GT 128MB 128-bit GDDR3 PCI Express x16 SLI Supported Video Card
    • ABIT KN9 SLI mother board
    • AMD Atholon 2.0 Ghz AM2 Processor

    • 1 gig ram (forgot the manufacturer)
    • Seagate Barracuda 7200.10 ST3320620AS (Perpendicular Recording Technology) 320GB 7200 RPM SATA 3.0Gb/s Hard Drive
    • Windows XP SP2

      The Problem is during play of Half-Life 2 Episode 2 Portions of the screen flash Pink and purple triangles and other shapes like maybe the textures aren't refreshing correctly. This seems to also slow down game play. I didn't have this problem with HL2 or HL2 ep 1. When I ran Ep 2 like the second time steam told me my video card drivers were out of date so I updated them but the problem persisted. Then another occasion when I tried to play it said again my drivers were out of date. This time I went directly to the Nvidia site and got the latest drivers. Still having the same issue. Also before the second driver update the problem has started occurring in Team fortress 2 also which I have been playing fine for weeks. I have de-fragged my computer and had steam run a check on the HL ep 2 files and everything checked out fine but still having the same problem. No recently added hardware or software, and the only help on steam says to make sure the drivers are up to date. Anyone else having this problem or had ideas on how to fix it?

    There are a couple of possibilities here.

    1.) Your videocard is overheating. Sometimes when your card takes too much heat (very likely for higher-end games pushing the limits beyond previous stuff you play), it will start to artifact the way you described. This can happen to the point of damaging the card if it happens for extended periods so for the love of your hardware don't keep playing if it is an overheat. To test if it is a heat issue, pull the side off of your case. Now point a fan into it and try to run the game. If you don't see the artifacting, its time to rethink your cooling solution. Judging by the speed slowdown you're talking about, I'd say this is probably your problem, particularly if the video card may be getting a bit old.

    2.) There could be physical damage to your videocard. If this problem is pervasive, then your card may have broken vRam or pipes on it. The 'checkerboard' phenomenon is the biggest indication of this. Unfortunately there's no easy way to test this short of swapping out another video card.

    3.) You could have faulty drivers. It sounds like you've been swapping drivers pretty often in an attempt to solve the problem. Have you been uninstalling the previous drivers? And have you been running drivercleaner or taking other measures? I've found installing new drivers over old ones is a bad idea - And even if you uninstall first, the uninstaller usually does a shitty job of cleaning up the residual files, and that can cause problems later.

    Edit: Are you having this problem anywhere besides Valve games? Now that I think about it, I've had these weird pink-texture issues before in Lost Coast, but they've been so isolated to that one tech-demo that I didn't really care, because the problem never popped up anywhere else. It seemed to be related to alt-tabbing in and out of the game. Does it look like the weird pinkness in this screenshot? Or this one? Or are you seeing less well-defined artifacts, rather than just lighting and shadow color changes?

    TetraNitroCubane on
  • Options
    RookRook Registered User regular
    edited November 2007
    When HL2 can't display a texture properly it does the pink checkerboard thing. Try validating your HL2:Ep2 download in the steam client.

    Rook on
  • Options
    tech_huntertech_hunter More SeattleRegistered User regular
    edited November 2007
    Unfortunately I did not uninstall the previous video drivers before installing the new ones. As for over heating it is possible but my mother board is set to shut down if the cpu gpu temp gets too high, maybe it could be approaching that point. Also its not the black and pink checkerboard pattern for a missing texture. Here is a web page with screen shots I took. Now they dont stay in one place they flash on and off and move around and some areas are worse than others. Here is the site http://www.huntertech.org/halflife

    I will try removing the drivers and try driver cleaner then reinstall the driver, if that doesn't work I will try the fan in the case.

    As for other games I play wow sometimes and no issues there and C&C generals occasionally and no problems there either

    tech_hunter on
    Sig to mucho Grande!
  • Options
    tech_huntertech_hunter More SeattleRegistered User regular
    edited November 2007
    So I got the driver cleaner and uninstalled my video drivers used the driver cleaner in safe mode and still having the glitches. Even put all video settings down to lowest level still same problem. So I go to open my case and I notice my video card fan is not spinning and it feels like you could cook some bacon on it pretty good. Do Dead fan causing my GPU to heat up causing the glitches. Guess I get to upgrade now :)

    tech_hunter on
    Sig to mucho Grande!
Sign In or Register to comment.