Club PA 2.0 has arrived! If you'd like to access some extra PA content and help support the forums, check it out at patreon.com/ClubPA
The image size limit has been raised to 1mb! Anything larger than that should be linked to. This is a HARD limit, please do not abuse it.
Our new Indie Games subforum is now open for business in G&T. Go and check it out, you might land a code for a free game. If you're developing an indie game and want to post about it, follow these directions. If you don't, he'll break your legs! Hahaha! Seriously though.
Our rules have been updated and given their own forum. Go and look at them! They are nice, and there may be new ones that you didn't know about! Hooray for rules! Hooray for The System! Hooray for Conforming!

NWN2 on Vista?

SanjuroSanjuro Registered User new member
edited November 2007 in Help / Advice Forum
Hi All,

I was interested in creating a submission for the BioWare job Gabe posted on Monday, but I've hit a snag. I actually went out and bought NWN2 specifically for the toolset, and it installed successfully, but the app stops responding anytime I try to create an area with the Toolset. I looked at atarisupport.com for some help, and it doesn't look like NWN2 is supported on Vista.

Has anybody found a way around this issue? I put XP on a new partition, and will install NWN2 there for the time being, but I'd rather not have to keep a whole OS installed just so I can use this application.

Sanjuro on

Posts

  • Judge Joe BrownJudge Joe Brown Registered User
    edited November 2007
    Have you tried running it in compatibility mode? And running it as an administrator?

    Judge Joe Brown on
  • kaliyamakaliyama Left to find less-moderated fora Registered User regular
    edited November 2007
    Is NWN2 breaking, or the toolset? I'm running NWN2 OK on vista, but haven't tried the toolset.

    kaliyama on
    fwKS7.png?1
  • robaalrobaal Registered User
    edited November 2007
    Did you update it before running? I vaguely recall that type of behaviour being reported when NWN2 was fresh (ie. toolset crashing, not specific to Vista).

    You might find relevant info at the NWN2 forums, as they are quite lively.


    And yeah, the game itself ran fine under Vista.

    robaal on
    "Love is a snowmobile racing across the tundra when suddenly it flips over, pinning you underneath.
    At night, the ice weasels come."

  • Cynic JesterCynic Jester Registered User regular
    edited November 2007
    I just tried the toolset on my Vista Ultimate, and it runs just fine, no compatability mode or anything needed on my part.

    Cynic Jester on
  • SanjuroSanjuro Registered User new member
    edited November 2007
    Okay, Questions answered:

    JJB: Yes and Yes. I've tried it with Compatibility and Run As Administrator turned on, and with just compatibility mode. No Dice.

    kaliyama: The Toolset is breaking. I actually haven't tried to launch the game yet. I will in a minute, and update the post.

    robaal: It actually errors out during the update, as well. It updates through 1.04, then throws an error that it has the wrong type of some file. I'll try to recreate and update.

    Cynic Jester: I'm on an OEM version of Home Premium, but I don't think that matters.

    UPDATE 2:
    Okay, I installed in on the XP Partition of that computer, same thing. I installed it on a totally different XP computer, same thing. Then I installed it on a second computer with Vista, and it works. So far, the only corollary I can see is that both the computers that didn't work have Dual Core processors. Is there an easy way to disable one core in Vista?

    UPDATE:
    Okay, When I try to launch the game, I get an error:
    "Could not find any compatible Direct 3D devices. The application will now exit."

    Here is the stack dump of the update:

    Your game version is: 1.06.980 English

    Pinging: nwn2patch.obsidianent.com
    Retrieving autopatcher version information
    Connecting...nwn2patch.obsidianent.com
    Downloading nwn2_pc_autopatch.txt
    Retrieving game patch information
    Connecting...nwn2patch.obsidianent.com
    Downloading nwn2_pc_english.txt
    Connecting...nwn2patch.obsidianent.com
    Downloading nwn2_pc_english_from106980_to1101115.txt
    Latest Game Version Available: 1.10.1115
    Determining the closest server to use.
    Pinging: vnfiles.ign.com
    Pinging: atari.com
    Connecting...vnfiles.ign.com
    Locate patch file nwn2_pc_english_from106980_to1101115.zip
    Downloading nwn2_pc_english_from106980_to1101115.zip 77.2 MB
    Done downloading.
    Extracting files from: temp\nwn2_pc_english_from106980_to1101115.zip
    inflating: nwn2_pc_english_from106980_to1101115.rtp
    Copied file: nwn2_pc_english_from106980_to1101115.rtp
    Patching File Data\2DA.zip
    Patching File NWN2Toolset\VariableSets\a_restsys_wm_vars.xml
    Patching File NWN2Toolset\Plugins\AnimationViewer.dll
    Patching File NWN2Toolset\Plugins\de\AnimationViewer.resources.dll
    Patching File NWN2Toolset\Plugins\es\AnimationViewer.resources.dll
    Patching File NWN2Toolset\Plugins\fr\AnimationViewer.resources.dll
    Patching File NWN2Toolset\Plugins\it\AnimationViewer.resources.dll
    Patching File NWN2Toolset\Plugins\pl\AnimationViewer.resources.dll
    Patching File NWN2Toolset\Plugins\ru\AnimationViewer.resources.dll
    Patching File NWN2Toolset\Plugins\zh-cht\AnimationViewer.resources.dll
    Patching File Data\AnimTags.zip
    Patching File UI\default\images\generic\b_bag_hover.tga
    Patching File UI\default\images\generic\b_bag_normal.tga
    Patching File UI\default\images\generic\b_bag_pressed.tga
    Patching File UI\default\images\generic\b_map.tga
    Patching File NWN2Toolset\Plugins\CampaignEditorPlugin.dll
    Patching File NWN2Toolset\Plugins\de\CampaignEditorPlugin.resources.dll
    Patching File NWN2Toolset\Plugins\es\CampaignEditorPlugin.resources.dll
    Patching File NWN2Toolset\Plugins\fr\CampaignEditorPlugin.resources.dll
    Patching File NWN2Toolset\Plugins\it\CampaignEditorPlugin.resources.dll
    Patching File NWN2Toolset\Plugins\pl\CampaignEditorPlugin.resources.dll
    Patching File NWN2Toolset\Plugins\ru\CampaignEditorPlugin.resources.dll
    Patching File NWN2Toolset\Plugins\zh-cht\CampaignEditorPlugin.resources.dll
    Patching File UI\default\images\character.tai
    Patching File UI\default\images\character_creation.tai
    Patching File UI\default\images\character_creation_F21_0.dds
    Patching File UI\default\images\character_F21_0.dds
    Patching File UI\default\characterscreen.xml
    Patching File UI\default\chargen_animal.xml
    Patching File UI\default\chargen_appearance.xml
    Patching File NWN2Toolset\Plugins\CommunityPlugin.dll
    Patching File UI\default\contextmenu.xml
    Patching File Data\convo.zip
    Patching File UI\default\creatureexamine.xml
    Patching File NWN2Toolset\Templates\Custom OnSpawn.nss
    Patching File UI\default\cutscene.xml
    Patching File UI\default\defaultchat.xml
    Patching File UI\default\defaultmpchat1.xml
    Patching File UI\default\defaultmpchat2.xml
    Patching File NWN2Toolset\Plugins\DefaultVerifier.dll
    Patching File NWN2Toolset\Plugins\de\DefaultVerifier.resources.dll
    Patching File NWN2Toolset\Plugins\es\DefaultVerifier.resources.dll
    Patching File NWN2Toolset\Plugins\fr\DefaultVerifier.resources.dll
    Patching File NWN2Toolset\Plugins\it\DefaultVerifier.resources.dll
    Patching File NWN2Toolset\Plugins\pl\DefaultVerifier.resources.dll
    Patching File NWN2Toolset\Plugins\ru\DefaultVerifier.resources.dll
    Patching File NWN2Toolset\Plugins\zh-cht\DefaultVerifier.resources.dll
    Patching File dialog.TLK
    An incorrect version of the file was found on your system.
    The update was unable to complete, since the file contents were incorrect.
    C:\Program Files\Atari\Neverwinter Nights 2\dialog.TLK
    File Size: 14355064
    File CheckSum: b5f7e02baac17b359b3a8f5b3fde95ca
    For assistance, please visit Atari's support web page.
    http://www.atarisupport.com
    The patch has been aborted

    Sanjuro on
  • Cynic JesterCynic Jester Registered User regular
    edited November 2007
    Looks like it could be a driver issue. Have you tried updating your video card driver?

    Cynic Jester on
  • RookRook Registered User regular
    edited November 2007
    I personally thought they meant Neverwinter Nights 1. As NWN2 was made by obsidian, and NWN1 was bioware.

    "I want to throw out an open invitation for
    anyone out there that thinks might be the strange combination of RPG
    fiend and talented writer to grab a copy of Neverwinter Nights and start
    putting together a writing sample. I don't care if you can script, just
    put three guys in a field and attach conversations to them"

    Rook on
Sign In or Register to comment.