As was foretold, we've added advertisements to the forums! If you have questions, or if you encounter any bugs, please visit this thread: https://forums.penny-arcade.com/discussion/240191/forum-advertisement-faq-and-reports-thread/

Telling my stupid monitor to pillar 4:3 resolutions

Squirminator2kSquirminator2k they/themNorth Hollywood, CARegistered User regular
I have a lovely 16:10 widescreen monitor which came with my PC. It's a Gateway FPD1975W monitor, and it's doing a pretty good job. My only gripe with it at the moment is that 4:3 resolutions such as 1024x768 and 800x600 get stretched, which is a real pain in the arse when I'm playing non-widescreen games such as Prince of Persia: The Sands of Time.

Does anyone know if there is a setting on this monitor - or perhaps something in the config for my marginally irritating NVidia GeForce 7650GS graphics card - that will allow me to display these resolutions in their proper aspect ratio?

Jump Leads - a scifi-comedy audiodrama podcast
Squirminator2k on

Posts

  • The Reverend Dr GalactusThe Reverend Dr Galactus Registered User regular
    edited March 2008
    For awhile NVidia had an option to do this, then they took it out, then they recently put it back in.

    It should be somewhere under the NVidia control panel for "image scaling" or something like that (I am miles away from my PC at the moment so I can't check) but there should be an option for "use monitor scaling" that you change to "use NVidia scaling". My Viewsonic strangely doesn't do this itself and so I had been running Dawn of War in a window until NVidia brought the option back.

    The Reverend Dr Galactus on
    valar-moreshellus.png
    PSN:RevDrGalactus/NN:RevDrGalactus/Steam
  • DeusfauxDeusfaux Registered User regular
    edited March 2008
    centered timings - box in the middle of the exact size/resolution of what you selected in game
    aspect ratio scaling - keeps aspect ratio, blows it up to touch appropriate sides (and not the other sides) - only on nvidia cards
    full - stretches to fit your whole screen

    you shouldnt use your monitors scaling options unless you have an ati card and cant do the aspect scaling

    Deusfaux on
  • DírhaelDírhael NorwayRegistered User regular
    edited March 2008
    For awhile NVidia had an option to do this, then they took it out, then they recently put it back in.

    It should be somewhere under the NVidia control panel for "image scaling" or something like that (I am miles away from my PC at the moment so I can't check) but there should be an option for "use monitor scaling" that you change to "use NVidia scaling". My Viewsonic strangely doesn't do this itself and so I had been running Dawn of War in a window until NVidia brought the option back.

    They didn't really remove it, they disabled it on XP (it works just fine without limitations in Vista). To get this back in XP, you will need to download the following tiny tool from Nvidia (it just sets a registry value):

    Get OverscanUtils.zip from this page.

    Just extract the contents of the zip and run the file named EnableOverscanCompensation.exe and reboot. You can now use the flat panel scaling options in the Nvidia Control Panel. The only drawback to this is that it will disable HDCP content protection, so you will not be able to watch Blu-ray/HD-DVD discs with said protection enabled.

    Do note that if you update or reinstall your drivers, you will have to run the .exe once again.

    EDIT: It says that the fix only applies for 8800 cards though, but it's worth a shot in any case..

    Dírhael on
  • freakish lightfreakish light butterdick jones and his heavenly asshole machineRegistered User regular
    edited March 2008
    I don't have an nVidia card or this problem, but have you tried the new nVidia Omega drivers? That seems like the kind of thing the guy would put back into his drivers.

    Course, maybe it's not, but if you run out of options it's worth a shot.

    www.omegadrivers.net

    freakish light on
  • Squirminator2kSquirminator2k they/them North Hollywood, CARegistered User regular
    edited March 2008
    I don't have an nVidia card or this problem, but have you tried the new nVidia Omega drivers? That seems like the kind of thing the guy would put back into his drivers.

    Oh-ho, no. I'm not touching those drivers again. They rendered my card unusable, and trying to install up-to-date drivers would BSoD my system. I had to do a System Restore to make the card work again.

    I'm using Vista, so I shall try some of the suggestions mentioned above.

    Edit: The option I need isn't available - it's not greyed out, it's just not there. It's listed in the Help file, though. Huh.

    Squirminator2k on
    Jump Leads - a scifi-comedy audiodrama podcast
  • Akilae729Akilae729 Registered User regular
    edited March 2008
    Does anyone know how to correct this problem when using an external monitor on a MacBook. The MacBook's built in display does it automatically, however, an external widescreen doesn't do this.

    Akilae729 on
    signaturebighe7.jpg
  • corky842corky842 Registered User regular
    edited March 2008
    They say it will be added in a future update.
    The option is called "flat panel scaling."

    corky842 on
  • stigweardstigweard Registered User regular
    edited March 2008
    corky842 wrote: »
    They say it will be added in a future update.
    The option is called "flat panel scaling."

    Posting to the future from the time before January 2007?

    stigweard on
  • Squirminator2kSquirminator2k they/them North Hollywood, CARegistered User regular
    edited March 2008
    corky842 wrote: »
    They say it will be added in a future update.
    The option is called "flat panel scaling."

    I hope so... in the meantime I'm now looking for a similar option for my laptop display. It's an Acer Extensa 5420 with an ATI Radeon graphics card.

    Squirminator2k on
    Jump Leads - a scifi-comedy audiodrama podcast
Sign In or Register to comment.