As was foretold, we've added advertisements to the forums! If you have questions, or if you encounter any bugs, please visit this thread: https://forums.penny-arcade.com/discussion/240191/forum-advertisement-faq-and-reports-thread/

Getting Wireless drivers to work in Ubuntu

KrayzieKrayzie Registered User regular
So after The Ubuntu thread in G&T I decided to give linux a try for the first time ever. I've only ever used windows, so it's been a little rough, but I'm starting to get the hang of it. I'm on a laptop, the HP Dv6625us.

Link:http://h10025.www1.hp.com/ewfrf/wc/genericDocument?docname=c01161231&cc=us&dlc=en&lc=en&jumpid=reg_R1002_USEN)

So far most drivers have been auto detected and installed and everything just worked like it should. Except my wireless card. I have a Broadcom wireless card, and I found a few solutions that should have worked, but didn't. I can see the firmware for the thing in system>administration>restricted hardware drivers, but turning it does nothing. I can't see any networks, and actually have no idea where they are even displayed for that matter. I can put in the network info manually, but that doesn't work either.

I'm seriously at a loss here, so any help at all would be greatly appreciated. I've gotten the hang of the terminal and package managers, so I should be able to follow any instructions, I just don't know what the hell to do.

Krayzie on

Posts

  • EchoEcho Moderator mod
    edited March 2008
    Googling "dv6625us ubuntu wireless" is serious business.

    Here ya go.

    Echo on
    Echo wrote: »
    Let they who have not posted about their balls in the wrong thread cast the first stone.
  • BarrakkethBarrakketh Registered User regular
    edited March 2008
    Echo wrote: »
    Googling "dv6625us ubuntu wireless" is serious business.

    Here ya go.

    At the top of that page you find:
    This method is no longer supported and could possibly cause more problems than it fixes. I'm going to leave it up, but just remember - use it at your own risk.

    [...]

    You should also know that the code maintainer for this project has moved on to bigger and better things. Unfortunately I don't know anything about programming in python (or any other language.) Thus, the installer available here for download is no longer maintained. Also be advised that the offline installer will not work with Gutsy Gibbon. The online installer may or may not, I haven't tried it.

    On the last page the author says:
    As K.Mandla stated, this thread had been unstickied - at my request. The fact is that it has been doing more harm than good lately, and I do not have the programming knowledge necessary to update it. This driver installation method has outlived its expected lifetime and I think it is now time to let it die a quiet death.

    The Ubuntu wiki has an installation guide. Assuming you're using Gutsy Gibbon (the current stable release) you may want to read this.

    Barrakketh on
    Rollers are red, chargers are blue....omae wa mou shindeiru
  • LittleBootsLittleBoots Registered User regular
    edited March 2008
    Or you could try Hardy, its hardware detection seems to be much better than previous versions.

    LittleBoots on

    Tofu wrote: Here be Littleboots, destroyer of threads and master of drunkposting.
  • The DeliveratorThe Deliverator Slingin Pies The California BurbclavesRegistered User regular
    edited March 2008
    I have a broadcom wireless card in my laptop, and to get it up and running under ubuntu I ended up using ndiswrapper. The method posted here should work for you, if you substitute the drivers for your laptop.

    edit: the lines that go "sudo echo ...." may not work for you, they didn't for me. I ended up having to run gedit with root prvilidges, and add the lines that way.

    The Deliverator on
  • KrayzieKrayzie Registered User regular
    edited March 2008
    Thanks for the help everyone. I ended up upgrading to heron and it made my wireless card work perfectly. It also fixed pretty much every other problem I had too, so thats pretty awesome. Consider this solved.

    Krayzie on
  • UpfishUpfish Registered User
    edited March 2008
    Hopefully this doesn't count as a hijack, since the problem was solved: I just installed Ubuntu on my laptop on a second partition, and I'm having a couple problems. The main one is that my wireless isn't working. My system detects wireless networks, and even connects to them, but then when I open firefox or try to download a program from the system list, it won't load anything.
    I'm posting from the same laptop I installed Ubuntu on, so I know it works.
    I attend a college which uses Cisco Clean Access Agent, which I read earlier doesn't require linux users to sign in. So that can't be the problem.

    The second problem, which I suspect is a video drivers error, is that my resolution only goes up to 1150xsomethingelse, something like that. I think if I download my drivers (which I can't, since I can't get internet access), this problem would be fixed.

    Again, the main issue is the internet thing. Does anyone know what's going on?

    edit: forgot to mention, I'm using Gutsy Gibbon 7.10

    Upfish on
Sign In or Register to comment.