The image size limit has been raised to 1mb! Anything larger than that should be linked to. This is a HARD limit, please do not abuse it.
Our new Indie Games subforum is now open for business in G&T. Go and check it out, you might land a code for a free game. If you're developing an indie game and want to post about it, follow these directions. If you don't, he'll break your legs! Hahaha! Seriously though.
Our rules have been updated and given their own forum. Go and look at them! They are nice, and there may be new ones that you didn't know about! Hooray for rules! Hooray for The System! Hooray for Conforming!

Civ 4 disc error

RamiRami Registered User regular
edited September 2008 in Help / Advice Forum
So I got a new PC last week, the only things i've installed are Vista 64, drivers for monitor, keyboard etc. WoW and Spore.

Today I installed Civ IV + Beyond the Sword, but then when I try to run it it says to insert the correct DVD, even though i've just installed it off that disc.

I had this problem once before on my old PC, I solved it by mistake when I closed down my DVD burner and it started to work. So I figured it was some crazy DRM/copy protection that wouldn't let it run. My new PC though, doesn't have any burning software other than Windows own version, and that would have been present on my old PC as well.

So, any ideas?

Steam / Xbox Live: WSDX NNID: W-S-D-X 3DS FC: 2637-9461-8549
Rami on


  • Bendery It Like BeckhamBendery It Like Beckham Hopeless Registered User regular
    edited September 2008
    this is normally an issue when installed off a virtual drive. You may want to try and make sure that you are using the correct dvd (stupid i know, but really take a look)

    Check to see if your optical drives drivers are up to date.
    Is it a backup copy?

    Bendery It Like Beckham on
  • RamiRami Registered User regular
    edited September 2008
    Nope, all original discs. I tried the vanilla version and the BTS disc but both give the same error. Drivers are all up to date.

    Rami on
    Steam / Xbox Live: WSDX NNID: W-S-D-X 3DS FC: 2637-9461-8549
  • GrobianGrobian What's on sale? Pliers!Registered User regular
    edited September 2008
    I get that sometimes and it fixes itself after ejecting the disc and putting it in again. If you have another drive, try that.

    Civ4 uses Safedisc and that scans for DaemonTools etc. If it finds anything, it just displays the "Insert correct disc" message instead of telling you what the problem is. Getting around Safedisc is probably not a good topic for this forum so I'll leave it at this link to a blog that may or may not help you.

    Grobian on
  • bobmyknobbobmyknob Registered User regular
    edited September 2008
    For vanilla Civ4, the discs are mislabeled. You need to use the Install Disc to play. I know I forgot about that recently, but if it's happening in BtS, I don't know what the problem could be.

    bobmyknob on
  • UltimaGeckoUltimaGecko Registered User
    edited September 2008
    Maybe not the most relevant, but I had this sort of problem with Civ4 right after it came out, and it was patched fairly quickly (I would suspect BtS retains the patch), but you might want to check for patchest regardless.

    Alternatively, some games don't like when you have emulation software for any reason (and some burning software), so if you have daemons, dvddecrypter or any sort of stuff like that you'd likely need to update it or remove it (although I think most games don't mind either of them now). Alternatively, you could try reinstalling assorted drivers (or looking for updated ones) as already mentioned. There's always the option of reinstalling, potentially some strange conflict from installing things in a strange order or a mod not installed right (likely not a problem if it hasn't worked on that computer...ever). Another strange option might be trying Windows XP compatibility.

    I also only have vanilla Civ4, but I'll also repeat bobmyknob and say the play disc is the Disc 1/Install disc (which shouldn't impact expansions).

    UltimaGecko on
    The facehuggers want to play with you in the AvP LP. Facehuggers also want you to check out the TF2 cards here. View the in-progress RE mansion recreation for L4D here.
    Bitstream wrote: »
    People respect a man who might do science at any moment.
  • yurnamehereyurnamehere Registered User regular
    edited September 2008
    Also, there are separate desktop icons for Vanilla Civ 4 and Beyond The Sword, and you need the correct disk for the icon you're clicking on.

    yurnamehere on
Sign In or Register to comment.