As was foretold, we've added advertisements to the forums! If you have questions, or if you encounter any bugs, please visit this thread: https://forums.penny-arcade.com/discussion/240191/forum-advertisement-faq-and-reports-thread/
Options

I'm connected to the Japanese iTunes store.

contrabandcontraband Registered User regular
edited November 2006 in Help / Advice Forum
What the fuck.

I'm pretty damn sure I'm connected to the Japanese iTunes Music Store. All the song prices are in Yen, and all I'm getting are Japanese artists (minus the really big names, god forbid I don't have access to the U2 and Greenday single, it's right up there at the top). What do I do?!

(this just makes me angry that I don't have a lot of this music regularly avalable to me, though. fuck you american music store, for not having capsule or perfume or clazziquai project)

sigxw0.jpg
contraband on

Posts

  • Options
    cheXziecheXzie Registered User regular
    edited November 2006
    Go to options (or was it preffernces) and change your country setting.

    cheXzie on
    cheXzie_sig_01.jpg
  • Options
    XntrggrXntrggr Registered User regular
    edited November 2006
    Or in the main iTunes Music Score screen scroll all the way down and switch it back to whatever your store is. There's a scroll down bar there with "My Store" on it.

    Xntrggr on
  • Options
    EggyToastEggyToast Jersey CityRegistered User regular
    edited November 2006
    Something is up with this, because a coworker was complaining about this same thing. So it's apparently not just you.

    EggyToast on
    || Flickr — || PSN: EggyToast
  • Options
    contrabandcontraband Registered User regular
    edited November 2006
    Solved. Thanks guys, chexzie. I changed my language to Finnish. I'm happy.

    contraband on
    sigxw0.jpg
Sign In or Register to comment.