As was foretold, we've added advertisements to the forums! If you have questions, or if you encounter any bugs, please visit this thread: https://forums.penny-arcade.com/discussion/240191/forum-advertisement-faq-and-reports-thread/
Options

USB 2.0

Left Wing jAyLeft Wing jAy Registered User regular
edited April 2009 in Help / Advice Forum
Having reformatted my laptop, all my USB ports no longer seem to be USB 2.0.

This results in all the devices I connect to the ports telling me that it 'could run faster...'. I know they used to be 2.0 ports, I even still have the stickers on the machine.

Where would I find updates for them, is it even possible? I did google the name of the hardware (Intel(R) 82801FB/FBM USB), but none of the results with downloads looked like something I just want to install on a whim (This is one of the reasons I reformatted).

Cheers

Left Wing jAy on

Posts

  • Options
    Sir CarcassSir Carcass I have been shown the end of my world Round Rock, TXRegistered User regular
    edited April 2009
    Windows Update?

    Sir Carcass on
  • Options
    EchoEcho ski-bap ba-dapModerator mod
    edited April 2009
    Probably needs some driver from the laptop manufacturer. My Acer laptop needed it.

    Echo on
  • Options
    jeepinryanjeepinryan Registered User regular
    edited April 2009
    Depending on the manufacturer, it may not be listed as a USB Driver on the site. Usually the chipset driver includes all the stuff you need for the USB ports though, so make sure to download and install that one.

    Good luck!

    jeepinryan on
  • Options
    Left Wing jAyLeft Wing jAy Registered User regular
    edited April 2009
  • Options
    proXimityproXimity Registered User regular
    edited April 2009
    I know that back in the day, you had to install XP SP1 before installing the USB drivers, otherwise they'd install as 1.1, not the 2.0 they're capable of. What OS are you running?

    proXimity on
    camo_sig2.png
  • Options
    Left Wing jAyLeft Wing jAy Registered User regular
    edited April 2009
    Currently XP Media Centre, SP2 is installed...pretty up to date on windows updates.

    I didn't even realise USB ports were capable of 2 different speeds depending on software. Laptop manufacturer isn't an option either, mine's made by 'Advent', so basically a bunch of hardware thrown together.

    Left Wing jAy on
  • Options
    Left Wing jAyLeft Wing jAy Registered User regular
    edited April 2009
    Update: Can't work this out and it's really frustrating; I'm definitely up to date with Windows updates, did drivers for the corresponding Intel chipset...Do I somehow need to reinstall the USB ports/software altogether? I'm not certain how I'd go about that; there are 4 'USB Root Hub' listed in Device Manager, and 4 'USB Universal Host Controller', with different numbers at the end. These ports 100% worked fine prior to the reformat, so what's different now?

    Really appreciate any further ideas, it's probably something really simple...

    Left Wing jAy on
  • Options
    Sir CarcassSir Carcass I have been shown the end of my world Round Rock, TXRegistered User regular
    edited April 2009
    Do you have SP3?

    Sir Carcass on
  • Options
    Left Wing jAyLeft Wing jAy Registered User regular
    edited April 2009
    Indeed, made sure of that today.

    I've checked all basic things I can think of; none of the hardware displays a problem in device manager, for example.

    Left Wing jAy on
Sign In or Register to comment.