As was foretold, we've added advertisements to the forums! If you have questions, or if you encounter any bugs, please visit this thread:

On PS3 bluray sound issues

Romero ZombieRomero Zombie Registered User regular
edited July 2009 in Help / Advice Forum
So I just picked up the 80 gig PS3 bundle with Killzone 2 and MGS4 and love it. I have an HDMI cable going from my PS3 to my TV because my receiver is old and doesn't have an HDMI port.

When I play my games, everything works as it should volume wise. However, when I put either a DVD or a Bluray in the PS3, I have to turn my tv up to ridiculous volumes to be able to hear.

Here are some things I have checked already

-The sound settings in the PS3 menu is at HDMI
-I've tried different HDMI ports from my TV
-I've tried a seperate HDMI cord to see if that was the issue

I looked online a bit and saw someone suggest an optical cable to go from my PS3 to my receiver and have the sound set up that way, but alas, my receiver doesn't have an optical in. At least that I can see.

So any suggestions?

Romero Zombie on


  • Options
    matt has a problemmatt has a problem Points to 'off' Points to 'on'Registered User regular
    edited July 2009
    Mine does (did) this too, and I never figured out why. My TV is relatively new, about 2 years. I have it running through a home theater system now, and the volumes are just fine coming out of that.

    matt has a problem on
  • Options
    capable heartcapable heart Registered User regular
    edited September 2021

    capable heart on
  • Options
    TopweaselTopweasel Registered User regular
    edited July 2009
    2 Things

    First. Do an auto detect of the sound options. When ever I switch devices with my PS3 I have to do it to get the audio through correctly. You might be using surround on a two speaker system or Stereo on a Surround system.

    Second is both TrueHD and DTS-HD Master allow for a sound leveling technology. Warner for example has theirs set like -10 dbs, that means you have to turn the stereo up to a level that translates to that to hit the sweet spot your used to. Both should have a regular surround option, not as digitally accurate, but very very passable.

    Though my guess is that it has to do with the PS3 audio options as you said it was a DVD issue as well.

    Topweasel on
  • Options
    eternalbleternalbl Registered User regular
    edited July 2009
    Turn on your PS3, go to the video settings and turn on "BD/DVD Dynamic Range Control"

    eternalbl on
Sign In or Register to comment.