Computer crashes a lot during Dragon Age and Borderlands

SeeksSeeks Registered User regular
I'm assuming this is a videocard issue, but I figured I'd ask here and see if maybe these games are just a pain in everyone's ass.

My setup:

CPU: Intel I5 750 (2.6g quad core, I believe)
Video: ATI 4870
RAM: 4 gigs DDR3
PSU: 650w
Windows 7 64 RC


Now, what's happening is a full system hang. Nothing responds, monitor goes black, and sometimes a weird sound will come out of the speakers, if any sound at all. Hard boot is the only fix.

This happened in Dragon Age with some frequency (typically, about 30-50% of the time I'd play)... though it usually wouldn't happen until at least 2-5 hours in. With Borderlands it's especially bad... I'll make it 5-15 minutes in before everything goes down. I've never made it farther than the fence you jump over during the intro level with the robot. And let me tell you, that little bastard gets annoying after a while.

Games I don't recall having this issue with include Crysis (though I never put more than an hour into it, because it honestly bores me), Fallout 3, Assassin's Creed, Oblivion and Quake 4.

What do you guys think it might be?

Edit: I've got the newest video drivers, too.

userbar.jpg
desura_Userbar.png
Seeks on

Posts

  • elliotw2elliotw2 Registered User
    edited November 2009
    Check all of your fans, one may have gone bad and the system's crashing to prevent a meltdown

    elliotw2 on
    camo_sig2.pngXBL:Elliotw3|PSN:elliotw2
  • SeeksSeeks Registered User regular
    edited November 2009
    Yeah, looks like that's it, sorta.

    I turned the fan up to 60% with CCC and made it all the way to the next checkpoint before it crashed, which is roughly two or three times as long as before I screwed with the fan.

    Now I'm torn between turning it up 70% and shortening the lifespan of my videocard by... however long, or saying fuck this stupid game and taking it back down to 50%.

    Seeks on
    userbar.jpg
    desura_Userbar.png
  • Torque MonkeyTorque Monkey Registered User
    edited November 2009
    iirc ATI was having some issues with drivers and Dragon Age, but I haven't heard anything about Borderlands. Judging by [url=http://forums.amd.com/game/messageview.cfm?catid=227&threadid=121153
    ]this thread on AMD's forums[/url], you're not the only one.

    Torque Monkey on
    Gojira2.png
  • elliotw2elliotw2 Registered User
    edited November 2009
    Seeks wrote: »
    Yeah, looks like that's it, sorta.

    I turned the fan up to 60% with CCC and made it all the way to the next checkpoint before it crashed, which is roughly two or three times as long as before I screwed with the fan.

    Now I'm torn between turning it up 70% and shortening the lifespan of my videocard by... however long, or saying fuck this stupid game and taking it back down to 50%.

    Well, if it's having fan troubles in general, first do some dust busting and clean it, and if it still has trouble, chunk it and get a new one as soon as you can, or at least a new fan. Fan problems always get worse over time, not better

    elliotw2 on
    camo_sig2.pngXBL:Elliotw3|PSN:elliotw2
  • SeeksSeeks Registered User regular
    edited November 2009
    Bleh. Tried it at 70%, crashed even faster than normal.

    Nice to know I'm not the only one... I guess? Whatever, it's not worth the hassle. I'll just stick to other, working games.

    Thanks for the suggestions though.

    Seeks on
    userbar.jpg
    desura_Userbar.png
Sign In or Register to comment.