Having trouble with my GeForce 8600 GTS: Aspect Ratio Correction

Squirminator2kSquirminator2k Toys, ports, and Time LordsNorth Hollywood, CARegistered User regular
I first installed the graphics card about a year ago, and while it said it had an option to run 4:3 resolutions without stretching to fit the screen the option wasn't available in the NVidia Control Panel. No bother - I'd lived without it for over a year already, it wasn't going to kill me to do without it.

When I did a clean install of Windows 7 a couple of months ago the option suddenly manifested itself. Indeed, the option was turned on by default. Fantastic! I no longer had to run the first season of Sam & Max in a window!

A recent Windows Update appears to have broken the feature, however - I just went to play Abe Lincoln Must Die! and the display stretched to fill the entire screen. I tried it on a couple of other 4:3 games - Prince of Persia: The Sands of Time, Addiction Pinball, Monkey Island 2: LeChuck's Revenge - and they're all stretched.

I checked out the NVidia Control Panel. The "scaling with fixed-aspect ratio" option is there:

nvidia1.gif

But as you see it's not enabled. It's not greyed out though, so it should be selectable. And it is. The problem is when I click "Apply" the computer rumbles for a few seconds, gives me a pop-up notification to let me know that my display settings have been changed, and then resets the option back to "Use my display's built-in setting".

My display is a Gateway GPD1975W. As far as I'm aware it doesn't have built-in aspect ratio correction. If it does I haven't found the setting yet.

Does anyone know why the NVidia card is preventing me from enabling an option that, until recently, was working perfectly fine?

The Game of Rassilon - a Doctor Who Roleplaying Game podcast
PortsCenterThe Life Toyetic with Ben and Molly
Squirminator2k on

Posts

  • autono-wally, erotibot300autono-wally, erotibot300 love machine Registered User regular
    edited December 2009
    I have the same problem, with an 8600 mgt

    autono-wally, erotibot300 on
    kFJhXwE.jpgkFJhXwE.jpg
  • Squirminator2kSquirminator2k Toys, ports, and Time Lords North Hollywood, CARegistered User regular
    edited December 2009
    And neither of us have a solution.

    Must unpleasant.

    Squirminator2k on
    The Game of Rassilon - a Doctor Who Roleplaying Game podcast
    PortsCenterThe Life Toyetic with Ben and Molly
  • RaekreuRaekreu Registered User regular
    edited December 2009
    And neither of us have a solution.

    Must unpleasant.


    It says on your screencap that the native resolution is 1440x900, which sounds like an odd one to me. The aspect ratio on this sucker is 16:10 which is not well supported for a lot of PC games. So, 2 things:

    1. In the games settings, do you have the resolution set to 1440x900 if it's available?
    2. Have you tried selecting the 'do not scale' option?


    #2 is something that I used to do for an LCD monitor that I had whose native resolution was too high for my rig to keep up with. 1280x1024 was the native resolution and anything under that with the scaling turned on looked clunky and pixelated. So what I did was I picked a resolution that matched the width of the monitor but with the height reduced. With the do not scale option chosen, the games I wanted to play would go into letterbox - black bars at the top and bottom of the screen but with proper scaling and image proportions.

    Raekreu on
  • StormwatcherStormwatcher Blegh BlughRegistered User regular
    edited December 2009
    Raekreu wrote: »
    And neither of us have a solution.

    Must unpleasant.


    It says on your screencap that the native resolution is 1440x900, which sounds like an odd one to me. The aspect ratio on this sucker is 16:10 which is not well supported for a lot of PC games. So, 2 things:

    1. In the games settings, do you have the resolution set to 1440x900 if it's available?
    2. Have you tried selecting the 'do not scale' option?


    #2 is something that I used to do for an LCD monitor that I had whose native resolution was too high for my rig to keep up with. 1280x1024 was the native resolution and anything under that with the scaling turned on looked clunky and pixelated. So what I did was I picked a resolution that matched the width of the monitor but with the height reduced. With the do not scale option chosen, the games I wanted to play would go into letterbox - black bars at the top and bottom of the screen but with proper scaling and image proportions.

    Erm, PC monitors nowadays are mostly 16:10, and 1440x900 is supported by all farily recent widescreen games... It's the normal res for 19" screens. Any games made the last 4 years have native support for it. Of course, they only show monitor-supported resolutions at the options screens, so if you have a 16:9 or a 4:3 monitor or TV, you're never gonna see 1440 as an option. Sure, very old games won't support it out of the box, but then again they won't support any widescreen resolutions. Some very rare early widescreen games might not support 1440, but that's usually fixable with .ini hacks or things like that. Sometimes even official patches.

    Oh, and BTW, option #2 is exactly what he's trying to activate. Scaling games up without stretching. That's what I use too. It's indeed the best option when the GPU+monitor combo allows you to set it.

    Scaling is a complicated issue, though. On ATI, you need to lower your monitor res (i.e. set it to 1280x800), pick the option you want (i.e. Scaling with fixed AR), apply , exit the config, then go back and move the res back to native.

    I HOPE it works for Nvidia too.

    If it doesn't, your best bet is searching The widescreen gaming forum site for solutions and maybe even post a plead for help over there.

    Stormwatcher on
    Steam: Stormwatcher | PSN: Stormwatcher33 | Switch: 5961-4777-3491
    camo_sig2.png
  • Squirminator2kSquirminator2k Toys, ports, and Time Lords North Hollywood, CARegistered User regular
    edited December 2009
    Quite frustratingly, none of the options are selectable. I choose them, I click apply, and then it changes the setting back.

    The only time it allows me to keep the setting, interestingly enough, is when I change my desktop resolution to something lower than my monitor's native 1440x900. At that point it saves the setting, which leads me to believe that the NVidia Control Panel is assuming that if the desktop resolution fits the entire screen then there's no point in saving the option change I'm making.

    Which is, y'know, bollocks.

    Squirminator2k on
    The Game of Rassilon - a Doctor Who Roleplaying Game podcast
    PortsCenterThe Life Toyetic with Ben and Molly
  • RaekreuRaekreu Registered User regular
    edited December 2009
    Raekreu wrote: »
    And neither of us have a solution.

    Must unpleasant.


    It says on your screencap that the native resolution is 1440x900, which sounds like an odd one to me. The aspect ratio on this sucker is 16:10 which is not well supported for a lot of PC games. So, 2 things:

    1. In the games settings, do you have the resolution set to 1440x900 if it's available?
    2. Have you tried selecting the 'do not scale' option?


    #2 is something that I used to do for an LCD monitor that I had whose native resolution was too high for my rig to keep up with. 1280x1024 was the native resolution and anything under that with the scaling turned on looked clunky and pixelated. So what I did was I picked a resolution that matched the width of the monitor but with the height reduced. With the do not scale option chosen, the games I wanted to play would go into letterbox - black bars at the top and bottom of the screen but with proper scaling and image proportions.

    Erm, PC monitors nowadays are mostly 16:10, and 1440x900 is supported by all farily recent widescreen games... It's the normal res for 19" screens. Any games made the last 4 years have native support for it. Of course, they only show monitor-supported resolutions at the options screens, so if you have a 16:9 or a 4:3 monitor or TV, you're never gonna see 1440 as an option. Sure, very old games won't support it out of the box, but then again they won't support any widescreen resolutions. Some very rare early widescreen games might not support 1440, but that's usually fixable with .ini hacks or things like that. Sometimes even official patches.

    Oh, and BTW, option #2 is exactly what he's trying to activate. Scaling games up without stretching. That's what I use too. It's indeed the best option when the GPU+monitor combo allows you to set it.

    Scaling is a complicated issue, though. On ATI, you need to lower your monitor res (i.e. set it to 1280x800), pick the option you want (i.e. Scaling with fixed AR), apply , exit the config, then go back and move the res back to native.

    I HOPE it works for Nvidia too.

    If it doesn't, your best bet is searching The widescreen gaming forum site for solutions and maybe even post a plead for help over there.

    My mistake on the 16:10 ratio there, it's been a long time since I've bought a new monitor. :oops: I'm still using the one mentioned in my post and it's 5:4 aspect ratio.

    As for the option #2, it isn't quite the same thing as what you're describing, at least not for nvidia cards. The do not scale option displays fullscreen programs at their literal resolution, so if he chose to run a program at 800x600 it would display as literally that - 800x600 pixels out of the 1440x900 on the screen, unscaled and unstretched. It isn't an ideal solution but the option that he's tried to use - the nvidia scaling with fixed aspect ratio - isn't working correctly for some odd reason.

    @OP: have you checked the nvidia website to see if there's an update for your drivers? Reinstalling could kick the nvidia control panel in its butt and get it working correctly again.

    Raekreu on
  • Squirminator2kSquirminator2k Toys, ports, and Time Lords North Hollywood, CARegistered User regular
    edited December 2009
    I'm using the latest driver build - 195.62. It may actually be what killed the setting.

    Squirminator2k on
    The Game of Rassilon - a Doctor Who Roleplaying Game podcast
    PortsCenterThe Life Toyetic with Ben and Molly
  • RaekreuRaekreu Registered User regular
    edited December 2009
    Bad nvidia, bad!

    I think that stormwatcher's suggestion to hit up the widescreen gaming forums he linked to in his post is your best bet, then. I know they've got solutions for Sam and Max and PoP. Some of the other games may take a little hunting to find solutions for, though.

    Raekreu on
  • Squirminator2kSquirminator2k Toys, ports, and Time Lords North Hollywood, CARegistered User regular
    edited December 2009
    Thanks, I'll check 'em out.

    Squirminator2k on
    The Game of Rassilon - a Doctor Who Roleplaying Game podcast
    PortsCenterThe Life Toyetic with Ben and Molly
  • StormwatcherStormwatcher Blegh BlughRegistered User regular
    edited December 2009
    Raekreu wrote: »
    Raekreu wrote: »
    And neither of us have a solution.

    Must unpleasant.


    It says on your screencap that the native resolution is 1440x900, which sounds like an odd one to me. The aspect ratio on this sucker is 16:10 which is not well supported for a lot of PC games. So, 2 things:

    1. In the games settings, do you have the resolution set to 1440x900 if it's available?
    2. Have you tried selecting the 'do not scale' option?


    #2 is something that I used to do for an LCD monitor that I had whose native resolution was too high for my rig to keep up with. 1280x1024 was the native resolution and anything under that with the scaling turned on looked clunky and pixelated. So what I did was I picked a resolution that matched the width of the monitor but with the height reduced. With the do not scale option chosen, the games I wanted to play would go into letterbox - black bars at the top and bottom of the screen but with proper scaling and image proportions.

    Erm, PC monitors nowadays are mostly 16:10, and 1440x900 is supported by all farily recent widescreen games... It's the normal res for 19" screens. Any games made the last 4 years have native support for it. Of course, they only show monitor-supported resolutions at the options screens, so if you have a 16:9 or a 4:3 monitor or TV, you're never gonna see 1440 as an option. Sure, very old games won't support it out of the box, but then again they won't support any widescreen resolutions. Some very rare early widescreen games might not support 1440, but that's usually fixable with .ini hacks or things like that. Sometimes even official patches.

    Oh, and BTW, option #2 is exactly what he's trying to activate. Scaling games up without stretching. That's what I use too. It's indeed the best option when the GPU+monitor combo allows you to set it.

    Scaling is a complicated issue, though. On ATI, you need to lower your monitor res (i.e. set it to 1280x800), pick the option you want (i.e. Scaling with fixed AR), apply , exit the config, then go back and move the res back to native.

    I HOPE it works for Nvidia too.

    If it doesn't, your best bet is searching The widescreen gaming forum site for solutions and maybe even post a plead for help over there.

    My mistake on the 16:10 ratio there, it's been a long time since I've bought a new monitor. :oops: I'm still using the one mentioned in my post and it's 5:4 aspect ratio.

    As for the option #2, it isn't quite the same thing as what you're describing, at least not for nvidia cards. The do not scale option displays fullscreen programs at their literal resolution, so if he chose to run a program at 800x600 it would display as literally that - 800x600 pixels out of the 1440x900 on the screen, unscaled and unstretched. It isn't an ideal solution but the option that he's tried to use - the nvidia scaling with fixed aspect ratio - isn't working correctly for some odd reason.

    @OP: have you checked the nvidia website to see if there's an update for your drivers? Reinstalling could kick the nvidia control panel in its butt and get it working correctly again.

    Regarding option 2, i think you got stuff mixed up. I was commenting on what you described (black bars on top/bottom but not sides). That is actually "Scale up with fixed AR", which, on a widescreen monitor, results on the game filling the height of the screen and getting Pillarboxed, i.e., black bars on the sides. That's my favorite solution for old, non-hackable 4:3 games. Please note that, even though the Aspect Ratio remains correct, the GPU is still scaling the game up.

    On the other hand, completely NO SCALING is a really terrible solution for any 19"+ screens. the game turns into a tiny rectangle in the middle surrounded by an ocean of black. No sane human being would ever chose that, unless he hates himself and wants his eyes to quit and go live in Florida. I'd rather have the game stretched fullscreen than have no scaling.

    BTW, none of those problems happen in really old DOS games, because DOSBox knows how to do the "Scale up with right AR" trick just fine. I can post the correct config lines, if anyone wants them.

    The whole scaling GPU crap is just for early Windows games. Oh, and for 2D games, it helps to configure them to use D3D or OpenGL rendering when possible, GPUs can't scale fully 2D rendering. Diablo 2 is one of those instances.

    Stormwatcher on
    Steam: Stormwatcher | PSN: Stormwatcher33 | Switch: 5961-4777-3491
    camo_sig2.png
  • EliminationElimination Registered User regular
    edited December 2009
    Yeah ever since the new drivers for Nvidia this featur eno longer works on my 9800GTX either.

    Elimination on
    PSN: PA_Elimination 3DS: 4399-2012-1711 Steam: http://steamcommunity.com/id/TheElimination/
  • Squirminator2kSquirminator2k Toys, ports, and Time Lords North Hollywood, CARegistered User regular
    edited December 2009
    I've contacted NVidia through their website and through Twitter. Absolutely no response.

    Squirminator2k on
    The Game of Rassilon - a Doctor Who Roleplaying Game podcast
    PortsCenterThe Life Toyetic with Ben and Molly
  • TransparentTransparent Registered User
    edited December 2009
    Do you have UAC enabled still? This probably isn't it but have you tried it either with UAC disabled or by forcing the NVidia control panel to run as administrator?

    Transparent on
    PAXtrain '10, let's do this!
  • Squirminator2kSquirminator2k Toys, ports, and Time Lords North Hollywood, CARegistered User regular
    edited December 2009
    UAC has been disabled since I installed Windows 7.

    The problem is that the Control Panel doesn't care about the setting change, whatever I change it to, if my desktop resolution matches my monitor's native resolution. If I change my desktop res to anything lower than 1440x900 it lets me change the setting without any problems.

    Squirminator2k on
    The Game of Rassilon - a Doctor Who Roleplaying Game podcast
    PortsCenterThe Life Toyetic with Ben and Molly
  • StormwatcherStormwatcher Blegh BlughRegistered User regular
    edited December 2009
    That's what I told you:
    - set res to less than native
    - change the scaling option to whatever you want (probably "scale up with fixed AR")
    - set res back to native.

    Even though scaling is grayed out after you go back to native, it should work. It does work fine on my machine.

    It's weird and counter-intuitive, but supposedly that's a feature not a bug.

    Stormwatcher on
    Steam: Stormwatcher | PSN: Stormwatcher33 | Switch: 5961-4777-3491
    camo_sig2.png
Sign In or Register to comment.