SATA drive not appearing

Metal Gear Solid 2 DemoMetal Gear Solid 2 Demo Registered User regular
So recently I've been attempting to set up a Seagate Barracuda SATA2 drive on my computer. I'm running ASUS PQ5 DELUXE P45 EAGLELAKE motherboard which has all the SATA ports on it with WinXP SP3, but whenever I plug it into various ports the computer won't detect it at all

I've attempted to plug into multiple red SATA ports on the mobo, as well as a single white one, but nothing changes. Drive manager only sees my C: and my external.

I was thinking it was due to a lack of proper drivers but I can't find any online and I don't think I have my mobo cd around

Also I saw some references to something I may have to do in my BIOS but not entirely sure what

Any suggestions?

SteamID- Enders || SC2 ID - BurningCrome.721 || Blogging - Laputan Machine
1385396-1.png
Orikae! |RS| : why is everyone yelling 'enders is dead go'
When I say pop it that means pop it
heavy.gif
Metal Gear Solid 2 Demo on

Posts

  • elliotw2elliotw2 Registered User
    edited November 2010
    So recently I've been attempting to set up a Seagate Barracuda SATA2 drive on my computer. I'm running ASUS PQ5 DELUXE P45 EAGLELAKE motherboard which has all the SATA ports on it with WinXP SP3, but whenever I plug it into various ports the computer won't detect it at all

    I've attempted to plug into multiple red SATA ports on the mobo, as well as a single white one, but nothing changes. Drive manager only sees my C: and my external.

    I was thinking it was due to a lack of proper drivers but I can't find any online and I don't think I have my mobo cd around

    Also I saw some references to something I may have to do in my BIOS but not entirely sure what

    Any suggestions?

    Open your BIOS, and look for the SATA disc controller settings. You want to change it from SATA mode to IDE/ATA/PATA/Legacy/whatever mode, and it should work.

    Option 2: Install Vista, which actually supports SATA

    elliotw2 on
    camo_sig2.pngXBL:Elliotw3|PSN:elliotw2
  • FoomyFoomy Registered User regular
    edited November 2010
    is not showing up in the disk management section of computer management? (admin tools->computer management->disk management) if it does show there, format it and assign a drive letter.
    is it showing up in the bios?

    Foomy on
    Steam Profile: FoomyFooms
  • Fred Savage Power GloveFred Savage Power Glove Registered User
    edited November 2010
    Foomy wrote: »
    is not showing up in the disk management section of computer management? (admin tools->computer management->disk management) if it does show there, format it and assign a drive letter.
    is it showing up in the bios?

    This. When I ran Windows, I'd forget that I had to do this every time I had a fresh, blank drive.

    Fred Savage Power Glove on
  • Metal Gear Solid 2 DemoMetal Gear Solid 2 Demo Registered User regular
    edited November 2010
    Foomy wrote: »
    is not showing up in the disk management section of computer management? (admin tools->computer management->disk management) if it does show there, format it and assign a drive letter.
    is it showing up in the bios?

    I mistakingly called it drive manager but yeah not appearing there

    will try bios thing now

    Metal Gear Solid 2 Demo on
    SteamID- Enders || SC2 ID - BurningCrome.721 || Blogging - Laputan Machine
    1385396-1.png
    Orikae! |RS| : why is everyone yelling 'enders is dead go'
    When I say pop it that means pop it
    heavy.gif
  • Metal Gear Solid 2 DemoMetal Gear Solid 2 Demo Registered User regular
    edited November 2010
    So I went into the bios and under Storage Configuration I found the SATA Configuration which was set to AHCI. Changed it to IDE and restarted but drive still wouldn't appear in disk management

    Turned off, swapped the SATA cable from the white port I had to a normal red port, restarted, still didn't appear

    Went back into the BIOS and it has SATA 1 through 6 listed now, with [Not Detected] next to each. If I go into one the Type is set to Auto and all the configurations beneath it are auto as well. Still nothing in disk management

    Feel like I'm getting closer but stumped as to what to try. There was the option to set the Type to Not Installed, but not sure if that's the right next step

    Metal Gear Solid 2 Demo on
    SteamID- Enders || SC2 ID - BurningCrome.721 || Blogging - Laputan Machine
    1385396-1.png
    Orikae! |RS| : why is everyone yelling 'enders is dead go'
    When I say pop it that means pop it
    heavy.gif
  • General_WinGeneral_Win Registered User
    edited November 2010
    I have the motherboard, make sure you're not plugging the sata cable into a RAID or eSATA port.

    Is your original drive an IDE (big ribbon, old tech) drive or a SATA drive? If it's a SATA you can put change the setting back to AHCI from IDE.

    Does the drive spin up when you turn the computer on?

    General_Win on
    tf2_sig.png
  • Metal Gear Solid 2 DemoMetal Gear Solid 2 Demo Registered User regular
    edited November 2010
    I have the motherboard, make sure you're not plugging the sata cable into a RAID or eSATA port.

    Is your original drive an IDE (big ribbon, old tech) drive or a SATA drive? If it's a SATA you can put change the setting back to AHCI from IDE.

    Does the drive spin up when you turn the computer on?

    Can't see any distinction between the SATA ports unless it's written on the mobo itself

    The only other drives I have are my C: which is IDE and an external through USB

    Haven't listened for the drive spinning up

    Metal Gear Solid 2 Demo on
    SteamID- Enders || SC2 ID - BurningCrome.721 || Blogging - Laputan Machine
    1385396-1.png
    Orikae! |RS| : why is everyone yelling 'enders is dead go'
    When I say pop it that means pop it
    heavy.gif
  • FoomyFoomy Registered User regular
    edited November 2010
    try checking the power connection to the drive, maybe it's loose or something.

    Foomy on
    Steam Profile: FoomyFooms
  • Metal Gear Solid 2 DemoMetal Gear Solid 2 Demo Registered User regular
    edited November 2010
    Unplugged and replugged multiple times, that shouldn't be an issue

    Metal Gear Solid 2 Demo on
    SteamID- Enders || SC2 ID - BurningCrome.721 || Blogging - Laputan Machine
    1385396-1.png
    Orikae! |RS| : why is everyone yelling 'enders is dead go'
    When I say pop it that means pop it
    heavy.gif
  • Metal Gear Solid 2 DemoMetal Gear Solid 2 Demo Registered User regular
    edited November 2010
    Any other suggestions on this?

    I've tried every SATA port that's on the motherboard itself. I don't have any in the back, just the 6 or so located on the motherboard itself to the right of all the PCI slots

    I've tried unplugging it and replugging it while the computer was turned on and there was no difference. It does feel like the drive is running though, but I don't hear any disc writing or anything

    Are there potentially any SATA drivers I'm missing?

    Metal Gear Solid 2 Demo on
    SteamID- Enders || SC2 ID - BurningCrome.721 || Blogging - Laputan Machine
    1385396-1.png
    Orikae! |RS| : why is everyone yelling 'enders is dead go'
    When I say pop it that means pop it
    heavy.gif
  • cuularcuular Registered User regular
    edited November 2010
    Have you tried going into Device Manager, right clicking on the "Disk drives" tab and selecting "Scan for hardware changes"?

    cuular on
  • Metal Gear Solid 2 DemoMetal Gear Solid 2 Demo Registered User regular
    edited November 2010
    Tried that, nothing comes up

    I did notice this though, underneath SCSI and Raid controllers there's a AHPW7YMJ IDE Controller that has a yellow exclamation mark on it and when I try to update the drivers my computer gets the new hardware pop-up, but then I run into an error saying "The specified service does not exist as an installed service" and it just keeps looping the Hardware Update Wizard. Not sure if it's related but thought I'd throw it out there

    Metal Gear Solid 2 Demo on
    SteamID- Enders || SC2 ID - BurningCrome.721 || Blogging - Laputan Machine
    1385396-1.png
    Orikae! |RS| : why is everyone yelling 'enders is dead go'
    When I say pop it that means pop it
    heavy.gif
Sign In or Register to comment.