Website in user profile

bowenbowen How you doin'?Registered User regular
It seems that if the user doesn't put http:// into their website in their profile, it doesn't automatically link or wrap, and on longer websites, it just gets cut off.

Can it be fixed so those website become clickable and http:// is assumed?

not a doctor, not a lawyer, examples I use may not be fully researched so don't take out of context plz, don't @ me

Posts

  • IcyLiquidIcyLiquid Two Steaks Montreal, QuebecAdministrator, Vanilla Staff vanilla
    edited October 2013
    I've had that request before, but the problem is that those fields are not Vanilla native, they're added by a plugin we have that lets the Admin create Custom Fields. Currently that plugin does not provide "type hints" for the fields, they're just standard text fields that pass through our formatter before being rendered to the page. The formatter understands that https? : // (.*) = URL, but the fields themselves are not of any particular type.

    So you see the problem.

    IcyLiquid on
    bowenZilla360
  • IcyLiquidIcyLiquid Two Steaks Montreal, QuebecAdministrator, Vanilla Staff vanilla
    Good idea, definitely, but not as trivial as it seems right now.

  • bowenbowen How you doin'? Registered User regular
    Indeed!

    Anyway to make it wrap at the least, that way one could copy paste? Either way no big deal, just ran across it and couldn't browse out to a website.

    not a doctor, not a lawyer, examples I use may not be fully researched so don't take out of context plz, don't @ me
Sign In or Register to comment.