[Help] Server Browser Saturating Connection?

Ash-HousewaresAsh-Housewares TARDIS HunterRegistered User regular
This is a problem I've been having for a few years now.

It seems when I run a 'refresh all' on a server browser in nearly any game with a high amount of internet servers (TF2, Dayz Standalone, L4D2, etc.) the browser returns really high pings (+200 ms).

After the refresh, I can select a server geographically close to me and refresh the one entity and it goes from a 250ms to 50ms ping.

The next step, I start a continual ping to my router before running the 'refresh all'. Router ping starts off 18ms and once the 'refresh all' starts it jumps to 200ms-600ms ping. After the 'refresh all' finishes, it goes back down to 18ms.

So my guess is, it's the amount of connections the router is trying to make which overloads the max udp/tcp connections. Which may cause the router to freak out but in all honesty, I really have no idea.

Pertinent information :

Internet Connection : Comcast 35down/15up
Router : Linksys WRT54g with DD-WRT firmware installed (Can give versions/revisions if needed)

Anyway, what do ya'll think? And how should I go about fixing this?

Edit: If you need more information let me know =)

Steam ID: Ash-Housewares | Twitch: Ash_Housewares
Ash-Housewares on

Posts

  • DigitalSynDigitalSyn Dr Digital Cumming, GARegistered User regular
    Actually I don't think you are hitting a limit of open connections, you are likely triggering DDoS protection or SYN Flood measures. Sometimes your ISP will do this as well ( rare, as they usually don't care ).

    Do you have a non-custom firmware router to plug in and see if the issue still exists? I am not familiar with DDWRT enough to know where you can go to confirm flood protection has tripped.

    Xbox360: D1G1T4LSYN ( Yes, those are numbers. )
    PSNID: DigitalX86
    Nintendo ID: digitalsyn
    3DS Friend Code: 5300 - 9726 - 6963
    Steam: http://steamcommunity.com/id/D1G1T4LSYN/
  • Ash-HousewaresAsh-Housewares TARDIS Hunter Registered User regular
    I just took my router out of the loop and connected straight to my cable modem. In TF2 server browser, atleast, I see alot pings in the 20ms range. During the server refresh I kept a continual ping to my cable modem and it goes from a steady <1ms ping to one entry that shows up at 4ms. So yeah, I'm gonna say it has something to do with my router.

    I guess since it's not ISP side, I'll start looking up flood protection in reference to DD-WRT. If nothing pings(ha) there I'll see if my router's hardware might be to blame. The router is up there in years, it might just be time to replace it.

    @DigitalSyn thanks for giving me a place to start!

    Steam ID: Ash-Housewares | Twitch: Ash_Housewares
Sign In or Register to comment.