PC - Ports closed regardless of forwarding

So I'm trying to open some ports for Dark Souls 2 multiplayer. I can access and change settings in my router just fine and added all relevant ports to the list of "forwarded ports". However, using websites or programs to check said ports for openness they are still marked as closed, even with a deactivated firewall. Any ideas?

My internet connection goes: PC => Switch => Router => Internet

steam_sig.png
Steam ID: 76561198021298113
Origin ID: SR71C_Blackbird

Posts

  • ZxerolZxerol HOW MANY POUNDS IS CAT POOP Registered User regular
    Are you connecting via a single router/modem combination device or through a router then a modem? If it's the latter, and depending on the modem and setup, you could possibly by running into a double NAT situation.

  • Blackbird SR-71CBlackbird SR-71C Registered User regular
    Zxerol wrote: »
    Are you connecting via a single router/modem combination device or through a router then a modem? If it's the latter, and depending on the modem and setup, you could possibly by running into a double NAT situation.

    I think it's router => modem, not sure, I didn't set it up. Even if, it doesn't appear in my network device list and I'm not sure how I'd edit its settings.

    steam_sig.png
    Steam ID: 76561198021298113
    Origin ID: SR71C_Blackbird

  • FoomyFoomy Registered User regular
    Did you remember to set a static IP for the computer? your pc could of grabbed a new IP when you rebooted sometime and is no longer getting the ports forwarded to it.

    Steam Profile: FoomyFooms
  • Blackbird SR-71CBlackbird SR-71C Registered User regular
    edited October 2014
    Foomy wrote: »
    Did you remember to set a static IP for the computer? your pc could of grabbed a new IP when you rebooted sometime and is no longer getting the ports forwarded to it.

    Hmmm no I didn't. How do I do this? Is that a router setting or something I set on my own PC?

    Edit: Though I remember taking a look at that in the router settings and it was the same every time. DHCP is enabled.

    Edit 2:

    Nevermind, I figured out how to set a static IP. Didn't help... Just to clarify, I turn my firewall off when testing ports, so that doesn't get in the way either. Not sure what else to do.

    Blackbird SR-71C on
    steam_sig.png
    Steam ID: 76561198021298113
    Origin ID: SR71C_Blackbird

  • DraygoDraygo Registered User regular
    Blackbird here are the troubleshooting steps you should follow:

    1) Plug your computer directly into your modem
    2) See if you can access desired port

    If you can then your computer is fine
    If you cannot then you need to get into your modem, or you might have AV software/firewall blocking the connection.

    So check for any possible blockage on your computer if not then log into your modem if the modem is configurable (combination modem/router)
    enter the gateway DHCP gives you into your web browser and log into the modem, many websites have the default passwords available if you need them. ATT modems have the access codes on a sticker on the modem.

    If the modem is in fact a modem/router combination then you will need to set up DMZ to point at the router when you reconnect it.

    If the you can access the desired port with just computer -> internet the next step is to check your actual router configuration. Make sure the routers firewall is ON. portforward.com will have specific instructions for your router brand as far as forwarding that game properly.

Sign In or Register to comment.