V-Sync / screen-tearing isssues (Solved)

HenroidHenroid Radio DemonInternet HellRegistered User regular
edited April 2017 in Help / Advice Forum
As long as I remember I've always had consistent minor screen tear issues across many different Windows versions and video cards, and I never really thought much of it. That changed this past week though since I got a new video card. I suppose I erroneously thought I'd be rid of the problem forever as no part of my computer (OS aside; Windows 7) is severely dated for the first time in ever. In Overwatch and other games the problem actually got much worse, where a 1 inch vertical space of the screen would be frames behind the rest of the screen. Now, that problem I actually found a solution for - changing those games to run in fullscreen rather than windowed-fullscreen. But I knew that it wasn't solving the problem on the native desktop / OS side of things.

The problem of screen-tearing still exists in Windows. It is harder to notice usually, but if there's a video playing somewhere on the screen eventually it will show a bit. I know it has something to do with a Windows based display setting, but I couldn't guess what it is or where I'd find it. Or maybe it's something else altogether.

Anyone know where I should be looking? And, hypothetically, once I solve it in this specific manner the display setting I changed for games shouldn't be required anymore right?

Nobody likes me but that's okay. I'm used to it.
Henroid on

Posts

  • dispatch.odispatch.o Registered User regular
    edited April 2017
    Tearing is caused by a difference in frame rate between the video card and the refresh rate of the monitor.

    No matter what card you have, if you run a game at 78FPS on a 60hz monitor, there will be tearing. VSync effectively caps your frame rate at your monitor refresh rate.

    You should check your display properties and make sure the refresh on your monitor is set correctly and that you've enabled VSnyc in your video card settings.

    I have to say, with modern LCD screens even without VSync you shouldn't be seeing as much artifact as I think you're describing. It's normally just a tiny difference in pixel alignment as the image updates without being timed with the monitor refresh. Even long before there were 144hz monitors as an FPS player I've run my frame rate uncapped with VSync disabled and barely noticed.

    What kind of monitor are you using?

    Edit: Display Adapter settings and monitor settings are both available by right clicking on your desktop. Depending on your video card there may be a few extra tabs to look through.

    What is your video card?

    dispatch.o on
  • HenroidHenroid Radio Demon Internet HellRegistered User regular
    My monitor is a Samsung SyncMaster 2033, and the video card is an EVGA Geforce GTX 1060.

    The only refresh rate on offer in Windows for my monitor is 60hz.

    Nobody likes me but that's okay. I'm used to it.
  • DonnictonDonnicton Registered User regular
    Do you have Windows Aero disabled? VSync will only work in Windows Vista/7 itself if Aero is both enabled and the current theme. There's no way around this.

    BouwsT
  • PaladinPaladin Registered User regular
    Force adaptive sync and see if that helps

    Marty: The future, it's where you're going?
    Doc: That's right, twenty five years into the future. I've always dreamed on seeing the future, looking beyond my years, seeing the progress of mankind. I'll also be able to see who wins the next twenty-five world series.
  • HenroidHenroid Radio Demon Internet HellRegistered User regular
    edited April 2017
    Paladin wrote: »
    Force adaptive sync and see if that helps
    What does this mean and how do I do it?

    Edit - I do indeed have Aero disabled, I just like the plain old Windows look.

    Henroid on
    Nobody likes me but that's okay. I'm used to it.
  • HenroidHenroid Radio Demon Internet HellRegistered User regular
    edited April 2017
    Donnicton wrote: »
    Do you have Windows Aero disabled? VSync will only work in Windows Vista/7 itself if Aero is both enabled and the current theme. There's no way around this.
    Just did some quick testing and this was indeed the issue. Going to a Windows Aero theme fixed all the screen tearing issues. That's so weird.

    Looking into it, Aero is based on Desktop Window Manager (DWM) running in the Task Manager, which it always has. Further looking into it, it's something that can be toggled in the Services menu. I'm gonna try forcing it into the on position without an Aero theme running, see what that does.

    Edit - Oh nevermind it doesn't work like that. Hmmm.
    Edit Edit - It at least let me customize colors / remove the dumb default desktop background and still keep Aero running. And things are running smoothly. So there we go I guess. I never knew that about Windows 7 & up. So dumb. I'd set Windows Classic because it had the theme that I liked almost right away. I had no idea I was disabling a whole THING because of it.

    Henroid on
    Nobody likes me but that's okay. I'm used to it.
Sign In or Register to comment.