As was foretold, we've added advertisements to the forums! If you have questions, or if you encounter any bugs, please visit this thread: https://forums.penny-arcade.com/discussion/240191/forum-advertisement-faq-and-reports-thread/

Desktop computer shutting itself off

OptyOpty Registered User regular
My desktop computer just suddenly started turning itself off. No blue screen, no warning, no increase in fan speed, just completely powered down. When I tried to turn it back on, it shut off in the exact same way again while loading Windows. My first instinct was to open it up and do a full dusting of everything and that seemed to work at first, letting it last long enough for me to boot into safe mode and copy some stuff to a USB drive, but it still eventually shut off again (luckily not during the copy). My guess is there's some form of hardware failure and/or overheating problem but I have no idea how to diagnose which component is the culprit. Does anyone have any advice or resources I could use to figure out what's going on?

Posts

  • LD50LD50 Registered User regular
    My first guess would be a power supply issue. Some things you can do:

    Check and make sure every power connector is well seated. Maybe unplug them all and plug them back in.

    Check the windows event viewer (just type 'event viewer' in the search bar in the start menu) assuming you can get it to stay on long enough. Look in windows->system. There's going to be a lot of stuff there, but make note of when exactly the power down happens and look at that time in the logs.

    Look for things marked critical. Get a cpu monitoring program like Core Temp. Keep an eye on your cpu temps and make sure they're not getting super high.

  • LD50LD50 Registered User regular
    A bit of a follow up:

    Assuming your temps check out and the information in event viewer isn't useful, you can try disconnecting all extraneous hardware. If you have a dedicated gpu, remove it and use the onboard graphics. Remove all but one stick of ram (leave the stick that is in the slot closest to the CPU). Unplug any drives that aren't needed to boot (extra hard drives, cd/dvd drives). Reboot and see if the problem persists. If it does persist it's almost certainly a faulty psu, but it could also be a faulty mainboard. If it goes away, it could either be a fault with something you removed or a faulty psu that can't deliver enough power to drive all your devices. At that point try and add back devices one at a time and see if you can isolate the issue.

    Alternatively: If you have a spare psu or one you can borrow from a friend, try using that psu instead and see if the problem goes away.

  • jungleroomxjungleroomx Never pre-order anything. Registered User regular
    edited May 2017
    It really sounds like either a GPU or PSU. If you've got a graphics adapter built in to the mobo, take out your gpu completely and see what happens.

    jungleroomx on
  • OptyOpty Registered User regular
    When I look at the Event Viewer there's absolutely nothing: the events just cut off when the power shuts off. It's pretty clear it's a hardware issue of some sort since Windows has no idea what's going on. I don't have any spare hardware to swap things out and my mobo doesn't have an onboard GPU, so all I could do was reseat the power connections, remove the DVD drive, and remove the hard drive, and that didn't stop it from happening. I remember there being some sort of bootable USB thing that'd be useful for running hardware diagnostics, but I can't remember what it was and I'm not sure if my system is stable enough for such a thing to even get a chance to work anyway.

  • LD50LD50 Registered User regular
    What processor do you have?

  • LD50LD50 Registered User regular
    Also, no software diagnostic will be able to detect a power problem, which is probably what you have.

    jungleroomxShadowfire
  • OptyOpty Registered User regular
    I built this thing in 2009, so everything's old as hell. Here's the CPU, here's the mobo, here's the GPU, and here's the power supply.

  • LD50LD50 Registered User regular
    If it were a problem with your GPU I would expect weirdness outside of the power issues. I'd be willing to bet you have a flakey PSU. It's old enough that I think replacing it would be a good idea anyhow.

    Jragghendonavannj
  • OptyOpty Registered User regular
    Would I be able to swap in a modern PSU like this one or would I need to find something older?

  • LD50LD50 Registered User regular
    PSUs haven't changed in ages. That PSU looks great.

    jungleroomx
  • OptyOpty Registered User regular
    edited June 2017
    Whelp, the new PSU didn't stop the problem from happening (I tested by letting it sit in the BIOS menu until it shut itself off), so it's something much harder to replace: the GPU, CPU, or motherboard. Since trying to figure out which one of those to replace will take just as much time as it would take to build a new one, my best bet at this point is probably to just go ahead and put together a new one.

    Opty on
  • MugsleyMugsley Registered User regular
    Ages (and ages) ago, I had similar problems with a build. It turned out to be my Abit motherboard that was the problem. I swapped out every other component before I found the problem.

    Gigabyte boards are usually build like tanks, but I'm guessing there's one or more of your power regulation/MOSFET components on the board that are either dead or dying. If you're trying to stay as cheap as possible, I recommend looking for a used board in Ebay or digging around for any discounted boards on enthusiast sites.

  • Grunt's GhostsGrunt's Ghosts Registered User regular
    I'm having the same problem, sort of. I was playing WoW last night when it suddenly turned off. When I tried to turn it on, it would turn on but nothing appeared on the screen. Also, it didn't do the beep noise that it normally does in start up.

    My build basically: https://pcpartpicker.com/list/gh8vLk

  • donavannjdonavannj Registered User regular
    I'm having the same problem, sort of. I was playing WoW last night when it suddenly turned off. When I tried to turn it on, it would turn on but nothing appeared on the screen. Also, it didn't do the beep noise that it normally does in start up.

    My build basically: https://pcpartpicker.com/list/gh8vLk

    Power supply or GPU issue most likely (maybe a combo where the PSU can't supply enough power to keep the GPU and the rest of the system running). That beep is part of the power-on self-test process (POST), and as part of the POST process it checks to see if can put out video. It will not beep if it cannot put out video. Try removing your GPU and either a) replacing it with a spare or b) switch to any onboard video your system has.

    steam_sig.png
  • Grunt's GhostsGrunt's Ghosts Registered User regular
    So, new power supply revealed that everything is fried.ek7y0bglpbqn.jpg

  • tsmvengytsmvengy Registered User regular
    edited June 2017
    Umm, what? Is that an ethernet cable? Power surge from there?

    tsmvengy on
    steam_sig.png
  • NEO|PhyteNEO|Phyte They follow the stars, bound together. Strands in a braid till the end.Registered User regular
    looks like a SATA cable to me, almost looks a bit fat for that though. Not that I have much occasion to look at them.

    It was that somehow, from within the derelict-horror, they had learned a way to see inside an ugly, broken thing... And take away its pain.
    Warframe/Steam: NFyt
    HeatwaveHandgimpNaphtaliShadowfire
  • Grunt's GhostsGrunt's Ghosts Registered User regular
    It's a SATA plugged in from my motherboard to my CD/DVD drive. It burned from both sides.

  • HeatwaveHeatwave Come, now, and walk the path of explosions with me!Registered User regular
    Yeah might want to get a surge protection powerboard

    P2n5r3l.jpg
    Steam / Origin & Wii U: Heatwave111 / FC: 4227-1965-3206 / Battle.net: Heatwave#11356
  • bowenbowen How you doin'? Registered User regular
    not a doctor, not a lawyer, examples I use may not be fully researched so don't take out of context plz, don't @ me
    HeatwaveShadowfire
Sign In or Register to comment.