Typing the Trademark symbol (™) turns it into an image?

DibbyDibby I'll do my best!Registered User regular
So apparently when you type out ™ it turns it into an image automatically?

Example post (Link):
Yhmnlfy.png

What it looks like when I hit the "Edit Post" button:
ZbJE1bS.png

Right clicking on the funky looking "tm" reveals a link: https://twemoji.maxcdn.com/2/72x72/2122.png

Which is an image of a TM emoji...? Not sure what's going on there.

DNiDlnb.png
Battle.net Tag: Dibby#1582

Posts

  • LD50LD50 Registered User regular
    It's unicode text on my end. What it gets turned into would depend on what's being used to view the webpage.

  • DibbyDibby I'll do my best! Registered User regular
    edited September 2018
    LD50 wrote: »
    It's unicode text on my end. What it gets turned into would depend on what's being used to view the webpage.

    Hrrrm that's weird. I'm using Chrome and I've never had this problem before until recently. I've always been able to use the normal unicode.

    edit: I can view the symbol just fine on any other website, it appears to only be messing up on here...

    double edit: Thought it might've been an addon or something, disabled everything... nothing. So it's not that...

    Dibby on
    DNiDlnb.png
    Battle.net Tag: Dibby#1582
  • BahamutZEROBahamutZERO Registered User regular
    it is a text character in firefox for me

    BahamutZERO.gif
    PLALord_Asmodeus
  • CambiataCambiata Commander Shepard The likes of which even GAWD has never seenRegistered User regular
    I see it as an image in Chrome which is my default browser. I checked in Firefox and it's not an image. Weird.

  • BahamutZEROBahamutZERO Registered User regular
    did you guys check if that symbol is rendering as an image on other websites or not? like https://en.wikipedia.org/wiki/Trademark_symbol
    if it is, then it's a browser thing, not something on PA's end

    BahamutZERO.gif
  • ASimPersonASimPerson Cold... ... and hard.Registered User regular
    On a Mac I see it was text regardless of browser.

    redoctober2.png
    SE++ Forum Battle Archive | PDT is not PST | DRUNKSTUCK: A Homestuck recap
  • DibbyDibby I'll do my best! Registered User regular
    did you guys check if that symbol is rendering as an image on other websites or not? like https://en.wikipedia.org/wiki/Trademark_symbol
    if it is, then it's a browser thing, not something on PA's end

    Yeah, already checked:
    Dibby wrote: »
    LD50 wrote: »
    It's unicode text on my end. What it gets turned into would depend on what's being used to view the webpage.

    Hrrrm that's weird. I'm using Chrome and I've never had this problem before until recently. I've always been able to use the normal unicode.

    edit: I can view the symbol just fine on any other website, it appears to only be messing up on here...

    double edit: Thought it might've been an addon or something, disabled everything... nothing. So it's not that...

    DNiDlnb.png
    Battle.net Tag: Dibby#1582
  • ASimPersonASimPerson Cold... ... and hard.Registered User regular
    Yeah, seeing it as an image on Chromium 58 on Windows. Since this is an old version, it's not a recent Chrome thing either.

    FWIW it seems to also do this with Edge on Windows.

    redoctober2.png
    SE++ Forum Battle Archive | PDT is not PST | DRUNKSTUCK: A Homestuck recap
  • EndEnd Registered User regular
    edited September 2018
    It looks like this is a feature of vanilla

    it's doing this test:
                const pixelRatio = window.devicePixelRatio || 1;
                const offset = 12 * pixelRatio;
                const ctx = canvas.getContext("2d");
                ctx!.fillStyle = "#f00";
                ctx!.textBaseline = "top";
                ctx!.font = "32px Arial";
                ctx!.fillText(testChar, 0, 0);
                emojiSupportedCache = ctx!.getImageData(offset, offset, 1, 1).data[0] !== 0;
    
    and then using twemoji (https://github.com/twitter/twemoji) if the test comes back not supported.

    testChar is the "T-Rex" unicode character (https://emojipedia.org/emoji/🦖/)

    It works fine on windows for me but not my Linux VM, but that does seem to be able to render the T-Rex Unicode character just fine under arial on a test page. I don't have time right now to check why it might not work with the canvas test, maybe later I will look.

    Also I do not recommend trying to put the T-Rex unicode character in a post, the rest of the message got cut off when I tried that (although it renders just fine in the url as url encoded, so that's weird)

    End on
    I wish that someway, somehow, that I could save every one of us
    zaleiria-by-lexxy-sig.jpgsteam~tinythumb.png
  • IrukaIruka Registered User, Moderator mod
    It's not a feature. We'll be patching this but its medium priority.

    DibbyElvenshae
  • DibbyDibby I'll do my best! Registered User regular
    edited September 2018
    Iruka wrote: »
    It's not a feature. We'll be patching this but its medium priority.

    Cool, thanks for the confirmation. Wasn't a huge deal for me tbh, but glad to see it's been noticed :)

    Dibby on
    DNiDlnb.png
    Battle.net Tag: Dibby#1582
Sign In or Register to comment.