Steam Broadcast: Not working on PC, but fine on phone

SatsumomoSatsumomo Rated PG!Registered User regular
So this one is a bit weird.

I can't broadcast, or watch other people's broadcasts using my PC. However, if I use my phone it works fine.

What happens is that the broadcast is on an endless loop of loading, it seems to load for a split second and then I see the loading icon again.

PC: Connected via LAN, already tried within Steam and on different browsers, same results. I turned off the Firewall, same results. Windows 10.

My phone is connected to the same network, and it loads broadcasts fine.

Any idea where to start troubleshooting? Could it be some sort of system-wide codec?


  • SatsumomoSatsumomo Rated PG! Registered User regular
    edited December 2019
    Update: I installed a VM on my PC and it streams fine through it.

    So I guess it's how my PC is handling whatever format Steam Broadcast is, right?

    This is what Firefox loops on when trying to watch a broadcast:

    Satsumomo on
  • ani_game_bumani_game_bum Optimistic, Rule-Breaking Nice Guy Always fading out of existence...Registered User regular
    Here is the Steam KB thread for troubleshooting the Client issues, which to me sounds like you need to update/reinstall a client file that is missing or corrupted if your VM install worked OK but not your main system (the second fix under the Basic section may be the way to go first):

    Do read up and take care, though; sounds like if not done correctly your games and user data can get deleted if you do a straight-up uninstall.


    Wii FC: 2569 0668 1330 4703 3DS FC: 5455 9912 6458
    PSN: ani_game_bum ID: Anigamebum#1354
    Steam Wishlist
  • SatsumomoSatsumomo Rated PG! Registered User regular
    Just a note, I did not install the Steam client on the VM, I simply put the broadcast on the browser and it worked instantly, on the pre-installed version of Edge.

  • OrogogusOrogogus San DiegoRegistered User regular
    Are you running any antivirus or antimalware programs, or adblocker extensions? Or did you edit your Windows HOSTS file to block ad or malware sites?

  • SatsumomoSatsumomo Rated PG! Registered User regular
    Only Windows Defender, have tried it with them disabled, same issue. Nothing in my hosts files, and only ublock origin, but happens even if its disabled (And I can't see broadcasts on Edge or Steam anyways).

    I find it weird that I'm getting 404 errors in the log. I assume something is simply blocking it right? Is there a way to see if a process blocks a connection?

  • SatsumomoSatsumomo Rated PG! Registered User regular
    edited December 2019
    Yeah just did a test on both my PC and the VM:


    On my PC: Ping request could not find host Please check the name and try again.

    And it worked perfectly on the VM, with an average 2ms response time.

    Interesting development, when I ping said address above, the VM gets a response from and if I try to ping that in my PC, it works.

    This seems like a DNS issue, I did a flush and switched to Google's DNS and it still isn't working. Arghhh!

    Satsumomo on
  • OrogogusOrogogus San DiegoRegistered User regular
    Try in Windows Safe Mode?

  • SatsumomoSatsumomo Rated PG! Registered User regular

    I managed to get some really good support from Steam (I had to insist on escalating because they were just sending me to the FAQs) and after several back and forths, we found out that this was being caused by my Windows 10 computer not syncing time correctly. Yup, weird but that was it.

    For some reason if I sync my time with microsoft time, it goes 4 minutes into the future. So I manually set my time to match my phone and voilá, I can view streams.

Sign In or Register to comment.