Warcraft woes [no more!]

Casual EddyCasual Eddy The Astral PlaneRegistered User regular
edited December 2006 in Help / Advice Forum
So I want to play DoTA with my brother who's at a different college. So I buy the Warcraft III battlechest for the low low price of 30 dollars from an EB. I install both the original and the expansion on my computer when I hit a slight snag. As soon as I open either version the screen turns black and quits back to the desktop. A little Error Report pops up and offers to send the info to Mac for further examination. I tried reinstalling both portions of the game (with completely deleting the game from the computer to reinstall) as well as several restarts. I've examined the readme and the manual but it doesn't seem to have a fix available. EDIT: Now when I try to open WC3 the application image appears on the bar at the bottom of the screen for a moment and then vanishes. Erggg.

Some notes:

-I'm on a MacBook with a 2 GHz Intel Core Duo and 1GB 667 MHz DDR2 SDRAM. Which I assume means something significant. WC3 is a dual disk and works with OsX - which is what my quite new laptop came with.
-The second time I tried to reinstall, I shut down all other applications and did absolutely nothing during installation. 'Cause I heard that was bad once.
-The CD is undamaged and new. The CD-Key is genuine.
-This is totally lame.

Anyone have ideas?

So it turns out the fellow at the bottom of the thread was right. I trashed the video files in the warcraft folder and now it works. I'm getting my ass kicked at DoTA, yipee!

Elki wrote: »

Casual Eddy: best poster 2014.
tyrannus wrote: »
Casual Eddy: best poster of 2015

gotta update that stuff man
Casual Eddy on

Posts

  • DeVryGuyDeVryGuy Registered User
    edited December 2006
    Has a universal binary been released for WC3? The build your playing was built for PPC and your running it on an intel, which is likely the source of your problems.

    Try installing and running this, I have no idea if it will help or not. Good luck

    http://www.versiontracker.com/dyn/moreinfo/macosx/20130

    DeVryGuy on
    Pokemon Diamond: 5369 6910 9799
    FFTSig.jpg
  • DeVryGuyDeVryGuy Registered User
    edited December 2006
    After looking on MacRumors list of universal binary games, Bliz has not released or announced plans on making a universal binary for WC3 (they are busy shoveling loads of money from WoW into a big pile, presumably), so you might be SOL until they decide to do so.

    There are spotty reports from WC3 running slowly to running perfectly, so I guess try running the update above and give it a shot. Otherwise return the game. Since it says it runs on OS X and it doesn't they shouldn't give you too much hassel.

    Source:
    http://guides.macrumors.com/Universal_Binary_Games

    DeVryGuy on
    Pokemon Diamond: 5369 6910 9799
    FFTSig.jpg
  • Casual EddyCasual Eddy The Astral PlaneRegistered User regular
    edited December 2006
    Thanks! I'm going out for a bit but i'll give that I try when I get back.

    Casual Eddy on
    Elki wrote: »

    Casual Eddy: best poster 2014.
    tyrannus wrote: »
    Casual Eddy: best poster of 2015

    gotta update that stuff man
  • Casual EddyCasual Eddy The Astral PlaneRegistered User regular
    edited December 2006
    It seems my computer isn't recognizing the application. After I've installed it the CD menu doesn't change from "Install Game" to "Play Game." Additionally, the patch program can't find anything to patch. It's a ROC patch for the ROC version, and I'm sure the game isn't up to date. So the patch refuses to work. Looks like I'm returning it when I can get off my ass. :cry:

    Thanks for the help though. Someday blizzard will finish moving around it's WoW money with huge bulldozers and steamshovels.

    Casual Eddy on
    Elki wrote: »

    Casual Eddy: best poster 2014.
    tyrannus wrote: »
    Casual Eddy: best poster of 2015

    gotta update that stuff man
  • TrippyDKTrippyDK Registered User
    edited December 2006
    I had this same problem. Turns out it has something to do with quicktime trying to play all the cutscene videos and stuff liek that. You have to archive the encode and decode files or something like that. I hope this at least gives you a step in the right direction.

    TrippyDK on
  • Casual EddyCasual Eddy The Astral PlaneRegistered User regular
    edited December 2006
    That sounds promising, but I don't have any idea what you're talking about.

    Casual Eddy on
    Elki wrote: »

    Casual Eddy: best poster 2014.
    tyrannus wrote: »
    Casual Eddy: best poster of 2015

    gotta update that stuff man
Sign In or Register to comment.