As was foretold, we've added advertisements to the forums! If you have questions, or if you encounter any bugs, please visit this thread:

Xbox 360S, Netflix won't start/play [solved]

Custom SpecialCustom Special I know I am, I'm sure I am,I'm Sounders 'til I die!Registered User regular
Hoping someone has seen this issue before.
I got a new Xbox 360S Friday, transferred all my data over and started using it right away (from an old white 360).
When I open the Netflix app it just sits on the home screen (red; "Netflix"). It doesn't start up the loading wheel at all, just sits.
All I can find online is to delete the app, clear the Xbox cache and download the app again but that hasn't worked.
I deactivated all my devices online at the Netflix site. I also plugged my old box back in, downloaded Netflix and it worked (made sure it didn't have something saved on there that was holding it back).

Anyone seen this before or have any ideas? I can't figure out anything...

edit: Found some related system files that needed to be removed so that they would download again when Netflix started.

edit2: Someone had the same problem, solution was (off the top of my head):
I think it was Settings > System > Storage > HD > Games and Apps. Then scroll down to where Netflix is and there should be a Netflix entry (mine had the logo) to delete as well as a Netflix data entry (just had a generic grey icon; forget the exact name). Each of those entries in the list will say they have 4 or 5 items when you delete (you want them all gone).

After you remove those, restart and download Netflix again.

XBL: F4ll0utBP | STEAM | PSN : CustomSpecial | Bnet: F4ll0ut#1636
Custom Special on
Sign In or Register to comment.