As was foretold, we've added advertisements to the forums! If you have questions, or if you encounter any bugs, please visit this thread: https://forums.penny-arcade.com/discussion/240191/forum-advertisement-faq-and-reports-thread/

Linux Question (fixed, please close).

azith28azith28 Registered User regular
edited June 2014 in Help / Advice Forum
Got a question and the linux board i usually go to has been unhelpful so far.

I'm trying to qualify some new hardware for an image. We want the same image to be applied to old hardware and new, yet the new hardware needs the default sound card set to card 1 and the old hardware needs the default set to card 0 in alsa.conf to work. Can this be setup in the config file to detect or support both possible options?

/proc/asound/cards on the new hardware:
0 [Intel ]: HDA-Intel -HDA Intel
HDA Intel at 0xf7c34000 irq 16
1 [Intel_1 ]: HDA-Intel - HDA Intel
HDA Intel at 0xf7c30000 irq 22

Old hardware /proc/asound/cards:
0 [Intel ]: HDA-Intel - HDA Intel
HDA Intel at 0xfc520000 irq 16

lspci on the new hardware for the audio devices:

00:03.0 Audio device: Intel Corporation Device 0c0c (rev 06)
Subsystem: Lenovo Device 309f
Flags: bus master, fast devsel, latency 0, IRQ 16
Memory at f7c34000 (64-bit, non-prefetchable) [size=16K]
Capabilities: [50] Power Management version 2
Capabilities: [60] Message Signalled Interrupts: Mask- 64bit- Count=1/1 Enable-
Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
Kernel driver in use: HDA Intel
Kernel modules: snd-hda-intel

00:1b.0 Audio device: Intel Corporation Device 8c20 (rev 04)
Subsystem: Lenovo Device 309f
Flags: bus master, fast devsel, latency 0, IRQ 22
Memory at f7c30000 (64-bit, non-prefetchable) [size=16K]
Capabilities: [50] Power Management version 2
Capabilities: [60] Message Signalled Interrupts: Mask- 64bit+ Count=1/1 Enable-
Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
Capabilities: [100] Virtual Channel <?>
Kernel driver in use: HDA Intel
Kernel modules: snd-hda-intel

/usr/share/alsa/alsa.conf:
Old system uses
defaults.ctl.card 0
defaults.pcm.card 0

New system to get sound working i had to change this to
defaults.ctl.card 1
defaults.pcm.card 1

I've been trying to make the system index the cards so that both are card 0 by adding a /etc/modprobe.d/alsa.conf file. I've tried indexing by vid/pid using the options snd-hda-intel index 1,2 vid=0x(etc) pid=0x(etc) but when i put this file in the modprobe.d directory and reboot the system doesnt find any sound cards at all, even when i reverse the order. i also tried indexing by driver but all that does is make card 0 1 and card 1 card 2 with no card 0.

Thanks for your help

Edit:
Found a workaround. closing.

Stercus, Stercus, Stercus, Morituri Sum
azith28 on
Sign In or Register to comment.