As was foretold, we've added advertisements to the forums! If you have questions, or if you encounter any bugs, please visit this thread: https://forums.penny-arcade.com/discussion/240191/forum-advertisement-faq-and-reports-thread/

Sony XBR4 / XBR5: the wierdest feature you'll never need

AlienCowThatMoosAlienCowThatMoos Registered User regular
edited June 2008 in Games and Technology
So I finally got around to buying a flat panel TV, the KDL-40XBR4. It's a damn fine TV. Spectacular picture. And then to remind me that it's by Sony, a square kick in the balls after they've got my money.

There's a feature called auto dim. It makes blacks blacker by dimming the backlight in scenes with lots of darkness. Making them harder to see. It doesn't even happen immediately; it takes a moment to register all the black and darken, then again to register the light scene afterwards and return to normal. It's like that old copy protection on VHS tapes that kicked in when you hooked two VCRs together.

I can't imagine any movie or show in the history of existence that would benefit from this "feature." I'm watching the HD DVD release of classic Star Trek and it kicks in on half of the exterior space shots. It's extremely noticeable, like a retard breaking down your door and yelling "This shot is dark! Durrr!"

Researching on the net I found out how auto dim came to exist. Back in the XBR2 days there were serious clouding issues with blacks. People kept complaining so Sony "fixed" the problem by releasing a firmware update that dimmed the back light whenever there was a lot of black on screen so you can't see the cloudiness. But this was not added as a feature you can turn off or on, it's just on and never turns off.

I figured someone here must have the technical knowledge I seek: Is there anyway to turn it off? Can it be turned off from the service menu? Has someone created custom firmware to remove it? Warranty be damned, I just want my TV to work.

I understand that "game mode" will disable auto dim, but when I turn it on the picture goes from being colorful, bright and beautiful to drab, dim and ugly. I can change the picture settings, but only manually; the pre-sets are locked out. Does game mode disable any other important features? What precisely does game mode do anyway?

Someone please help!

SpidermanSig.jpg
AlienCowThatMoos on

Posts

  • ChenjesuChenjesu Registered User regular
    edited June 2008
    That's not a proprietary Sony feature. I have a Sharp Aquos, and it has a similar feature, but I believe it can be shut off on the Sharp. It's certainly not as bad an issue as you describe on normal viewing.

    From what I've read, it's also a common solution to another inherent LCD weakness: poor contrast ratio. If they do the dimmy thing, they can count the difference between black with the light dimmed, and white with it at full blast, and they get a better numerical contrast ratio, even if it's obnoxious to actually use.

    Chenjesu on
  • ThreepioThreepio New Westminster, BCRegistered User regular
    edited June 2008
    Long story short: Buy a Plasma.

    Threepio on
    142.jpg
  • AlienCowThatMoosAlienCowThatMoos Registered User regular
    edited June 2008
    Chenjesu wrote: »
    That's not a proprietary Sony feature. I have a Sharp Aquos, and it has a similar feature, but I believe it can be shut off on the Sharp. It's certainly not as bad an issue as you describe on normal viewing.

    From what I've read, it's also a common solution to another inherent LCD weakness: poor contrast ratio. If they do the dimmy thing, they can count the difference between black with the light dimmed, and white with it at full blast, and they get a better numerical contrast ratio, even if it's obnoxious to actually use.

    I've watched a few movies and played a few games and at first the only place I noticed this thing is at the credits. It looked annoying and extremely unprofessional (and extraordinarily obvious, like the text would go from pure white to dark grey) but it wasn't a big deal, it was just the credits. Then I popped in Star Trek and it . happpens. all. the. god. damn. time.

    I hate it and I want it gone. If it weren't for this one issue it would be the finest tv I've ever seen.

    AlienCowThatMoos on
    SpidermanSig.jpg
  • AlienCowThatMoosAlienCowThatMoos Registered User regular
    edited June 2008
    Also, I aware that LCDs don't display the same level of deep black that Plasmas do. I like that. I prefer a brighter image. In other words, even if this auto-dim worked perfectly (which it very much doesn't) I'd like to be able to set the screen to a certain brightness and have it stay there.

    AlienCowThatMoos on
    SpidermanSig.jpg
  • Sci-Fi WasabiSci-Fi Wasabi Registered User regular
    edited June 2008
    I bought last years 32" S series from Target and this feature was so god-awful that I couldn't see anything in AVP2 or Alien. It also had a garrish red push that just looked awful, like they were just trying to hit the 6500k standard without, you know, making sure the picture looked good.

    Also the picture had HORRIBLE fucking line sharpening. Everything had a bright white line around the edges. If you lowered the sharpness, the only thing would change would be the legibility of the fucking menu!

    I thought Sony's were the shit until I owned that tv.

    Sci-Fi Wasabi on
    sci+fi+wasabi.png
  • AlienCowThatMoosAlienCowThatMoos Registered User regular
    edited June 2008
    I've found it. If anyone else is suffering the same problem, it's removed or at least minimized to the point that I can't see it by turning "Advance C.E." to "Off."

    AlienCowThatMoos on
    SpidermanSig.jpg
  • Sci-Fi WasabiSci-Fi Wasabi Registered User regular
    edited June 2008
    I've found it. If anyone else is suffering the same problem, it's removed or at least minimized to the point that I can't see it by turning "Advance C.E." to "Off."

    My model didn't have that option, unfortunately. I hope the use of this "feature" doesn't become too widespread.

    Sci-Fi Wasabi on
    sci+fi+wasabi.png
  • AlienCowThatMoosAlienCowThatMoos Registered User regular
    edited June 2008
    I've found it. If anyone else is suffering the same problem, it's removed or at least minimized to the point that I can't see it by turning "Advance C.E." to "Off."

    My model didn't have that option, unfortunately. I hope the use of this "feature" doesn't become too widespread.

    Are you sure? It's hidden under "Picture" > "Advanced Settings." After testing a bit the effect does seem to still be there, but it's not as insanely noticeable now. I can't see it when the movie goes to credits or when Star Trek cuts to the outside of the ship. I can see it when using the tv's setup menus with nothing in the background (ie. blackness).

    AlienCowThatMoos on
    SpidermanSig.jpg
Sign In or Register to comment.