As was foretold, we've added advertisements to the forums! If you have questions, or if you encounter any bugs, please visit this thread: https://forums.penny-arcade.com/discussion/240191/forum-advertisement-faq-and-reports-thread/
Options

Simcity 3000 in Vista 32-bit

Dr SnofeldDr Snofeld Registered User regular
edited September 2008 in Help / Advice Forum
Installs fine, but when I try and run the game the Maxis loading thingummy pops up on screen and nothing happens. Can't even bring up Task Manager unless I take the disc out, and even then the Maxis thingummy is still on screen, though I can still use other programs since it's not on top. Running in compatability mode for XP and 98 does nothing. Any ideas?

l4d_sig.png
Dr Snofeld on

Posts

  • Options
    Al_watAl_wat Registered User regular
    edited September 2008
    Dunno if this will work, but i was having problems yesterday with starting up Mass Effect and this seemed to help: When you go to run the application, right click and choose "run as administrator".

    Al_wat on
  • Options
    evilmrhenryevilmrhenry Registered User regular
    edited September 2008
    I'm on Vista 32bit, and just installed and ran Simcity 3k no problem. (Everything on defaults.)

    EDIT: Maybe a corrupt install? Try running it from the start menu? It doesn't look like a generic Vista problem, though.

    evilmrhenry on
  • Options
    Dr SnofeldDr Snofeld Registered User regular
    edited September 2008
    Reinstalled and ran from the start menu as Administrator (which shouldn't make a difference since I AM the Administrator for my PC, nobody else uses it) and the same thing happened. Could be having problems reading the disc, I suppose.

    Dr Snofeld on
    l4d_sig.png
  • Options
    JustinSane07JustinSane07 Really, stupid? Brockton__BANNED USERS regular
    edited September 2008
    Unlimited or the original?

    Because I got them both to work on Ultimate64. I did, however, use the command line shortcuts to skip the opening movie as that was having problems.

    JustinSane07 on
  • Options
    Al_watAl_wat Registered User regular
    edited September 2008
    Dr Snofeld wrote: »
    Reinstalled and ran from the start menu as Administrator (which shouldn't make a difference since I AM the Administrator for my PC, nobody else uses it) and the same thing happened. Could be having problems reading the disc, I suppose.

    yeah its retarded. Things SHOULD always register you as administrator, but sometimes it doesn't work. This is not only a problem with Vista, when I did some IT work I would run into it all the time with XP.

    But since you tried it, doesn't seem like this is your issue.

    Al_wat on
  • Options
    Dr SnofeldDr Snofeld Registered User regular
    edited September 2008
    Unlimited or the original?

    Because I got them both to work on Ultimate64. I did, however, use the command line shortcuts to skip the opening movie as that was having problems.

    It's the UK edition, which is World Edition with extra buildings, so I dunno, Unlimited I'd assume.

    Dr Snofeld on
    l4d_sig.png
  • Options
    Dr SnofeldDr Snofeld Registered User regular
    edited September 2008
    Think you could give me those command line shortcuts so I can try? See if it's a problem with the opening cinematic.

    Dr Snofeld on
    l4d_sig.png
  • Options
    JustinSane07JustinSane07 Really, stupid? Brockton__BANNED USERS regular
    edited September 2008
    Argh, I just spent like a half hour looking and I can't find them. But I did come across this...

    Vista has a Compatibility Mode similar to the Windows XP version..

    To install a program using Windows XP's Compatibility Mode, hold
    down SHIFT as you insert the game CD, use My Computer to browse
    to the setup program, and then skip down to step 1 in the list below:

    To run an installed program using Windows XP's Compatibility Mode,
    first right click the program and "Send To..." / Desktop (create shortcut).

    1.. Right click on the shortcut to the program.
    2.. Click on Properties.
    3.. Click on the Compatibility tab.
    4.. Click on Run this program in compatibility mode and select one of these:
    a.. Windows 95
    b.. Windows 98
    c.. Windows NT 4
    d.. Windows 2000
    5.. Under Display settings, check mark the mode that you think that is best:
    a.. Run in 256 colors.
    b.. Run in 640 X 480 screen resolution.
    c.. Disable visual themes.

    Click on Apply.Click on Ok.Double click on the program.

    JustinSane07 on
  • Options
    Dr SnofeldDr Snofeld Registered User regular
    edited September 2008
    Argh, I just spent like a half hour looking and I can't find them. But I did come across this...

    Vista has a Compatibility Mode similar to the Windows XP version..

    To install a program using Windows XP's Compatibility Mode, hold
    down SHIFT as you insert the game CD, use My Computer to browse
    to the setup program, and then skip down to step 1 in the list below:

    To run an installed program using Windows XP's Compatibility Mode,
    first right click the program and "Send To..." / Desktop (create shortcut).

    1.. Right click on the shortcut to the program.
    2.. Click on Properties.
    3.. Click on the Compatibility tab.
    4.. Click on Run this program in compatibility mode and select one of these:
    a.. Windows 95
    b.. Windows 98
    c.. Windows NT 4
    d.. Windows 2000
    5.. Under Display settings, check mark the mode that you think that is best:
    a.. Run in 256 colors.
    b.. Run in 640 X 480 screen resolution.
    c.. Disable visual themes.

    Click on Apply.Click on Ok.Double click on the program.

    Compatability mode? Tried it.

    Oddly enough SimCity 2000 works just perfectly, but I'm not as good at that one for some reason.

    Dr Snofeld on
    l4d_sig.png
Sign In or Register to comment.