As was foretold, we've added advertisements to the forums! If you have questions, or if you encounter any bugs, please visit this thread:

USB devices not working on boot in OSX, iSight on from boot.

yalborapyalborap Registered User regular
So, I have an iMac. Nice machine, lasted a good three years without trouble. Then the hard drive started to die. I freaked a little, lacking backups, but quickly got it to a nearby authorized reseller and service center. They got it back to me in a day or two, said they'd fixed a directory tree problem and it was good to go. I got an external hard drive, made a backup, all seemed good.

Then it died again about 12 hours later. I stayed calm, took it in, they said they'd fix it with only the charge for parts due to the proximity of it. I went to Comic-Con before it was done, and got it back when I returned, with an additional note that they'd found the inverter board damaged and, on the off chance it'd been them that'd caused it, fixed it no charge.

So I got back and hooked up my mac, eager to be off this shitty old laptop. And...The camera turns on from boot. That's odd. More odd: My mouse and keyboard don't work until I take it in and out of sleep mode several times.

Browse around internet. Find existence of thing called SMC that handles power-related stuff and might be part of the problem. Use method to try and fix it. Doesn't work. Machine is still loopy. Some internet people suggest internal USB hardware might be fucked.

Gonna take it in tomorrow, but first, is there anything else I can do other than the official method(yank all cords, let sit for 15 seconds, replug in) to potentially fix this on my own? Second, should I just ask for a goddamned replacement machine, since I'll be going in for the third time in a month with three separate problems occurring? And finally, how likely is it that this was;

A: Software based


B: Something easily broken during the two replacement processes?

yalborap on


  • TrentusTrentus Registered User regular
    edited July 2009
    It might be worth trying a parameter ram reset (hold command+option+p+r on boot, wait for it to chime a second time (or first if you had it muted) and release). It's fixed a few USB issues for me in the past (or otherwise it's just coincidence that they were resolved afterwards).

    Trentus on
  • yalborapyalborap Registered User regular
    edited July 2009
    Tried that...Nothin'. Same problems.

    yalborap on
Sign In or Register to comment.