Problems with Presario 2100 laptop

amateurhouramateurhour One day I'll be professionalhourThe woods somewhere in TennesseeRegistered User regular
So a friend of mine gave me a free laptop, which is awesome. It's the Presario 2100 from a couple years back.

It's got an AMD Athlon XP mobile processor (2.16 ghz), 704 megs of ram, ATI graphics, and is overall a pretty good system. He said the only problem was that the pci card slot and usb drives won't work. I haven't tried the pcmia slot yet, but the USB port does nothing when I plug something in.

Thing is though, they're both registered as working properly in hardware settings, so I know they're at least still connected to the motherboard and registering.

My questions are:

1) Any way to fix the usb port issue? I've got XP pro installed with all the latest updates, and what I think are the latest updates for the laptop hardware.

2) If not, where is a reputable place to buy motherboards online? They're too expensive through compaq, and I've gotten bad reviews about the ebay sellers through compaq support forums. (I checked the support forums for USB help, but to no avail)

If I can't get it working, and the motherboard is too expensive, I'm going to gut the screen for another project and just use it as a firewall/file server. Just hoping I could get it working first.


Arch wrote: »

I never expected this burn from captain bushmeat
amateurhour on

Posts

  • ben0207ben0207 Registered User regular
    edited April 2008
    I used to have on of these!

    I don't know how to fix yor problem though.

    ben0207 on
  • That_GuyThat_Guy I don't wanna be that guy Registered User regular
    edited April 2008
    I assume you did a fresh install of XP with all the drivers? If so, a new mobo for a laptop is WAY more trouble and cost than you are going to want to invest. Most of the time things like video cards, and mobile processors are soldered to the board and are NOT easy to remove.

    That_Guy on
    steam_sig.png
Sign In or Register to comment.