Eeepc 901 drive issues w/ UNR 9.10

EvigilantEvigilant VARegistered User regular
I recently installed the Ubuntu NBR 9.10, updating from 9.04. LiveCD works fine, it installs and runs fine, but after 1-2 restarts I get the following issue:
One or more of the mounts listed in /etc/fstab cannot yet be mounted:
/home: waiting for UUID=(uuid)
Press ESC to enter a recovery shell
init: mountall-shell main process (784) terminated with status 127
mountall start/starting
swapon: /dev/disk/by-uuid/(uuid): swapon failed: Device or resource busy
mountall: swapon /dev/disk/by-uuid/(uuid) [833] terminated with status 255
mountall: Problem activating swap: /dev/disk/by-uuid/(uuid)
One or more of the mounts listed in /etc/fstab cannot yet be mounted:
(ESC for recovery shell)
/home: waiting for UUID=(different UUID)

mountall: Cancelled
Running fsck /dev/sdb
[   33.649464] Buffer I/O error on device sdb1, logical block 1
[]                     Buffer I/O error on device sdb1, logical block 2
[]                     Buffer I/O error on device sdb1, logical block 3.....through 9
[   138.733534] ata2.01: status: { EBR }
[]                                        error: { IDNF ABRT }
[]                                        exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6
[]                                        cmd 20/00:40:3f:00:00/00:00:00:00:00/f0 tag 0 pio 32768 in
[]                                        res 17/17:17:17:17:17/00:00:00:00:00/17 Emask 0x3 (HSM Violation)

This error repeats several times but the number between the brackets [] changes. The status, error, exception, cmd, res, etc... all stay the same.

It ends with:
end_request: I/O error, dev sdb, sector 63
e2fsck 1.41.9 (22-Aug-2009)
fsck.ext2: Device or resource busy while trying to open /dev/sdb
Filesystem mounted or opened exclusively by another program?
[email protected]: ~#

/dev/sdb1 being /home
/dev/sdb2 being extended
/dev/sdb5 being Linux swap

I'm relatively new to the Linux world, Ubuntu Hardy Heron -> Jaunty NBR being my experiences.

I try unmounting the device (so I can mount it) using umount /dev/sdb1 but to no avail. It tells me the device isn't mounted. Trying mount /dev/sdb1 returns the error found using fsck. Using fdisk I can: delete, create, edit the partition and partition table. If I boot into liveCD I see /dev/sdb is formatted with /dev/sdb1 /home /dev/sdb2 /dev/sdb5 swap. I've tried re-downloading the UNR 9.10 off of the ubuntu website, re-installed several times and I get the same result.

If I have UNR up and running for a bit after a fresh install then I try updating it through the update manager. It immediately hangs once updating has completed, goes into a complete freeze and requires a complete forced power-off. Once it reboots same issue. I've tried installing Moblin on the netbook and it works fine, as long as I don't update it. Once I update Moblin using the update manager, I lose the /dev/sdb disk and the entire thing goes to shit.

What's going on? Is the disk dead or something else? Anyone know what I can do to fix it other than replacing the netbook?

Google+ Profile XBL\PSN\Steam\Origin: Evigilant
Evigilant on

Posts

  • ImpersonatorImpersonator Registered User regular
    edited November 2009
    What do you have in sda? /boot?

    Impersonator on
    Bioptic wrote: »
    Lemmings was pro-Communist propeganda. All are created equal, sorted into specific jobs and roles that they will hold for the rest of their lives by a higher authority, and must sacrifice continuously for the good of the group. Success is measured by meeting quotas and nothing else. Also, nuclear holocaust.
  • EvigilantEvigilant VARegistered User regular
    edited November 2009
    What do you have in sda? /boot?

    sda is /

    Evigilant on
    Google+ Profile XBL\PSN\Steam\Origin: Evigilant
Sign In or Register to comment.