The image size limit has been raised to 1mb! Anything larger than that should be linked to. This is a HARD limit, please do not abuse it.
Our new Indie Games subforum is now open for business in G&T. Go and check it out, you might land a code for a free game. If you're developing an indie game and want to post about it, follow these directions. If you don't, he'll break your legs! Hahaha! Seriously though.
Our rules have been updated and given their own forum. Go and look at them! They are nice, and there may be new ones that you didn't know about! Hooray for rules! Hooray for The System! Hooray for Conforming!

Can see photos when memory card is in the camera, but not in Windows...

ueanuean Registered User regular
edited May 2010 in Help / Advice Forum

So, my work has a camera, a Sony Cybershot DSC-S950. Overall, a crappy cheap camera, but it does the job.

There have been about 380 pictures taken with the camera, and they're all pretty necessary as we've documented things over the past few weeks. With the memory card in the camera (memory card is a 4GB Lexar Memory Stick Pro Duo) I can cycle through every single picture on the card. When I remove the card and try and view the pictures on the camera, I can't, as (duh) the card is out of the camera. When I insert the card into my computer's built in card reader, the card shows up empty - zero files ("This folder is empty"). The computer I am using is a Sony Vaio VGN-FW140D with Windows Vista Home Premium.

So, boiled down to the core problem - the card displays 384 photos when it is plugged into the camera. It displays nothing when plugged into windows.

Steps tried so far:
-Check to see if photos are stored on the camera's internal memory. They are not (removing the card also removes ability to see the pictures)
-Try plugging the memory card into the computer's built in card reader (no pictures)
-Try plugging the memory card into an external card reader (no pictures)
-Try plugging the memory card into an external card reader with another computer [Windows XP] (no pictures)
-Right click the memory card and check properties when plugged into either the built in card reader or an external card reader (3.32GB used, 406MB free in both cases)
-Scan the card with a memory card undelete program [UndeletePlus] - shows 4 files only, hidden files
-Try to open the memory card drive with "cmd" -> e:\ - this shows an empty drive with no files

Stumped :(

Guys? Hay guys?
PSN - sumowot
uean on


  • ueanuean Registered User regular
    edited May 2010
    Aha. An update.

    -Scan the memory card with MS Security Essentials (this shows the file path of all the photos as E:\DCIM\101MSDCF\photos.jpg)

    Open "cmd", type e:\
    Ok. No files or folders apparently. dir => "File Not Found"
    "cd DCIM" works (!), "dir" => 101MSCDF is a folder option.

    Proceed to copy all folders off the card to the computer.

    Now, why the hell couldn't I see the base DCIM folder? I'm gonna reformat the card but would love to know why this was such a hassle. Virus?

    uean on
    Guys? Hay guys?
    PSN - sumowot
  • ApogeeApogee Lancks In Every Game Ever Registered User regular
    edited May 2010
    Maybe they were marked as hidden, and you don't have the 'show hidden files' option ticked? All I can really think of. Bizzare.

    Apogee on
  • SpacemilkSpacemilk Registered User
    edited May 2010
    I'm at work right now, but I'm pretty sure I have the same camera as you and I recently had the exact same issue. Blue dotting this for now, as you may have solved my recent camera woes, for which I would love you forever.

    See, my problem was that I could view pictures taken on my camera, but when I'd go to load them off my camera, my computer wouldn't recognize it at all. I tried a different USB cable, nothing. I hadn't tried just plugging in the card itself. HOWEVER, if I erased everything on my card and took a picture, then tried to upload the picture immediately, it worked. It's almost like the pictures deteriorate on my camera and make it so I can't download them if I wait too long (of course I never tried any middling period). In any case I don't want to run further experiments because I have a night of pictures that I really really want to save so I don't want to erase any more. :(

    Anyway I hope you found the problem! And fuck this camera, I think I might get a new one, this problem is not worth dealing with...

    Spacemilk on
  • stahstah Registered User
    edited May 2010
    Sounds like you got it figured out, so my suggestion is more to the nature of the problem.

    Without doing any research into the camera, I'm wondering it has a it's own software for removing and adding photos to the camera. If so, maybe it's their attempt at forcing you to use the software?

    stah on
  • imansiliconimansilicon Registered User
    in addition to what uean said:
    I write this down for people who have never used command prompt before:

    1- run cmd.exe on the start menu search field
    2- type: e: (or whatever drive name the memory card is attributed to. u can check it out on "my computer")
    3- type: dir/s (normal dir might not show everything, this one does)
    4- locate the directory (folder) of your photo files. (the mpg or whatever extension files location on the list)
    5- go to that directory: (e.g., type: cd DIR1\DIR2)
    6- type: c:
    7- make a directory in c: (e.g., type: md mycamphotos)
    8- type: e: (this takes u back to the DIR1\DIR2 directory
    9- type: copy *.* c:\mycamphotos

    The desired files are copied to that folder

  • Mr. PokeylopeMr. Pokeylope Registered User regular
    edited September 2012
    Do you have other devices or disks that are designated as the E:\? Could even be removable devices such as an other camera, flash drive, phone etc... that aren't currently plugged into the computer. If you do might want to try the following.

    Plug the camera back into the computer and then go to control panel->Adminstrative tools->Computer Management->Disk Management

    Find the camera on the list of disks and change the Drive letter of the camera to one not in use. If your not sure what to choose pick Z:\. If this is the conflict your computer should recognize the camera like normal.

    Mr. Pokeylope on
This discussion has been closed.