As was foretold, we've added advertisements to the forums! If you have questions, or if you encounter any bugs, please visit this thread: https://forums.penny-arcade.com/discussion/240191/forum-advertisement-faq-and-reports-thread/

Sluggish...

ANTVGM64ANTVGM64 Registered User regular
Howdy, my computer has felt...sluggish for the past couple of months. I've run CCcleaner, and anti malware, and also Defragged, and the problem persists. for example, this very page froze for a second at the "Post new Thread" line before loading everything else.

Another example is with video. I attempted to watch the 720p HD version of the Green Hornet Trailer, and it stuttered a bunch, when the PC I have at work plays it fine and is several years older.

This is a gateway p-6860 FX. It can run COD4 perfectly fine, but it stutters on the internet?

ANTVGM64 on

Posts

  • SeeksSeeks Registered User regular
    edited June 2010
    Might be a browser/flash problem. Check and see if you've got the latest Flash installed, and just for kicks, install another browser (be it Chrome/Firefox/Opera/whatever) and try web videos on that.

    There's also the nuke from orbit option, depending on how long you've gone since a reformat.

    Seeks on
    userbar.jpg
    desura_Userbar.png
  • DjeetDjeet Registered User regular
    edited June 2010
    Are you using IE 7/8? If so, disable all add-ons and only enable them when you need them (good chance the only one you'd "need" is flash, though the flash add-on is ... not great).

    Edit: If that doesn't help, try Hitman Pro. I got it from CNet and I've had luck using it when I'm not sure what else to do.

    Djeet on
Sign In or Register to comment.