Club PA 2.0 has arrived! If you'd like to access some extra PA content and help support the forums, check it out at patreon.com/ClubPA
The image size limit has been raised to 1mb! Anything larger than that should be linked to. This is a HARD limit, please do not abuse it.
Our new Indie Games subforum is now open for business in G&T. Go and check it out, you might land a code for a free game. If you're developing an indie game and want to post about it, follow these directions. If you don't, he'll break your legs! Hahaha! Seriously though.
Our rules have been updated and given their own forum. Go and look at them! They are nice, and there may be new ones that you didn't know about! Hooray for rules! Hooray for The System! Hooray for Conforming!

Steam not working

emp123emp123 Registered User regular
edited December 2013 in Help / Advice Forum
I have a ticket open with Valve, but since they work on Valve time I'll be lucky to get a response before the winter sale is over and Ive also asked in the Steam Thread but its understandably preoccupied with the winter sale as well so I come to you Help and Advice - my Steam isnt working properly. I have no idea why, since it was working fine in October when I disconnected my computer so I could move.

It looks like this:
http://farm8.staticflickr.com/7409/11459852086_bedfdb15a5_o.png

Games dont download (well, some do, Papers Please did, Bioshock and Far Cry 3 would not), when I tried deleting everything but steam.exe and steamapps to reinstall Steam my download kept losing data (would be at 30MBs, drop down to 12, download more and drop again and this would continue until I received an error telling me Steam needs to be connected to the internet to update). Now, I am on wireless, and I cant directly plug in to the internet to test wired internet, but Ive tried my home network (Comcast modem/router all in one thing) and tethering my phone (Verizon via FoxFi). When I tried to install Steam via Verizon my phone showed 270MBs downloaded when Steam was reading a total of 100MB download.

Ive updated drivers, Windows, and firmware. Ive run virus scans, CCleaner and Malwarebytes. I did determine this is a Windows 7 issue, since I still have Windows 8 RC installed on a partition and when I boot into Windows 8 Steam works just fine (looks fine, games download, etc). Ive also been having a similar issue with Battlelog in Chrome so Im not convinced this issue is with Steam itself, but Im not sure what could be causing it and why it would just randomly start happening.

Hardware Info:
Windows 7 Pro
Asus P8Z68-v Pro
Intel 2600k @ 4.5GHz
EVGA GTX 570
Corsair Force 3 SSD
Western Digital 1TB HDD
8GBs RAM

Heres a history of the things Steam Thread has suggested and things that Ive tried, but Ive basically summed it up pretty well.
emp123 wrote: »
emp123 wrote: »
emp123 wrote: »
DaringDirk wrote: »
emp123 wrote: »
DaringDirk wrote: »
emp123 wrote: »
emp123 wrote: »
emp123 wrote: »
Okay, my Steam is still being a piece of shit and doing this. Why

Okay, so I decided to opt into the beta client to see if it would resolve my issues...but now Im back to not being able to download the Steam client because it keeps losing progress and eventually tells me that Steam needs to be connected to the internet. I know this isnt an internet issue as Im not losing connection to anything else and Ive tried both my home wifi and tethering my phone to my computer and the issue persists. Im super tempted to just nuke this install from orbit and start over, but Im pretty lazy and my Windows 7 disc is like 500 miles away.


I just want Steam to work :(

EDIT: And according to my phone, I downloaded 270MBs in an attempt to download the 89 required for the Steam update.

So my tale of woe continues:
I cant download games. Well, I can, but they dont. I bought Far Cry 3 and so far its downloaded 9kbs. Ive run CCleaner, Ive manually deleted references to Steam in regedit, Ive tried running in compatibility mode, Ive tried restarting, and opting into the beta...I dont know what else to do :(


EDIT: Now that I think about it, I downloaded Papers Please last night (or the night before) so I dont know what the fuck is up with Far Cry 3 not working.

@emp123, stupid question, but have you changed your Steam location to different servers? Also, in Control Panel, Internet Settings, Connections, LAN Settings, make sure ALL THAT SHIT is unchecked, then try again.

Yeah, Ive switched to a couple of servers in the area and it didnt resolve anything. LAN options were all unchecked already.

Thanks for the help though.

I dont think its an internet issue since the images in the store page arent properly displaying, but Im not sure what could have caused it.

Try the TCP loading option for your Steam shortcut: https://support.steampowered.com/kb_article.php?ref=5623-QOSV-5250

That didnt fix anything either :(

I also just updated (after the issues began) my SSD's firmware, even though Steam and most of my games are on a mechanical drive. Im running the most recent Nvidia drivers, but Im starting to think there may be a correlation between when I installed those drivers and now, but Im also thinking Internet Explorer may have fucked something up (I had to use IE to launch Battlefield 4 as Chrome got all fucking (kinda like Steam actually)).

EDIT: Im gunna give the Nvidia beta drivers a shot.

Im also seeing issues with some things Ive downloaded off the internet, namely downloading Steam from Steam's website gave me a file I couldnt install because its corrupt.
@DaringDirk

My Steam folder continues to set itself to read-only, but Ive determined whatever my issue is it only applies to Windows 7 - I have a Windows 8 partition and just installed Steam no problem and its currently downloading both Far Cry 3 and Bioshock. Unfortunately its the Windows 8 RC and I have zero desire to boot into it every time I want to play a new game.

While Windows 7 virus scan and Malware whatever both didnt find anything when I was in Windows 7, Im running them in Windows 8 just to be sure.



I should probably spin this off into its own H/A thread.

Is your Steam stuff in a folder like My Documents, or something?

Windows 7 is on an SSD, Windows 8 is on one partition of a 1TB hard drive, steam games are on another.

camo_sig2.png
emp123 on

Posts

  • Sir CarcassSir Carcass I have been shown the end of my world Round Rock, TXRegistered User regular
    Try deleting everything in your Steam folder except the steamapps folder and steam.exe, then run the exe.

  • emp123emp123 Registered User regular
    I tried that first and the download was super weird, it would download for a bit and then 'lose' data. Like, it would download 12MBs, drop down to 4, continue downloading past where it was and then lose more data eventually giving me an error telling me that Steam needs to be online to update, even though I wasn't losing Internet connection.

    camo_sig2.png
  • MichaelLCMichaelLC In what furnace was thy brain? ChicagoRegistered User regular
    Not ideal, but you can at least serve the Newell through their phone app.

    Though it sounds like you have another partition which can run it at least temporarily.

    Mugsley wrote:
    So now I need to get it trimmed and adjusted, and all in.

    Steam:MichaelLC
  • SteevLSteevL What can I do for you? Registered User regular
    When you mentioned in the previous thread that it kept marking the Steam folder as read-only, I thought that was the obvious problem. But I checked my Steam folder just now and it's also marked read-only! I'm also using Windows 7, and having no issues. That's a really weird issue.

  • emp123emp123 Registered User regular
    Yeah, it's super odd. It was working fine like last week and it works fine in Windows 8.

    Maybe it's because I'm low on hard drive space, but if that was the case I don't think it would work when I'm booting in Windows 8.

    I could deal with the shitty images since yeah, website and phone app, but not being able to download the games I buy is rough, especially since my free time is super limited. At least the download in Windows 8 RC, play in Windows 7 will work for now.

    Although I must say this IT Professional game sure has amazing graphics even if the game play kind of sucks.

    camo_sig2.png
  • emp123emp123 Registered User regular
    Bit of an update:
    I reformatted my SSD and reinstalled Windows 7. I then installed Steam (by downloading the installer off Valve's website) on a fresh secondary hard drive, but the issues persist. Its super super weird. The only thing that changed between October when I took my computer apart and December when I put it back together was that I now have to be on wifi.

    Im going to try Windows 8 tomorrow since Steam seems to work fine on Windows 8 RC.

    camo_sig2.png
Sign In or Register to comment.