As was foretold, we've added advertisements to the forums! If you have questions, or if you encounter any bugs, please visit this thread: https://forums.penny-arcade.com/discussion/240191/forum-advertisement-faq-and-reports-thread/

Possible RAM/Paging Issue

Hi guys,

This is my first ever post in this section, and hopefully it'll be my last.

So I've been playing games on this laptop more than usual the last couple of weeks and I'm running into an odd problem.

I've played quite a bit of many games, but in particular Tomb Raider, Costume Quest and Lego LOTR (noted only because all three differ in terms of requirements) about an hour into my session I get a popup that prompts me to close the program due to low RAM. I have NO other programs running in the background and I have a 1GB video card and 8 GB RAM.

I can ALWAYS ignore this message and go back to playing with zero lag or problems. However, sometimes I get a forced closure from Windows (or other programs stop working or close) due to being critically low on memory.

After playing Costume Quest, I got the error "page fault in nonpaged area" that forced me to restart the whole machine.

I'm hoping this is some hiccup or setting. I've made sure that windows is managing my paged memory, but due to talking about this in the steam thread, apparently it is setting a bizarrely high amount of memory to my page file. Currently windows has it at 8083MB.

I hope this isn't a RAM failing issue. Help!

Posts

  • LD50LD50 Registered User regular
    When this starts to happen, open up the task manager and click the processes tab. Hit the 'show processes from all users' button if you're using vista or above, and then sort the list by memory. Take a look at what program is eating up all of your ram. If you're not sure, feel free to take a screenshot and post it here for us to look at.

  • stevemarks44stevemarks44 Registered User regular
    So after running memtest and doing what you suggested, I've realized this is simply an obnoxious windows message. I have 8gigs of RAM and it seems to trigger the message any time I hit 50% memory usage.

    Dumb.

  • Donovan PuppyfuckerDonovan Puppyfucker A dagger in the dark is worth a thousand swords in the morningRegistered User regular
    What version of Windows are you running? 7, Vista, 8? 64 bit or 32 bit?

  • stevemarks44stevemarks44 Registered User regular
    8.1 64 bit.

    The only time I really had a major problem was after playing Tomb Raider, which is the most graphically intense game I've ever run on this laptop. I was also running Chrome and Spotify in the background.

    Now I'd just like to find a way to disable this error message.

    Thanks for all the help, guys and gals.

  • Donovan PuppyfuckerDonovan Puppyfucker A dagger in the dark is worth a thousand swords in the morningRegistered User regular
    Hmm. I was hoping this would be a simple slution like your OS being 32 bit and thus having some conflict with using more than 3.2 gigs of RAM.

    There was an old Celeron laptop at my last job that did this all the time on a 64 bit OS, and the shitty way I "fixed" it was to set a custom pagefile size of 16384 MB minimum and maximum size. 16 gigs of pagefile on a system with 4 gigs of RAM might seem a bit much, but hell, 8 gigs of paging didn't fix the problem.

    stevemarks44
Sign In or Register to comment.