As was foretold, we've added advertisements to the forums! If you have questions, or if you encounter any bugs, please visit this thread:

USB Wireless adapter suddenly won't work after reformatting.

DigitoDigito Registered User regular
Alright, this one's got me stumped. So I recently reformatted my computer and afterwards, my primary USB Wireless adapter of choice, a TP-Link TL-WN722n has completely ceased functioning. Which is weird because my other two adapters, a Linksys AE3000 and one of the super tiny Belkin's I forget the name of offhand work no problem. However, they don't give me a terribly stable connection in my new room (good enough to use the internet, not good enough to play games) while the TP-Link worked amazingly well, giving me both the most reliable and fastest connection.

Now this is where it gets a little weird. The specific problem is that when I plug it in, literally nothing happens. Windows doesn't see any new devices, there's no "You just plugged in a USB device!" sound, and the device manager will not pick it up even if I refresh it or reboot the computer. It literally will not acknowledge a device has been plugged in and it does this regardless of what slot I plug it into while the other two work straight away. Even installing the drivers in advance doesn't work, as the driver installer is unable to see the adapter is plugged in. Installing the drivers regardless doesn't seem to fix the problem either. But the kicker? It works fine plugged into any other machine in the house. The only one that won't recognize it is my computer, and it worked flawlessly before the reformat, mine is the only one is simply will not work on. Windows has been fully updated again so I don't think it's some update I missed either.

Knowing my usual trend with computer issues the cause is probably something simple I've overlooked, but I'm drawing a blank right now. Anyone got any ideas?

EDIT: Just as an aside, if anyone might also happen to know why my AE3000 (Supposedly a pretty high end wireless adapter) pulls dismal speeds and has a horribly unreliable connection even when practically on top of the router, that'd be pretty nice too. It's always baffled me as to why a 40 dollar adapter can't seem to pull more than 3Mbits down with a connection that drops every five seconds while a 15 dollar micro adapter can hit 13 with perfect stability in the same location.

EDIT 2: This just became a moot point in rather grand fashion. I was taking the adapter to the living room in order to try it on a friends computer there when the cat came running past chasing a bug that had made it inside of the house. Cat rounds the corner at the same time I am, cat gets between my feet, I have a brief skirmish with gravity in which I lose miserably. The cat is fine and purring away contentedly on my desk right now, the adapter is in a fairly large number of not so large pieces, and the bug I believe has escaped, bringing this tale to a rather abrupt close.

Now if only my cat would stop looking so cute so I could be mad at her for more than five seconds.

Digito on


  • AVAVTAVAVT Registered User new member
    I think your cat is mad because her servant was busy doing some peasant work all day and forgot to take care of her majesty. If you realize your sin, apology properly and offer some sacrifices she might consider giving you a less painful death tonight.

Sign In or Register to comment.