No Audio Devices are Installed

So in the past 3 days, I've gone from having audio and using my headset to communicate on Steam or whatever, to no audio playback or input at all.

I first noticed an issue after using Mumble for the first time, though I'd installed it over a year ago. When I used it, everything was fine, but the day after I used it, I couldn't get my microphone to work. I also didn't have sound coming out of my computer at first, but I uninstalled and reinstalled the driver for my soundcard, and it worked fine for that day. The next day, nothing worked at all. Under Sound in the control panel, it says "No audio devices are installed." Under Device Manager, I saw my soundcard, and onboard sound, and all of these say "The device is working properly."

So I reseated my soundcard, and got no improvement. Then I took the soundcard out entirely, and uninstalled all drivers and software, and still have no improvement. With onboard audio only, it still says "No audio devices are installed" under Sound from the Control Panel, though I still see the devices and they are still "working properly" under the device manager.

Any ideas for where to go next? I can't think of what the next step could be.

For reference, the soundcard is a Soundblaster X-Fi something or other that I've had for 6 years, and the computer is one I built last year which got the soundcard from a previous machine. Until this week it worked perfectly. Also, I'm on Windows 10, though I was on windows 8 when it started and I thought upgrading might make some kind of difference, though it didn't change anything. I also got a mechanical keyboard, a Ducky Shine 4 this past weekend, but that doesn't have any related software.

Thanks!

Posts

  • BigityBigity Lubbock, TXRegistered User regular
    Go into device manager and delete the card, then do a hardware scan. That fixed my audio weirdness in Win10.

    76561198017303226.png
  • BigityBigity Lubbock, TXRegistered User regular
    Also, did CL release drivers yet? I think I remember them being way behind.

    76561198017303226.png
  • IcemopperIcemopper Registered User regular
    Bigity wrote: »
    Go into device manager and delete the card, then do a hardware scan. That fixed my audio weirdness in Win10.

    I tried that for both the sound card and then the realtek audio, but neither worked. I also restarted Windows Sound in services, but that also had no change.

    I'm going to boot Ubuntu from a flash drive today to find out if it is more a hardware problem.

  • IcemopperIcemopper Registered User regular
    edited August 2015
    Yeah, I booted Ubuntu from USB and the sound worked just fine on my motherboard and my soundcard, so something is up with Windows. Is there a way to install just the Windows Sound service?

    What's odd, and I only just noticed, is that I get system sounds out of it. I can pull up the volume mixer and test the sound, and get a response. I still see "No Audio Devices Installed" under the Playback tab, and I still get no audio from iTunes or Chrome.

    Icemopper on
  • tsmvengytsmvengy Registered User regular
    Right-click on the speaker in your taskbar and go to Playback Devices
    See what's listed
    Right-click in that windows and make sure "Show Disabled Devices" and "Show Disconnected Devices" are both checked.

    steam_sig.png
  • IcemopperIcemopper Registered User regular
    Both are definitely checked, but still nothing shows up. Here's what I'm seeing:

    DXtES07.png

Sign In or Register to comment.